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NOTE TO USERS

LABVIEW DATALOGGING AND SUPERVISORY

CONTROL MODULE NOTES FOR BRIDGEVIEW
USERS

Welcome to National Instruments LabVIEW Datalogging and Supervisory
Control (DSC) module, the next generation of BridgeVIEW.

National Instruments brings you this powerful tool for handling high
channel count applications, as well as for supervisory control of a wide
variety of distributed systems as a fully compatible upgrade path for
BridgeVIEW, the National Instruments industrial automation version of
LabVIEW. The LabVIEW DSC module takes the best of the BridgeVIEW
tools and integrates them into LabVIEW as a powerful module, opening
a path for future innovations in logging your data and supervising your
networked system.

Your BridgeVIEW applications will run under the LabVIEW DSC module
with no more conversion than the ordinary mass compilation necessary
under any major version change of LabVIEW. Refer to the Converting VIs
section for detailed information about how to convert your VIs to
LabVIEW 6.1.

This is “change documentation,” describing changes and features in the
LabVIEW DSC module to help you get up to speed quickly. It assumes that
you are familiar with LabVIEW 6.1 and with BridgeVIEW 2.1 or greater,
and is not necessarily as complete as the formal documentation.

Refer to the LabVIEW Datalogging and Supervisory Control Module
Release Notes for installation instructions and for last-minute changes,
corrections, and material that was not available for the printed manuals. For
complete discussions of LabVIEW DSC module features and functionality
in context with the complete software package, consult your printed
documentation and online help.

™

™
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If you are upgrading from BridgeVIEW and are about to run the LabVIEW
DSC module for the first time on a Windows 2000/XP system, consult the
Compatibility and Industrial Automation Server Strategies section for
information about using certain servers under Windows 2000/XP.
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Installing the LabVIEW Datalogging and Supervisory
Control Module

Before you install the LabVIEW Datalogging and Supervisory Control
module you must have already installed LabVIEW 6.1.

Note If for any reason you reinstall LabVIEW 6.1 after installing the LabVIEW DSC
module, you should also reinstall the LabVIEW DSC module after completing the
LabVIEW reinstallation.

Perform the following steps to install LabVIEW and the LabVIEW DSC
module:

1. Insert the LabVIEW 6.1 CD in your CD-ROM drive.

2. Run the installer as follows:

a. If your computer system has the AutoPlay feature enabled, the
installation will begin automatically.

b. If your system does not use AutoPlay, run the following program:

x:\setup.exe

where x is the letter of your CD-ROM drive.

3. Follow the onscreen instructions.

4. Reboot your computer. You must reboot your computer after installing
LabVIEW 6.1 and before installing the LabVIEW DSC module.
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5. Insert the LabVIEW DSC module CD in your CD-ROM drive.

6. Run the installer as follows:

a. If your computer system has the AutoPlay feature enabled, the
installation will begin automatically.

b. If your system does not use AutoPlay, run the following program:

x:\LabVIEW DSC Setup.exe

where x is the letter of your CD-ROM drive.

7. Follow the onscreen instructions.

8. Reboot your computer.

Required System Configuration
You must have LabVIEW 6.1 or greater installed on your computer before
you install the LabVIEW Datalogging and Supervisory Control module.

Note If for any reason you reinstall LabVIEW 6.1 after installing the LabVIEW DSC
module, you should also reinstall the LabVIEW DSC module after completing the
LabVIEW reinstallation.

The LabVIEW DSC module runs on any system that supports
Windows 95/98/2000/XP and Windows NT 4.0. A minimum of 32 MB of
RAM and at least 60 MB of free disk space (for the system to use as
swap space) is required for this version to run effectively. We recommend
128 MB of RAM and at least 127 MB of swap space available on your
system. Increasing your computer resources will have a significant effect
on performance of the LabVIEW DSC module.

Compatibility and Integration
The LabVIEW DSC module is part of National Instruments long-term
effort to more closely integrate our software tools to make systems
integration easier and more efficient. In particular you will find that the
LabVIEW DSC module is more closely integrated with Lookout, National
Instruments HMI and industrial process control software, and hardware
devices such as National Instruments FieldPoint.

Toward this end, the LabVIEW DSC module makes use of the Logos
communications protocol, an internal National Instruments technology for
rapid and reliable transmission of data across your network and between
applications running on one computer. You will occasionally encounter the
term Logos in data addressing and browsing activities, and may find the
term used in URLs for data connections.
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Except for the appearance of the term in certain dialog boxes and data
locators, you never interact directly with Logos.

Getting Started with the LabVIEW DSC Module
As a former user of BridgeVIEW, you will find some elements of
the LabVIEW DSC module familiar. Some of the features are not in
BridgeVIEW and others have changed. A quick tour of the changes
should make your transition to the LabVIEW DSC module easier.

One of the first changes you will notice is the reorganization of the Project
menu item into a Tools menu. LabVIEW DSC module tools are
concentrated in the Datalogging & Supervisory Control menu item,
as shown in the following illustration. Notice that the submenus,
Security, and Advanced are shown in their expanded form on this
illustration as well.

Most of the items have the same or similar names as their BridgeVIEW
counterparts. You will find some interface changes, though, as well as
improved performance and ease of use.

Major changes have taken place in security, in the HMI wizard and how
it works, in compatibility with National Instruments Lookout, in historical
trending, and how you use the Citadel historical database.
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Other changes have taken place internally, out of view from the user level,
as changing technologies have been incorporated into LabVIEW and the
LabVIEW DSC module tools, but care has been taken to ensure interface
and operational compatibility with your BridgeVIEW applications.

Logging Data
The LabVIEW DSC module uses a newer version of National Instruments
Citadel database. Consult the LabVIEW Datalogging and Supervisory
Control Release Notes for detailed information on maintaining continuity
of data when you upgrade from BridgeVIEW to the LabVIEW DSC
module.

Set Your Palette
You can customize your LabVIEW palettes to display the controls and
functions you most often use. The active palette should have been set to
display the LabVIEW DSC module palettes when you installed the module.
If it was not, or if you have done other LabVIEW component installations,
you may need to select the active palette yourself.

If your palette is not already set to stay visible on the screen, fix the palette
to the screen by clicking on the push-pin, and the palette buttons will
appear. Click on the Options button, as shown in the illustration to the left
and select the Datalogging & Supervisory Control option for all your
LabVIEW DSC module controls and functions to appear in your palettes.

For more information on customizing your palettes, consult your
LabVIEW documentation.

Tag Utility Toolbar Feature
The LabVIEW DSC module features a floating toolbar to give you quick
access to the most frequently used tag utilities without needing to go
through the menu tree.

Activate the toolbar by selecting Tools»Datalogging & Supervisory
Control»Show Toolbar. Click on the appropriate button to activate the
tool you want to use.
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Working with Tags
Tags are how the LabVIEW DSC module keeps track of your data. As a
former BridgeVIEW user, you are familiar with tags and how they are used.
You will use tools for working with tags in essentially the same way you
used the BridgeVIEW tools.

Tag Name Control
The Tag Control is located on the I/O subpalette of the LabVIEW Controls
palette.

Connecting to Tags Across the Network
Using tags across a network has been made much easier with the LabVIEW
DSC module.

When you browse for tags, or to find servers when you create and configure
tags, or to select a DataSocket data source, you will see some variation of
the view in the left column of the following window.

As you can see, navigating to data is a matter of finding the data source
(such as LabVIEW, Lookout, or certain servers) on your own computer
or on your network.
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To find tags or data on another computer, you must first register the
computer. You can register computers through the Tag Configuration
Editor, the Tag Monitor, or through the LabVIEW DSC module options.

• In the Tag Configuration Editor, select Configure»Network»
Registered Computers.

• In the Tag Monitor, right-click on the Network node and select
Register Computer.

• From LabVIEW, select Tools»Datalogging & Supervisory
Control»Options and click on the Advanced tab, selecting
Registered Computers from the options.

Note In order to register or unregister a computer, you must be logged in as Administrator
or with administrator privileges (that is, your user account must be a member of the
Administrator group).

Refer to the Register and Unregister Computers section in this document
for more information about registering and unregistering computers.

Importing Network Tags
You can import tags into your local LabVIEW DSC module .scf file from
a .scf file located on another computer. Open the Tag Configuration
Editor and select File»Import Network Tags. The following dialog box
appears.
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With this you can browse to a .scf file on any computer on your network,
and import tags from that file into your local .scf file.

You can also use this dialog box to import tags from a remote computer
using BridgeVIEW 2.x networking. This option is provided for
compatibility with BridgeVIEW 2.x networking, but we recommend
converting to the latest National Instruments Logos networking when
possible.

You can also access this option in the Tag Configuration Editor with
BridgeVIEW compatibility pre-selected by selecting Configure»
Network»BridgeVIEW 2.x Networking»Import Network
Configuration.

Configuring Tags
The Tag Configuration Editor has been streamlined and made more flexible
and efficient. When you invoke this tool, the following screen appears.

The first three icon buttons create, open, or save a new tag configuration file
(.scf). Use the next two buttons to start and stop the Tag Engine. Use the
next four to invoke the tag wizard, create a new tag, or edit, copy, or delete
existing tags. Use the last four buttons to launch the Tag Monitor, launch
HTV, create a new VI, or exit the Tag Configuration Editor.



LabVIEW DSC Module Notes for BridgeVIEW Users 10 ni.com

The Tag Configuration Editor menu items are much the same as they were
in BridgeVIEW, with a few exceptions, including some relocated items, as
listed below:

• File»New VI

• Edit»Column setup

• Configure»Security

• Configure»Network»Registered Computers

• Configure»Network»Time Synchronization

• Configure»Network»Convert Network Protocol

• Configure»Network»BridgeVIEW2.x Networking»Allow
Network Access (relocated from Configure»Allow Network Access)

• Configure»Network»BridgeVIEW2.x Networking»Clients have
Write Access (relocated from Configure»Clients have Write
Access)

• Configure»Network»BridgeVIEW2.x Networking»Import
Network Configuration (relocated from the File menu)

• Configure»Network»BridgeVIEW2.x Networking»Configure
Network Access (relocated from BridgeVIEW Project Menu)

• Window

• File»Exit LabVIEW (Choose Close to exit the Tag Configuration
Editor, and Exit LabVIEW to quit LabVIEW.)

Tip As an additional convenience, you can create a new tag through the HMI Wizard as
well as in the Tag Configuration Editor. Right-click a front panel object and select
HMI Wizard from the shortcut menu to launch the HMI Wizard.

Column Setup
Selecting Edit»Column Setup invokes the Select Tag Fields to View
dialog box. You can display the same columns of information as in the
spreadsheet import/export options in the Tag Configuration Editor. Use the
Select Tag Fields to View dialog box to set which columns are active by
adding or deleting tag attributes to or from the Fields to View window.
Highlight the tag attribute category you want and click on Add or Delete
to customize your view.
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You can change the order of appearance of columns by selecting a given
column heading and moving it up and down on the list by clicking the
appropriate button, or by selecting a column heading and dragging it to the
position you want it to occupy.

Tag Security
The LabVIEW DSC module implements permission-based security for
tags. Selecting Configure»Security in the Tag Configuration Editor
displays the following dialog box.

Notice that this box has two tabs: SCF File Access and Network Data
Access. Both of these tabs allow you to configure a different aspect of
security.
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When you select the SCF File Access tab, you are setting security on the
.scf file itself, specifically setting who can edit a given .scf file. This
permission is part of each .scf file, and can vary from file to file.

When you select the Network Data Access tab, you set who will have
access to data. Security settings here determine who can and cannot
connect to tags configured in a .scf file. The settings you make here are
specific to a given .scf file, and can vary from file to file. All tags in a
given .scf file inherit the settings you make in this tab, except for any tags
you edit security settings for individually. (As noted elsewhere in this
document, you must use the same lookout.sec file on all your network
computers for network security to work properly.)

When you click on the Edit button on the SCF File Access tab, the
following dialog box appears.

The large field in the center of this dialog box lists the groups and user
accounts that have permission to work with the .scf file shown.
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To remove a permission, select it and click on Remove. To change the
extent of the permission, select it and choose from the options in the Access
listbox. To add a new user or group to the permissions, click on the Add
button. The following dialog box appears.

Highlight the user or group you want to add and double-click on it (or click
the Add button). Set the Access Rights, and click the OK button when you
are finished.
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The Network Data Access option of the Access Rights Configuration
dialog box is shown in the following illustration.

You can configure two levels of network security: host access and user or
group access. The Host Access List controls whether or not a particular
computer can access data on your computer, no matter who is logged on.
You can also grant or deny access to specific users and groups.

Clicking on Edit invokes the following dialog box.
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As with the other options, you click on Add to add permissions for
accessing the data configured in the selected .scf file.

You can also configure the host access—meaning you can set which
computers on your network can access the data configured by the active
.scf file. To set computer access, click on the Configure Host Access
button. You can also open this dialog box directly from the Network tab
of the Access Rights Configuration dialog box by clicking on the Hosts
button in that dialog box. In either case, the following dialog box appears.

In BridgeVIEW you accessed this dialog box by selecting
Project»Configure Network Access. This dialog box functions the same
way the BridgeVIEW version did, adding the capability to browse the
network for computers you want to permit or deny access to individually.

You can use the asterisk wildcard to enable or disable all computers or
all computers in a set. For instance, entering *.yourdomain.com would
select all the computers with that domain address. This is the same syntax
used in the LabVIEW VI Server TCP/IP Access section of the LabVIEW
options. Consult your LabVIEW documentation for more information on
how LabVIEW uses host names.
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If you are uncertain of the computer names you want to allow or deny
access to, you can browse the network and select individual computers
by clicking on the Browse button. The following dialog box appears.

Click on the network node to expand the network view, and select the
computer you want to allow or disable access for. Click OK to add this
computer to your access list.

If you have enabled BridgeVIEW 2.x networking in your Tag
Configuration Editor (by selecting Configure»Network»BridgeVIEW
2.x Networking»Allow Network Access), it enables the Advanced button
on the Configure Network Access dialog box. Clicking on this button in
the dialog box pops up the following two-tab dialog boxes that function in
the same way they did in BridgeVIEW 2.x.
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Note These settings only apply to BridgeVIEW 2.x networking.

Register and Unregister Computers
Refer to the Registering Computers section of this document for detailed
instructions about how to register and unregister a computer. Access this
option in the Tag Configuration Editor by selecting
Configure»Network»Registered Computers.

Convert Network Protocol
This option converts the .scf file currently loaded in your Tag
Configuration Editor from using BridgeVIEW 2.x network tags to using
LabVIEW DSC module Logos tags.

Access this option by selecting Configure»Network» Convert Network
Protocol.

Windows
All open LabVIEW windows appear under this menu item, allowing you to
select the window you want to access next directly.

Tag and Alarm Monitoring
Tag monitoring in the LabVIEW DSC module has changed both in
appearance and in operation since BridgeVIEW. In addition to monitoring
tags, this tool also monitors alarms and events in a display in the bottom
right of the window. You access the Tag Monitor from the LabVIEW DSC
module by selecting Tools»Datalogging & Supervisory Control»
Monitor Tags. You can also launch the Tag Monitor from the Engine
Manager, as well as from the main LabVIEW window, the Tag Utilities
Toolbar, and other convenient locations.
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Monitoring Tags
As you can see, you navigate to the tags you want to monitor using the tree
in the left window of the Tag Monitor. There are several other features in
the Tag Monitor that follow from this innovation.

Not only can you monitor tags with the Tag Monitor, you can also view and
acknowledge alarms in the bottom right pane of the Tag Monitor.

You can see tags both directly in your local computer under the My
Computer node, and across the network, under your computer name
(PAROIKOS in this instance) under the Network node. You can also
see data from other National Instruments software and devices on other
network computers, such as the Lookout process running on the computer
named TRIPPER.

There are several ways to select tags for monitoring:

• Select, then drag and drop multiple items from the selection tree into
the monitoring window.

• Double-click tag to move it to the tag display window on the right.
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• Select a tag and right-click it, or select a tag or set of tags and then click
the Add button.

• Select the tags and press <Ctrl-A>.

You can save different tag monitoring selections for quick access.

The tag values and status update continuously, so the Trigger Tag setting
used to update values in BridgeVIEW is no longer necessary, and has been
removed from the Tag Monitor.

There is no longer a timeout setting in the Tag Monitor.

The Tag Monitor no longer displays the scaling units for a tag.

Status information for the tag is conveyed in the Quality column.

In the View menu, you can set a given computer or device (such as a
National Instruments FieldPoint module) as the root for the tree view in the
left window. Select Goto Host to enter the computer name or the IP address
you want to make the root for the tree view. Select Default to restore the
full tree.

Selecting View»Refresh refreshes the tree view and the alarm view at the
bottom of the window. (The tags in the tag window update continuously,
and do not need to be refreshed.)

You can add, remove, write to, or edit the properties of a tag by selecting
the tag and using the options in the Items menu. You can also right-click
on a tag to access these options.

Monitoring Alarms and Events in Tag Monitor
The alarm and event pane of the Tag Monitor window is the same Alarm
and Event Display control that has been added to the LabVIEW DSC
module controls. Refer to the Alarms and Events Control section of this
document for more information about using this feature.

Browsing Tags
The Tag Browser has been removed from the LabVIEW DSC module. You
can use the Tag Monitor to browse tags if necessary.
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HMI Wizard and DataSocket
One of the great changes in the LabVIEW DSC module is in how the HMI
wizard takes advantage of the power of National Instruments DataSocket
technology. The result is simpler code and more efficient execution.

The LabVIEW DSC module HMI wizard uses National Instruments
DataSocket technology to link your LabVIEW front panel object to data.
For more detailed information on using DataSocket, consult your
LabVIEW documentation.

When you use the HMI Wizard in an application, the wizard checks to see
if you have an Engine Status VI included in your block diagram. If you do
not already have that VI in your block diagram, the HMI wizard will create
a loop that will launch the Tag Engine when you run your VI. The loop
stops if the Tag Engine stops (unless you override its effects with other
program structures).

The actual changes in how you use the HMI Wizard are minimal. When you
right-click on a control or indicator in LabVIEW and select the
HMI Wizard, the following dialog box appears.

You can select a tag from the currently loaded .scf file, or you can click
on the Tag Configuration Wizard button and create a tag to connect to.
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If you choose to create a tag by clicking on the wizard, the following dialog
box appears.

Select the server or data source for the tag to which you want to connect
your control or indicator, and then either click OK or set the tag defaults as
you do using the Tag Configuration Wizard in the Tag Configuration Editor.

You can also make a memory tag. Click on the Memory Tag button and the
following dialog box appears.

Select the data type, enter the tag name, and click on OK to complete
creating your memory tag.
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To view the alarm configuration options in the HMI Wizard dialog box,
select Alarm Acknowledgement from the Attach control to: drop-down
menu. The dialog box to the alarms options as shown in the following
illustration.

The options in this dialog box have not changed. You set the alarm limits
when you configure your tag. Use the options in this dialog box to set how
your control or indicator will react when alarms are triggered.

Panel Wizard
The Panel wizard has been enhanced to give you control over the action of
the Boolean controls you use to control other front panels.

When you right-click on a Boolean control (such as a pushbutton) and
select Panel Wizard, the following dialog box appears.



© National Instruments Corporation 23 LabVIEW DSC Module Notes for BridgeVIEW Users

All the functions you are accustomed to in using the panel wizard are
located on the appropriate option tab in this dialog box. One change has
been made in the Polling tab options, and the items in the Button tab
are different in the LabVIEW DSC Module from BridgeVIEW.

When you click on the Button tab, the following options appear.

Checking Match button label to action changes the button label to match
the VI name you are using the button to call. If you are using the wizard to
invoke the login dialog or the Historical Trend Viewer, the label will reflect
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those choices. Checking the Match Boolean text to action does the same
for the boolean text.

The Mechanical Action options work the same way as the mechanical
action options available by right-clicking on a Boolean control in
LabVIEW.

There has been a change in the wording of one of the Polling options, as
shown in the following illustration.

The option shown as Until engine is shut down used to be presented
as While engine is running. The changed wording is a more accurate
description of what actually happens in the software.

If you run the calling VI while the engine is not running, the VI will poll
when started and continue to poll until the engine is started and then shut
down. If the engine is restarted after having stopped, however, the VI will
not resume polling until you restart the calling VI.

Tag Engine
The Tag Engine (the next generation of the BridgeVIEW engine) is how the
LabVIEW DSC module manages your data. The engine starts data servers,
logs data, handles alarm and event reporting, and maintains the real-time
database with the current values of your tags as well as alarm and event
status.

When the Tag Engine is loaded, an icon appears in the Windows Taskbar
tray (located next to the clock on your taskbar) as shown at left.You can
control the Tag Engine by right-clicking on this icon and selecting Stop
or Exit.
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Although the appearance of the Tag Engine Manager has changed, you use
it the way you always have, with all options having the same names.

Click on the minimize button to minimize the Engine Manager. If you close
the Engine Manager completely, you can access it again by right-clicking
on the Engine Manager icon in the Windows Taskbar tray and selecting
Show Details.

View Client Connections
You can see what computers are drawing data from your LabVIEW DSC
module applications. The Tag Engine must be running. Click on the View
Client Connections icon in the Tag Engine Monitor, and the following
dialog box appears.

This dialog box shows all the computers currently accessing data from your
LabVIEW DSC application. This dialog box does not automatically refresh
its display if the list of connected computers changes, so you do need to
click the Refresh button (or press <F5> on the keyboard) to see changes
in the list of computers accessing data from your local computer.
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Select the computer you want to check, and click on the Details button. The
following dialog box appears.

This dialog box does not display any tag values; it just shows the data being
accessed by the remote computer, along with information characterizing
the tags being accessed.

To see the current total of data updates (for example), you must close the
Connections for dialog box, refresh the Engine Host Connections dialog
box, and then check the details again.

Historical Trend Viewer
The Historical Trend Viewer has been updated for the LabVIEW DSC
module. The LabVIEW DSC module Historical Trend Viewer uses
improved networking and can retrieve data from both local and remote
sources. In addition, you are no longer restricted to viewing data currently
being logged by the engine, if running.

The Tag Engine does not need to be running for you to retrieve data from
your historical database. The Citadel service must be running on the
computer you are accessing data from, however.

You access the Historical Trend Viewer by selecting Tools»Datalogging &
Supervisory Control»View Historical Data. The user interface for the
LabVIEW DSC module version of the viewer is essentially the same as the
traditional BridgeVIEW interface.

Alarms and Events Control
The LabVIEW DSC module includes a control for monitoring and
acknowledging alarms and events. This tool improves networking and adds
other advanced features.

Located on the Alarms and Events control palette, the Alarm and Event
Display looks like the following illustration when you place it on a
LabVIEW panel.
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This display will show alarms and events from every computer and process
you configure it to display.

To monitor alarms from a process, you must first select the sources for
those alarms. When the VI is running, right-click in the alarm display
and select Select Processes. The following dialog box appears.

Navigate to the process you want to view alarms for, and select it, then
click on the Add button. Remove any processes you do not want to see
alarms for.

For the Alarm display to work, you must be monitoring at least one tag
from some process or VI (whether on your own computer or on a network
computer). Until you are monitoring at least one tag, you cannot select
which processes on your computer or on a network computer to monitor
for alarms and events. (The process or VI containing the tag you are
monitoring is automatically selected as a process for your alarms and
events window to monitor; you need not select it manually.)

Right-click on an alarm and select an acknowledgement option to
acknowledge that alarm, all selected alarms, or all alarms.
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You can filter alarms so you only see the alarms you are interested in. When
the VI is running, right-click in the alarm display and select Filter Options.
The following dialog box appears.

When you set filter options, only alarms that meet all your filter criteria will
be displayed in the alarm area of the Tag Monitor.

To monitor alarms with specific priorities, set the Min and Max values of
the Priority criterion.

Set User Name to restrict your alarm monitoring to alarms generated while
that particular user is logged on. You can only select one user name at a
time, but you can use wild card characters to widen the scope of the alarms
reported.

Set Ack User Name to restrict your alarm monitoring to alarms
acknowledged by that particular user. You can only enter one user name
at a time, but you can use wild card characters to widen the scope of the
alarms reported.

The Ack Comment filter restricts your alarms displayed to those with the
specified acknowledgement comment.

Set Object Name to restrict your alarm monitoring to alarms involving the
tag name you enter. You can only enter one name at a time, but you can use
wild card characters to widen the scope of those objects reported.

Note For Object Name filtering to work, your tag name must be a completely qualified
tag name, as displayed in the tag monitoring display above the alarm display.
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Set Description to restrict your monitoring alarms that meet your criteria.
You can only choose one description category at a time, but you can use
wild card characters to widen the scope of the alarms reported. The
categories HiHi, Hi, Lo, or LoLo are added as a prefix to any descriptions
and are ignored by description filtering.

Set Area Name to restrict your monitoring to the alarm area you choose.
You can only enter one alarm area at a time.

Use the Browse Areas button to locate and select the alarm area you want
to use as a filter.

You can choose to have the alarm display show alarms only, events only, or
both alarms and events by checking the appropriate box in the Show section
of this dialog box.

Use the parameters in the Old Alarms section to display alarms after they
have been acknowledged.

Select Audible Alarms to enable a sound alert when an alarm takes place.
The sound depends on your Windows system setting for error sounds.

If you are filtering alarms, any alarms that do not meet your filter criteria
do not show up in your alarm display.

Security
The LabVIEW DSC module uses permission based security. While you
can still use control level security and the Security VIs as you did in
BridgeVIEW for HMI controls, we recommend you begin using
permission-based security for your applications.

The mechanics of security in the LabVIEW DSC module have changed in
three important ways: logging in, security levels, and how you set up user
accounts.

Instead of logging in through the BridgeVIEW security menu, you log in
with LabVIEW’s User Name option. Refer to the Logging In section for
more information about logging in.

You create and maintain user accounts using the National Instruments User
Account Manager. You must be logged in under an account with a sufficient
security level to access this tool, with which you create different user
accounts and set different security levels for each user.

To access the User Account Manager, select Tools»Datalogging and
Supervisory Control»Security»Edit User Accounts.
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Because you cannot yet remotely configure security on distributed
LabVIEW DSC module applications, you must copy the security file from
your development computer to all other computers running LabVIEW (or
Lookout) applications that you want to use your user accounts with.

Note The National Instruments User Account Manager is a part of the continuing, long
term integration of National Instruments software tools. At this time the security file it
creates is called lookout.sec, located in the Windows System directory. The path to the
Windows System directory varies for different Windows versions. This is not just so your
LabVIEW DSC module applications can share data with National Instruments Lookout,
but also utilize the same security settings and user accounts.

The Security VIs that come with the LabVIEW DSC module have changed.
Refer to the Security VI Changes section of this document for more
information about these changes.

Logging In
Instead of logging in through a security submenu as you did in
BridgeVIEW, you log in with the LabVIEW User Name option.
Select Tools»User Name to invoke the User Login dialog box.

Refer to the Importing Your BridgeVIEW Security User Accounts section
of this document for instructions about how to import your BridgeVIEW
user accounts into the LabVIEW DSC module.

Security Levels
BridgeVIEW offered up to 255 security levels. LabVIEW DSC module
offers 11 ranging from 0 to 10, with 10 being the highest level.

The LabVIEW DSC module no longer depends on security levels,
however, and discourages their use. Instead, we recommend that you use
the access rights to configure access to controls and indicators, as described
in the Tag Security and Setting Security Access Permissions sections of this
document.
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When the National Instruments User Account Manager imports user
accounts from your copies of BridgeVIEW, it maps the security levels
as shown in the following tables.

Refer to the Importing Your BridgeVIEW Security User Accounts section
of this document for information about importing your BridgeVIEW
security levels into the LabVIEW DSC module system.

BridgeVIEW Default
Security Level

National Instruments
User Account Manager

Security Level

0 0

25 1

50 2

100 4

150 6

200 8

255 10

BridgeVIEW Security
Level Range

National Instruments
User Account Manager

Security Level

0 0

1–38 1

39–63 2

64–89 3

90–114 4

115–140 5

141–165 6

166–191 7

192–216 8

217–242 9

243–255 10
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Setting Security Access Permissions
You set security permissions on individual controls, for LabVIEW DSC
module tools, controls, and for tags. All permissions are set using the same
set of dialog boxes.

Set permissions for individual controls by right-clicking on the control
on the front panel of your LabVIEW application, and selecting Security.
To configure permissions for the LabVIEW DSC module tools, select
Tools»Datalogging & Supervisory Control»Options, click on the
Advanced tab, and select Security Preferences or Tools Access.
You configure tag security and network security through the Tag
Configuration Editor.

When you begin to configure permissions, the following dialog box is the
first to appear.

This illustration shows the name of the selected control and the currently
assigned permissions.
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To remove a permission, select it and click on Remove. To change the
extent of the permission, select it and choose from the options in the Access
listbox. To add a new user or group to the permissions, click on the Add
button. The following dialog box appears.

Highlight the User or Group you want to add and click the Add button.
Set the Access Rights, and click the OK button when you are finished.

National Instruments User Account Manager
You create individual accounts for operators and developers with the
National Instruments User Account Manager. Anyone whose account is
a member of the Administrators group can create, revise, or delete system
user accounts by selecting Tools»Security»Edit User Accounts. The User
Account Manager appears.
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Use the User Account Manager to create and edit the properties of groups,
create or edit the properties of user accounts, assign users to one or more
groups, and otherwise manage security for your Lookout and LabVIEW
DSC module applications.

Note For your user accounts to work consistently across your network, you must use the
same lookout.sec file for all your installed copies of Lookout or the LabVIEW DSC
module. After you have created your lookout.sec file, copy and replace the
lookout.sec file on each of the other computers you want to be able to use these user
accounts with.

Importing Your BridgeVIEW Security User Accounts
You can import your BridgeVIEW user accounts into the User Account
Manager. If it is not already running, open the National Instruments User
Account Manager by selecting Tools»Datalogging & Supervisory
Control»Security»Edit User Accounts. Then select User»Import
BridgeVIEW User Accounts. A dialog box appears asking you whether
the user accounts you want to import are from BridgeVIEW 1.0, 1.1 or
later, a BridgeVIEW 2.0 binary export, or a BridgeVIEW text export file.
Select the correct option to complete importing your user information.
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Creating User Accounts
To create a user account, select User»New User Account. The following
dialog box appears.

Enter the new user’s domain name in the Username field.

Enter the user’s Full Name.

You can use the Description field for job titles or other relevant
information.

Enter the user’s password in the Password field.

Enter the password a second time in the Confirm Password field to make
sure there was no typing error in the first entry.

Set the new user’s Security Level. Security levels range from 0 to 10, with
10 being the highest possible security authorization. Assign level 10 access
only to those people responsible for system security.

Minutes idle until logoff sets how long LabVIEW will run with no
operator interaction before logging the current user off automatically.
Setting this value to 0 (the default) means there is no timeout in effect.

The User Account Manager default is for passwords never to expire. You
can set an expiration time for passwords if you choose. Users cannot reset
their own password; a member of the Administrator group must set the
password for them.
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Select the Account Disabled checkbox if you want to disable a user
account without removing the user from the system.

Click on the Groups button to add this user to various local security groups.
The following dialog box appears.

The default groups are Administrators, Guests, Operators, and System
Operators. Any groups you have created are also shown.

To enter a user in a group, highlight the group in the Not Member of field
and click on the Add button. To remove a user from membership in a group,
highlight a group in the Member of field and click on the Remove button.

Note When you add an individual user who has a security level different than that of the
group, that user will have the higher of the security levels.

Creating Groups
To create a group, select User»New Local Group. The following dialog
box appears.
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Group Name assigns a name to your new group.

Enter a description of the group in the Description field.

Security Level assigns the security level for members of this group.

Note When you add an individual user whose individual account has a security level
different than that of the group, that user will have the higher of the two security levels.

To add Members, click on the Add button. The following dialog box
appears.

The List Names From listbox selects the domain to list user names from.
At this time, you are restricted to your local domain.

Highlight the names you want to add in the Names field, and click on the
Add button to add those users to your group.
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Modifying Users and Groups
The dialog boxes for editing users and groups are essentially the same as
those for creating users and groups. Open the User Manager, double-click
on the user or group you want to edit, or highlight and select
User»Properties. The following dialog box appears.

The User Properties dialog box displays information about user activity.
You use it as you would the new user dialog box.

Special Users and Groups
The National Instruments User Account Manager comes with several user
accounts and groups built-in. The user accounts include Administrator,
Anyone, Guest, and (nobody). The built-in groups include Administrators,
Guests, Operators, and System Operators. You cannot delete any of these
accounts, though you can edit the properties of some of them.

The Administrator account overrides all other security settings and has
access to everything in LabVIEW. This override extends to all accounts
added to the Administrators group.

You cannot delete the Administrator account or change its security level.
You can set the password and enter the name and a description of the
Administrator. You can also add or remove user accounts.
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The (nobody) account cannot be edited or deleted, and does not actually
appear as an account in the User Account Manager. This account is what
LabVIEW defaults to when no authorized user is logged on. It always has
a security level of 0.

The Anyone account is built in. You cannot delete this group in the User
Account Manager, and you can only edit the full name and description
(despite the asterisks in the password fields, you cannot create a password
for the Anyone account). When you first create an application, it is
configured with this account allowed full read and write permissions.

You can edit all the properties of the Guest user account and of the Guests,
Operators, and System Operators groups.

Configuring Startup VIs
In BridgeVIEW you could select a group of VIs to open automatically
when you launched BridgeVIEW. This capability has been relocated and
enhanced for the LabVIEW DSC module.

To configure startup VIs, select Tools»Datalogging & Supervisory
Control»Advanced»Startup VIs. The following dialog box appears.

Clicking the Add button opens a standard file open dialog box. Select the
VI you want to have open and click on the Show Panel and Run buttons to
set your behavior preferences.

Select a VI in the list to change its order of loading and change the behavior
options.
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If your startup VI runs without showing a panel, you must have the VI
open a reference to itself using for it to continue running. Refer to your
LabVIEW documentation about the LabVIEW VI Server for information
on how to have a VI open a reference to itself.

Options
You can set a number of different types of options in the LabVIEW DSC
module. You can customize the way your LabVIEW environment uses the
LabVIEW DSC module tools, set security access to the module tools,
register and unregister computers for networking, and time synchronize
computers on your network so your data time stamps are consistent from
computer to computer.

Select Tools»Datalogging & Supervisory Control»Options.
The following dialog box appears.

Environment
The Environment options control how LabVIEW works for you as a
development tool. These options include:

• Enabling error dialogs and displaying DSC module error messages

• Requiring LabVIEW to display a prompt screen when you exit if the
Tag Engine is running

• Forcing the Tag Engine to shut down when you exit LabVIEW

• Checking the default .scf file, and changing it if you choose
by clicking on the open file icon to the left of the display field
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• Stopping and restarting the Tag Engine automatically if the .scf file
is changed

• Confirming any change made in the default .scf file

Startup
There are three Startup options you can set as shown in the following
illustration.

These options include:

• Automatically starting the Tag Engine when LabVIEW runs

• Showing the Engine Manager when the engine runs

• Checking proxies when LabVIEW starts

Click on the Startup tab of the Options dialog box to access these options.
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Advanced
There are three categories of Advanced options you can set as shown in the
following illustration.

These options include:

• Having the Tag Configuration Editor preloaded and ready to run when
you launch LabVIEW

• Closing the Tag Monitor (if it is open) when you exit LabVIEW

• Closing the Image Navigator (if it is open) when you exit LabVIEW

• Registering computers for networking (must be logged in as
Administrator to enable this option)

• Setting time synchronization for your network computers (must be
logged in as Administrator to enable this option)

• Setting security access to the LabVIEW DSC module tools (must be
logged in as Administrator to enable this option)

• Setting Security Preferences (must be logged in as Administrator to
enable this option)

Click on the Advanced tab of the Options dialog box to access these
options.
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Registering Computers
You must register computers for easy transmission of data across your
network using LabVIEW, Lookout, and National Instruments FieldPoint
and other hardware. Click on the Registered Computers button in the
Options dialog box. The following dialog box appears.

To remove a computer from your list of registered computers, select the
computer and click on the Remove button. To add a computer to your list
of registered computers, click on the Add button. The following dialog box
appears.
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Enter the computer you want to access in the Computer Name field, or
browse for the computer in the network tree.

Click on OK when you are finished.

To unregister a computer in the Tag Monitor, right-click on it and select
Unregister.

Time Synchronization
To keep your data properly time stamped, you must make sure the times
on your computers are properly synchronized. The National Instruments
time synchronization service is installed as a service in Windows NT that
runs every time you run your computer. Time synchronization runs as a
background process in Windows 98/95.

Click on the Time Synchronization button of the Advanced options tab in
the Options dialog box. The following dialog box appears.

Any computer that is running the time synchronization service can serve as
a time server or a time client. The primary time server is the first computer
listed in the Time Server Search Order field.

Note You must make sure that the order of search for time servers is the same for all the
computers on your network you want to synchronize, including the primary time
synchronization server.

You do not need to include a computer running the LabVIEW DSC module
in its own list of time synchronization services.



© National Instruments Corporation 45 LabVIEW DSC Module Notes for BridgeVIEW Users

Suppose you have four computers you need to have synchronized. If one
fails, the others look for the next in line to synchronize to as time servers.
For computers A, B, C and D, you would use the following time server
search order in each computer.

As the primary time server, Computer A would have no other servers listed.
As long as Computer A is running, it should synchronize to itself.
Computer B should synchronize to Computer A as long as A is running.
If A is not running, B should synchronize to itself. Computer C should
synchronize to Computer A if it is running, Computer B if A is not running,
and to itself if neither A nor B is running. This pattern should be used for
all the computers you want in one synchronized set.

To change the order in which your computers search for a time
synchronization server, select the computer name and click on the Up or
Down buttons.

Use Sleep Time (seconds) to set how long each computer waits between
each synchronization. You should set the primary time synchronization
server sleep time to 60 seconds.

If your primary server is offline for some reason, a computer scheduled
to synchronize automatically seeks out the second computer on the
synchronization server list. At the time of the next synchronization, the
computer first looks for the primary server before seeking a secondary
synchronization server.

Note If you have some computers running Windows 98/95 and other computers running
Windows NT in your network, you should list your Windows NT computers first in the
server search list. Time synchronization works better between Windows 98/95 and
Windows NT systems when the Windows NT computer is the server.

Table 1-1. Time Synchronization Order

Computer A Computer B Computer C Computer D

None listed A A A

— — B B

— — — C
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To add a computer to the Time Server Search Order field, click on the
Add button. The following dialog box appears.

If you know the name of the computer you want to add, you can type it
into the Computer name field. If you do not know the exact name of the
computer, you can browse for it in the network tree contained in the Select
a Computer field.

To remove a computer from the Time Server Search Order field,
highlight the computer name and click on the Remove button.

If no computer is set as a primary time server, your computer synchronizes
to itself.
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Tool Access
You can limit access to most of the LabVIEW DSC module tools using the
Tool Access options. Click on the Tool Access button on the Advanced
options tab. The following dialog box appears.

As you can see, this dialog box allows you to set security permissions for
every major LabVIEW DSC module tool.

Click on the tab for the tool you want to configure permissions for, and then
click on the Edit button. The standard LabVIEW DSC module Access
Rights dialog box appears with the name of the tool you are configuring
permissions for displayed above the list of users and groups.
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Refer to the Setting Security Access Permissions section of this document
for more information about adding and removing users and groups in the
Access Rights dialog box.

Security Preferences
You can configure a number of security features using Security Preferences
options. Click on the Security Preferences button on the Advanced
options tab. The following dialog box appears.

Use these settings to configure how you want to logon when LabVIEW first
starts.
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Click on the Advanced tag of the security system settings to invoke the
following dialog box.

Use this option to disable the ability of on operator to use <Alt-Tab>
to switch between programs running on your applications computer.
The special keyboard driver is installed by default when you install the
LabVIEW DSC module.

VI Changes
Most of the VIs in the LabVIEW DSC module have not changed from their
BridgeVIEW versions. What changes there have been are in the form of
additional inputs or outputs.

Historical Data VI Changes
The Historical Data VIs have changed and expanded for the LabVIEW
DSC module, adding functionality and flexibility for logging capabilities.

The LabVIEW DSC module permits logging and retrieval of string tags.
These VIs function the same was as their Analog data counterparts. Consult
the LabVIEW context-sensitive help for guidance in using these VIs.

One general change has been made in the Historical Data VIs: you can use
URLs as well as tag names as the Tag input to the VIs.



LabVIEW DSC Module Notes for BridgeVIEW Users 50 ni.com

To use this feature you must set the tag control to use undefined tag names.
Right-click on your tag control to set this option.

In the past you would input a tag to the Tag Name input of a Historical Data
VI in order to specify what data point the VI was to access. If you choose,
you can input a URL instead. A URL is the way National Instruments
DataSocket and National Instruments Logos networking locate data.

The general form for URL DataSocket or Logos URLs is

\\computername\LabVIEW\tagname

or

\\computername\ProcessName\tagname

where computername is the name of the computer running the process
containing the tagname on your network and tagname is the name of the
data point you want to connect to.

When you are connecting to a data source in Lookout or in some other
National Instruments data source utilizing Logos networking, you use the
URL address element ProcessName, where ProcessName is the name of
the process containing the data point you want to connect to.

In BridgeVIEW, while the BridgeVIEW Engine was running you were
restricted to accessing data in the .scf file that was loaded. Once the
BridgeVIEW Engine was closed you could see all your tags. In the
LabVIEW DSC module, you can see tags in all your .scf files, whether
the Tag Engine is running or not.

If you use a URL input for Tag in addition to a data path for Citadel Path 
In, the LabVIEW DSC module will check in the directory specified by
Citadel Path In for your URL.

If you use a URL input for Tag while the Citadel Path In input is blank, the
LabVIEW DSC module uses the URL to locate your tagged data.

The Citadel Path Out output contains the URL for the data being
reported if the data is from a local computer. If the data is from a remote
computer, this output will be empty.

The Tag Engine does not have to be running on your local computer for the
Historical Data VIs to access information on your local computer. If you
are accessing data on a remote computer, however, the Tag Engine or a
Lookout process must be running for you to access the data.

The Data Type output returns the proper data type for analog and
string data.
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Security VI Changes
While your old BridgeVIEW security VIs will continue to work, the
LabVIEW DSC module features an array of security VIs. These VIs work
in much the same way as the BridgeVIEW security VIs, with a few changes
in terminology and scope. Help for using these VIs can be found in the
context help window of LabVIEW.

Compatibility Issues
Other than the need to recompile VIs when upgrading to a new version of
LabVIEW, there are no incompatibilities between BridgeVIEW 2.1 and
later and the LabVIEW DSC module.

If you are running processes on a computer running Windows 2000/XP, you
should install the IAS/IAK server patch before attempting to run your
applications. Refer to the Compatibility and Industrial Automation Server
Strategies section of this document for more information about running
IAS/IAK servers under Windows 2000/XP.

Converting VIs
Upgrading your BridgeVIEW VIs is an automated process. When you open
a VI created in a previous version, LabVIEW automatically converts and
compiles the VI.

Conversion is a memory-intensive operation. When LabVIEW opens a VI
saved in an earlier version (or in BridgeVIEW), it loads all components of
the converted VI (front panel, block diagram, and data) into memory, then
compiles the VI in memory. LabVIEW also loads into memory the
components of all subVIs that need to be converted.

To estimate the amount of memory required to convert VIs, total the
amount of disk space that your VIs and all of their subVIs occupy. If these
VIs are in VI libraries, add approximately 30 percent of the VI library size
to the total, because the VIs are compressed within the library. The
conversion process might require at least that total and an additional 3 MB
of memory.

If your computer does not have enough memory to convert your VIs all at
once, convert the VIs in stages, by components. Examine your hierarchy
of VIs and begin by opening and saving subVIs in the lower levels of the
hierarchy. Continue to the higher levels of the hierarchy. To convert a
directory of VIs, select Tools»Advanced»Mass Compile. However, this
option converts the VIs in a directory or VI library in alphabetical order. If
a high-level VI is encountered first, Mass Compile requires approximately
the same amount of memory as described in the previous paragraph.
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To monitor your memory usage, select Help»About LabVIEW. This
option summarizes the amount of memory that you are using.

Compatibility and Industrial Automation Server Strategies
Before Windows 2000/XP, National Instruments encouraged the use of
Industrial Automation Servers, sometimes referred to as IAK or IAS
servers. National Instruments furnished OPC servers as an alternative.

For reasons of compatibility with future versions of Windows, National
Instruments recommends that you use OPC servers, specifically the OPC
servers from NI-DAQ (includes SCXI), National Instruments FieldPoint,
and National Instruments Foundation Fieldbus OPC servers that come with
those products, and the Lookout Protocol Drivers OPC Server that use the
reliable, time-tested and field-proven Lookout drivers.

The Lookout Protocol Drivers OPC server is available from National
Instruments separately; contact National instruments for information
on purchasing this server and the accompanying drivers. This CD also
includes a patch allowing IAK (IAS) Industrial Automation Servers to
run under Windows 2000/XP. This patch is furnished to ensure backwards
compatibility only, without guarantee that those servers can be patched
to continue to work under future releases of Windows.

Refer to the Using IAS Servers Under Windows 2000/XP section of this
document for more information about IAS servers and Windows 2000/XP
compatibility issues.

Using IAS Servers Under Windows 2000/XP
If any of your applications use National Instruments Industrial Automation
Servers (also referred to as IAK or IAS servers), you must install a patch
for those servers to function correctly under Windows 2000/XP.

To install this patch, run the setup.exe program located in

x:\redist\IA Servers Patch\disk1

where x is the CD-ROM drive that contains the IAS patch. (While this
patch is not available on the LabVIEW DSC module CD, you can get it
from your BridgeVIEW 2.1.1 CD, or the most recent National Instruments
Industrial Automation Servers CD.)

Specifically, the servers requiring the patch for Windows 2000/XP are:

• Allen-Bradley (RSLinx)

• Applicom

• DirectNET
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• GE Fanuc Ethernet

• Mitsubishi

• Modbus

• Modbus Plus

• Omron Host Link

• Optomux

• Ppccom

• Siemens

The NI-DAQ OPC or National Instruments FieldPoint OPC servers do not
need updates to function in Windows 2000/XP, but we strongly recommend
that you use the most recent versions available.

We also recommend that you use the stand-alone NI-DAQ OPC or National
Instruments FieldPoint OPC servers with the LabVIEW DSC module
rather than the old IAK (IAS) servers.

If you are using the Lookout Protocol Drivers OPC Server, you should
update to the new version by installing it from the Lookout Protocol Drivers
OPC Server CD, available from National Instruments.

Advice for Future Development
While the patched IAK (IAS) servers are currently usable under
Windows 2000/XP, National Instruments cannot guarantee that future
versions of Windows will allow IAK (IAS) servers to run correctly.

National Instruments recommends that all your future development using
the LabVIEW DSC module use the National Instruments Lookout Protocol
Drivers OPC Server or the OPC servers for NI-DAQ, National Instruments
FieldPoint, and National Instruments Foundation Fieldbus.

Refer to the Converting Applications from IAK- to OPC-Based Servers
section of this document for more information about this topic.

Converting Applications from IAK- to OPC-Based
Servers
You can convert your applications from using IAK (IAS) servers into
applications using National Instruments Lookout Protocol Drivers OPC
Server instead. Included with the LabVIEW DSC module is a conversion
utility to aid you in this task.

Conversion is not a seamless process at this time. Because of LabVIEW’s
strict type checking along with choices you may have made in tag
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configuration, and differences in implementation of different server
drivers, some manual adjustments will probably have to be made in
your conversions. The amount and extent of manual corrections depend
on your particular applications. You should make sure to preserve backup
working copies of all applications you intend to convert so that your
operations can continue while you make all necessary manual corrections
in your converted processes.

To run the conversion utility, launch the Tag Configuration Editor and open
the tag configuration file (.scf) you want to convert. The Tag Engine
(which takes the place of the BridgeVIEW Engine in the LabVIEW DSC
module) does not have to be running.

From the File menu of the Tag Configuration Editor, choose Upgrade PLC
Drivers. Follow the instructions in the dialog box that appears.

The conversion utility may generate a list of error messages. At the end of
the conversion process, you can choose to save a record of those conversion
messages. These messages can be of great help in making manual
adjustments, so we recommend you save this record in a file so that you
can refer to them later.

Click on OK to complete the conversion process and save your .scf file.
You can then begin using the Tag Configuration Editor to make any manual
corrections necessary to your converted tags.

Note The drivers for the National Instruments Lookout Protocol Drivers OPC Server are
derived from National Instruments Lookout HMI/SCADA software. The documentation
for these drivers lists their connection points to PLC and RTU hardware as data members.
This term corresponds to the term items as used in the Tag Configuration Editor.

Making Manual Corrections to Converted Tags
In BridgeVIEW you were accustomed to configuring tags to use items from
the IAK (IAS) servers.

The conversion utility maps the items of your BridgeVIEW tags to National
Instruments Lookout Protocol Drivers OPC Server data members.

In some cases you may find that the Lookout Protocol Drivers OPC Server
data members are Boolean values where you had previously configured
them as integers. You may also find that there are some item names in your
previous tag configuration that cannot be mapped directly to data member
names in the changed server drivers. Examining the Lookout protocol
driver data members listed in the Lookout Protocol Drivers OPC Server
help file should help you resolve such incompatibilities.
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You will notice that instead of explaining how to build an item name
according to the published protocol of the PLC or RTU hardware, the data
member documentation features tables listing the ranges themselves and
characterizing the data members in those ranges as to data type, whether
they are read-only, write-only, or read-write. These tables also include a
general description of what that data member does.

Notice too that certain data members listed can be used to change the
parameters of the driver object itself (if you choose).

Using this data member documentation you can edit your tags as necessary
to manually fix any conversion difficulties.

More IAS Server Conversion Information
For information on National Instruments product updates and changes in
the future, point your browser to http://www.ni.com/.

To download the latest patches and drivers, see the National Instruments
Software Library at:

http://digital.ni.com/softlib.nsf/web/all+software
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