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Using This Guide

With SystemBuild™ menu options and this guide, you will soon be able to generate
high-quality design documentation automatically from SystemBuild block dia-
grams.

Organization

This guide provides the information you need to start using DocumentIt™, as well as
the more advanced details necessary to customize the generated design documenta-
tion. The summaries that follow will tell you exactly what to read for the task you
want to accomplish.

■ Chapter 1, Introduction, provides an overview of the Integrated Systems design
documentation generation concept, a description of the basic steps required to
produce documentation, and a brief example of documentation generation from
a SystemBuild model. This chapter, along with Chapter 2, will give you every-
thing you need to know in order to generate documentation using any of the
templates described in Appendix B through Appendix E .

If you want to create custom documentation, refer to Chapter 3 and the Related
Publications references provided later in this section.

■ Chapter 2, Invoking DocumentIt, tells how to generate documents from
SystemBuild, the Xmath Commands window, and from the operating system
command line.

■ Chapter 3, Customizing the Generated Documentation, points you to a detailed
explanation of template files (*.tpl ) for formatting a document. Integrated
Systems supplies DocumentIt templates (*.tpl files) for each of the examples
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given in Appendix B through Appendix E. You can copy the *.tpl files from
any of these examples and modify them using the information in this chapter.

■ Appendix A, DocumentIt Options, provides a description of the DocumentIt
options, and explains how to use an autostar.opt  file.

■ Appendix B, Generating Documents Using FrameMaker, provides a description of
how to generate a sample design document using DocumentIt and FrameMaker
templates.

■ Appendix C, Generating 2167A Documents Using FrameMaker, provides a
description of how to generate a sample design document conforming closely
with DOD-STD-2167A using DocumentIt and FrameMaker templates.

■ Appendix D, Generating 2167A Documents Using Interleaf, provides a
description of how to generate a sample design document conforming closely
with DOD-STD-2167A using DocumentIt and Interleaf templates.

■ Appendix E, Generating Documents Using Microsoft Word, provides a description
of how to use a template to create a general purpose document in Microsoft
Word.

■ Appendix F, Generating ASCII Documents, provides a description of how to gen-
erate a sample design document using a DocumentIt template.

This manual also has an Index.
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Conventions

This section describes the conventions used in this manual.

Font Conventions

Fonts other than the standard text default font are used as follows:

Format Conventions

This manual uses two special formatting conventions, one to present code and pro-
gramming examples, as well as sample procedures, and one to present sample in-
put/output.

Sample Procedures

Example 1 shows the formatting convention for sample procedures and code and
programming examples.

% Represents the C shell system prompt in command examples.

courier
font

Denotes directory names, file names, menu names, menu options,
commands, Template Programming Language (tpl) segments, syntax
statements, operators, and scope classes within text. This font type
is also used in programming examples.

italic Italic is used with the default font for emphasis and publication
titles.

courier
italic
font

Denotes placeholders in syntax examples.

courier
bold font

Denotes command-line input.

Bold Helvetica
narrow

Buttons, fields, and icons in a graphical user interface are set in bold
Helvetica narrow  type. Keyboard keys are also set in this type.

<hll> Single-letter abbreviation denoting a high-level language supported
by AutoCode: c (C) or a (Ada).

<HLL> Abbreviation for the full name of one of the two high-level languages
supported by AutoCode: C or Ada.
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EXAMPLE 1: Code, Programming, and Sample Input/Output Example Format

#include "XmathLNX.h"

extern void cosine_();

void myfun(nlhs, lhs, nrhs, rhs)
int nlhs, nrhs;
externType **lhs, **rhs;
{
   /* y = cos(x) */

   et_matrix *x, *y;
   x = (et_matrix*)rhs[0];
   y = AllocateMatrix(x->rows, x->columns, 1);
   lhs[0] = (externType*)y;
   cosine_(&x->rows, &x->columns, x->real, y->real);
}

static functionData fdata[] = {
   {"myfun", myfun, 1, 1, 1, 1, (char*)0},
   {0,0,0,0,0,0,0}
};

main(argc, argv)
int argc;
char **argv;
{
   XmathMain(argc, argv, fdata, 1);
   return 0;
}

Sample Input/Output

The formatting convention for sample input/output is shown in the next several
paragraphs.

Sample input is shown in bold and italic (used for placeholders):

makeproject projname

Sample output is shown in Example 1 above.
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Mouse Conventions

This document assumes you have a standard, right-handed three-button mouse.
From left to right, the buttons are referred to as MB1, MB2, and MB3. All instruc-
tions assume MB1 unless otherwise noted.

Note and Caution Conventions

Within the text of this manual, you may find notes and cautions. These statements
are used for the purposes described below.

NOTE: Notes provide special considerations or details which are important to the
procedures or explanations presented.

CAUTION: Cautions indicate actions that may result in possible loss of work
performed and associated data. An example might be a system
crash that results in the loss of data for that given session.

Environment Variables

At installation an environment variable is defined that points to the location where
ISI tools have been installed. For UNIX systems, this variable is $ISIHOME. For
Windows systems, this variable is %ISIHOME%.

How to Access Integrated Systems-Supplied Files
At several places in this manual, you are asked to execute, study, or copy and mod-
ify certain files we provide for your use. The paths to the files are specified by envi-
ronment variables, which are established by the xmath startup software for your
convenience. For UNIX, the environment variables are:

Variable Status (as delivered)

$ISIHOME Available from operating system or Xmath Commands window

$SYSBLD Available from  Xmath Commands window and SystemBuild
Load/Save dialog

$XMATH Available from Xmath Commands window

$CASE Available from Xmath Commands window

dit.book  Page xi  Tuesday, September 28, 1999  8:47 AM



Using This Manual DocumentIt User’s Guide

xii

To make $SYSBLD, $XMATH, or $CASEavailable from the operating system, in the
Xmath Commands window, type:

oscmd ("echo $variable")

where variable is SYSBLD, XMATH, or CASE, as you require. The Xmath software
will display the required path. From the operating system, place this path in a set-
env  statement and execute it.

For information on Windows environment variables, see Xmath Basics.

Related Publications

Integrated Systems provides a complete library of publications to support its prod-
ucts. In addition to this guide, publications (from Integrated Systems and other
sources) that you may find particularly useful when using DocumentIt include the
following:

■ SystemBuild User’s Guide

■ SystemBuild Fuzzy Logic Block User’s Guide

■ Xmath Basics

■ AutoCode User’s Guide

■ AutoCode Reference

■ Template Programming Language User’s Guide

■ RealSim User’s Guide

■ Military Standard: Defense System Software Development, DOD-STD-2167A,
February 1988.

■ MML Reference from Adobe Systems Incorporated

This manual will help you create custom documentation formats using
FrameMaker MML markup language.
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Support

You can contact MATRIXX Technical Support in any of the three ways listed below.
When Technical Support responds, you will be given a Call ID specific to the prob-
lem you have reported. Please record the Call ID and use it whenever you contact
Technical Support regarding the issue.

■ Submit a problem report via the ISI web site using the following URL:

http://www.isi.com/Support/MATRIXx

This is the preferred method, as it is the most traceable; your problem report
will be automatically entered into our support database.

■ Send e-mail to mx_support@isi.com . We can serve you better if you e-mail us
with details on your configuration and the circumstances under which your
problem occurred. We provide an ASCII file that you can use as a template for
your e-mail to support; it can be found in:

MATRIXX/version/v6support.txt

where

MATRIXX is your MATRIXX product version directory, which is under ISIHOME.
To determine this directory location, from the Xmath command line, type one of
the following commands.

On the PC:

oscmd("echo %MATRIXX%");

On UNIX:

oscmd("echo $MATRIXX");

If you have Xmath running you can use the following Xmath function call to
copy the template to the current working directory:

copyfile("$MATRIXX/version/v6support.txt")

■ Call 800-958-8885 (where 1-800 service is available) or 408-542-1930. Tele-
phone support hours are 7:00 a.m. through 5:30 p.m. PST, Monday through
Friday. We can respond more efficiently if you are ready to provide the informa-
tion requested in MATRIXX/version/v6support.txt  at the time you call.
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Using the ISI FTP Site

If your problem involves scripts or model file(s), Technical Support may ask you to
FTP your files to us for further examination.

1. Connect to the ISI FTP site:

ftp ftp.isi.com

2. Log on as anonymous , and supply your email address as the password.

3. Change to the /incoming  directory:

cd /incoming

4. Use put or mput to specify the file(s) you are transferring. When the transfer is
complete, quit .

5. Send an email message to Technical Support that states the Call ID (if avail-
able), the exact name(s) of the file(s) you put in /incoming , and the approxi-
mate time you made the transfer; alternatively, call 800-958-8885 (where 1-800
service is available) or 408-542-1930 and provide this information. It will be a
minimum of 15 to 20 minutes before the transferred file(s) will pass through the
firewall.
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1-1

1 Introduction

This chapter provides an overview of the MATRIXX
® design documentation genera-

tion concept, a description of the basic steps required to produce documentation,
and a brief example of documentation generation from a SystemBuild™ model. This
chapter, along with Chapter 2, describes everything you need to know in order to
generate documentation using any of the templates described in Appendix B
through Appendix F.

1.1 DocumentIt and the Rapid Prototyping Concept

Conventional real-time system development usually takes place in stages with sepa-
rate tools for control design, software engineering, data acquisition, testing, and de-
sign documentation. The MATRIXX product family integrates tools for each stage of
system development into a single environment. This allows a design to move easily
from one stage to the next, making it possible to create a well-documented working
prototype early in the design process (Figure 1-1 shows DocumentI™ in the MA-
TRIXX product line).

Within the MATRIXX design automation product family, a system model can be
built, simulated, analyzed, tested, and debugged using SystemBuild and Xmath®.
Real-time code in a high-level language for the model (C or Ada) using AutoCode®

and design documentation can be generated automatically with DocumentIt. The
generated application code can be evaluated on the host with SystemBuild simula-
tion or run on the RealSim™ controller for hardware in-the-loop testing. Finally, the
generated application code can be cross-compiled and linked for implementation on
an embedded processor. Documentation can be updated and automatically gener-
ated along each step of the process.
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Xmath

SystemBuild

(Hardware in-the-loop testing)

AutoCode

Cross-Compilers/
Real-Time

Operating System
(e.g., pSOSystem)

MATRIXX Product Family

Tools

FIGURE 1-1 DocumentIt in the MATRIXX Product Line
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ASCII Output
Document
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(Document Generation)
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1.2 Automatic Document Generation Process

As an integral part of MATRIXX Rapid Prototyping concept, DocumentIt lets you gen-
erate design documentation from a SystemBuild block diagram model quickly, auto-
matically, and without programming skills. DocumentIt details the software design
in a uniform standardized documentation format and fully supports the
SystemBuild hierarchical approach to system design.

Because DocumentIt uses templates to format documents and select specific con-
tents, you can configure DocumentIt to suit your particular documentation needs.
The templates can be readily modified to conform to any documentation standard.
For example, DocumentIt can be used to generate the following:

■ Detailed description of the design in ASCII format

■ Most industry-standard formats

■ Tables containing SuperBlock and Block inputs and outputs, State Transition
Diagrams, and Global data

■ Documents formatted for FrameMaker (including DOD-STD-2167A) and
Microsoft Word (or any application that reads RTF)

A typical sequence for using DocumentIt is as follows (this sequence corresponds to
the sequence of steps shown in Figure 1-2):

6. Build and Document the Model

Develop the continuous-time plant model and corresponding discrete-time con-
troller SuperBlocks using SystemBuild block diagrams. The SystemBuild model
is built up from a large palette of blocks which combine to describe the way the
model works and how it should be controlled. DocumentIt automatically ex-
tracts information from the Inputs, Outputs, Document, and Comment fields
for SuperBlocks and primitive blocks.
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Step 1
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FIGURE 1-2 DocumentIt Automatic Documentation Generation Process
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7. Customize documentation generation.

Tailor your generated design document using the template programming lan-
guage (TPL) provided in DocumentIt. This programming language lets you im-
plement virtually any template file for a specialized purpose. DocumentIt output
in this case is an ASCII text file, which can be used by almost any text process-
ing product. You can edit the file with the host editor or print it as a simple un-
formatted ASCII file.

Alternatively, if used with text publishing software, the template file not only
contains DocumentIt parameters, but can also contain publishing software
commands such as rich text format (RTF) or FrameMaker markup language
(MML), which DocumentIt writes directly to the output file. The DocumentIt out-
put ASCII file can then be used as input to the text publishing software for auto-
matic formatting.

8. Generate the design document.

Invoke DocumentIt from inside SystemBuild, from the Xmath Commands win-
dow, or from the operating system command line. DocumentIt loads discrete-
time and continuous-time SuperBlocks, reading the associated data to generate
the design documentation in accordance with the template instructions.

9. Process documents with markup commands.

Import DocumentIt document files with FrameMaker, Interleaf, or RTF markup
commands into FrameMaker, Interleaf, or Microsoft Word, which automatically
formats the document.

10. Print the formatted document.

Save the model design document in RTF, FrameMaker (MML), or ASCII format,
and send it to a printer for hard copy output.

1.3 Cruise Control Example

This section provides an abbreviated illustration of the use of DocumentIt. Figure
1-3 on page 1-6 shows a modified version of the cruise control model. This model is
found in the following location:

UNIX $CASE/DIT/templates/fmaker/general/Controller_Logic_gen.dat

Windows %CASE%\case\DIT\templates\fmaker\general\Controller_Logic_gen.dat
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The cruise control model consists of the highest-level SuperBlock, two embedded
SuperBlocks, and associated units. Figure 1-4 shows the associated SuperBlock
Properties dialog. Click HELP for information on each field in the dialog.

FIGURE 1-3 Cruise Control SystemBuild Diagram
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The information from the SuperBlock Properties dialog can be included in the
DocumentIt ASCII output file by using the appropriate keywords in the template file.
The excerpt from a template file shown in Example 1-1 produces entries in the
DocumentIt ASCII output file shown in Example 1-2.

EXAMPLE 1-1: Template file excerpt

@SEGMENT MAIN() STRING S1 @
Software Design Document

@SCOPE SUPERBLOCK 0@

Overview : @S1=user_param("OVERVIEW_s", "SUPERBLOCK")@@S1@
Architecture: @user_param("ARCHITECTURE_s", "SUPERBLOCK")@@S1@
System States and Models: @S1=user_param("SYSTEM_STATES_AND_MODES_s",
 "SUPERBLOCK")@@S1@

Num Ext. In          = @num_sb_in_i@
Num Ext. Out         = @num_sb_out_i@

FIGURE 1-4 SuperBlock Properties for Cruise Control Diagram
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Num Super Blocks     = @num_blks_in_sb_i@
Attribute            = @sb_attr_s@
Frequency            = @sb_freq_r@

Has Input Data = @sb_has_in_data_b@
@ENDSEGMENT@

EXAMPLE 1-2: DocumentIt ASCII Output File

==================================
Software Design Document

Overview : This cruise controller regulates vehicle speed around a set point.
This cruise controller has three external inputs as follows:

the desired "speed" or velocity of the vehicle,

the current "speed,"

the current "acceleration" of the vehicle.

This cruise controller has one external output, which is the throttle
actuator command.

Architecture:  There are three SuperBlocks in this model.

The SuperBlocks are as follows:

the "Differentials" SuperBlock computes the difference between
desired and measured velocity and acceleration, adds computed target
acceleration to measured acceleration, and outputs a servo-limited
throttle command based upon these differences

the "Cruise Control Logic" SuperBlock determines whether or not
throttle position should be altered, based upon the difference
between actual and desired vehicle velocity, and

the "Mux3" SuperBlock determines the target acceleration based upon
inputs from the control logic.

System States and Models:  This model is enabled and disabled
externally.
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Num Ext. In          = 3
Num Ext. Out         = 1
Num SuperBlocks      = 3
Attribute            = Discrete
Frequency            = 50.0000

Has Input Data = 1

Similarly, information from all SuperBlock/block dialogs and input/output descrip-
tion dialogs can be included within an ASCII output file by the appropriate use of
the keywords in the template file.
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2 Invoking DocumentIt

This chapter tells how to generate documents from SystemBuild, the Xmath Com-
mands window, and from the operating system command line.

2.1 How to Generate Design Documentation

Using DocumentIt, you can generate design documentation from:

■ SystemBuild, which lets you automatically generate a real-time file (.rtf ) and
then extract block and SuperBlock documentation from a model, using a
Graphical User Interface. For ease of use, this is the recommended method of
documentation generation.

■ Xmath, which lets you automatically generate an .rtf and then extract block
and SuperBlock documentation from a model, using an Xmath command. See
Appendix A for the Xmath command options.

■ The operating system command line, which lets you extract block and
SuperBlock documentation from an already-existing .rtf , using the autostar
command from the operating system prompt. See Appendix A for the operating
system command-line options.

2.1.1 Generating Documentation From Within SystemBuild

To use DocumentIt while inside SystemBuild,

1. Select a Top-Level SuperBlock. By default, the name of the SuperBlock you se-
lect is used for both the RTF file and the documentation output file.

2. Select Tools→DocumentIt from the Catalog Browser to open the Generate Docu-
mentation dialog.
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3. Select your options. The available options include:

DocumentIt status is displayed in the Xmath Commands window log area.

Platform Specific Differences

The DocumentIt Generate Documentation dialog has some platform specific fea-
tures.

Windows

SystemBuild uses the standard Windows selection dialog to display an output file
name in the File name  field.

Block Parameters Select the source of the %Var informa-
tion. The %Vars from Xmath option
uses the latest values of the Xmath
variables. Block Defaults uses the
block's default values.

Typecheck If selected, the Analyzer checks for
matching data types for input and
output signals. AutoCode generates
the appropriate data types in the
target language that correspond to the
SystemBuild data types. If not
selected, input and output signals and
parameter data are assumed to be
FLOAT. In this case, DocumentIt only
generates the RT_FLOAT data type for
signals and data. Default = 0.

Template File Specify the DocumentIt template .tpl
or .dac file to be used to format
the documentation. The standard
ASCII template is used by default.

Config File File containing other DocumentIt
command-line options.

MS Word Enable special prcessing for Microsoft
Word RTF file generation. This option
is required if you are using the
Microsoft Word template as described
in Generating Documents Using Mi-
crosoft Word.
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If you want more information on standard portions of the dialog, click on the
question mark (?) icon on the dialog’s title bar, and then position the question mark
cursor over a field or icon and click. The Windows help for that field will be dis-
played.

Depending on the template file used, the document can be either an ASCII text file
or an ASCII file with embedded word processor markup language formatting com-
mands. These commands are word processor specific. Example templates are pro-
vided to support FrameMaker, Interleaf, and rich text format (RTF), used by
Microsoft Word (and read by other programs).

dit.book  Page 3  Tuesday, September 28, 1999  8:47 AM



Invoking DocumentIt DocumentIt User’s Guide

2-4

UNIX

The Generate Documentation dialog uses a standard Motif file selection dialog to
specify the name of the output documentation file in the Selection field.

Filter Displays the file selection directory path. Uses standard shell
wildcard character(s) to select the files shown in the Files listing.
Default value is the current directory with the *.cat  filter.
Pressing Return after changing the filter path updates the listings
in Directories and Files.

Directories Lists the directories within the current directory. Double-click
the directory name to change the current directory.

Files Lists the files in the selected directory that meet the filter crite-
ria. If the rest of the dialog is filled out to your satisfaction, dou-
ble-click on a file to save to that file name.
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Template Information

Appendix B through Appendix E provide examples of automatic documentation gen-
eration using DocumentIt templates, as follows:

■ Appendix B describes how to generate a general purpose design document us-
ing DocumentIt and FrameMaker templates.

■ Appendix C describes how to generate a sample design document conforming
closely with DOD-STD-2167A using DocumentIt and FrameMaker templates.

■ Appendix D describes how to generate a sample design document generate a
sample design document conforming closely with DOD-STD-2167A using Docu-
mentIt and Interleaf templates.

■ Appendix E describes how to generate a sample design document using Docu-
mentIt and Microsoft Word templates.

■ Appendix F describes how to generate a sample design document in ASCII text
file format using a DocumentIt template.

2.1.2 Generating Documentation from the Xmath Commands Window

The documentit command lets you process a model to generate design documenta-
tion.

Two syntaxes are supported:

documentit, {model = name1, file = name2, template=name3}

documentit model, {options}

where name1 identifies the model to be processed for documentation generation.
The model can be either:

■ A string (in “quotes”), which must be the name of a SuperBlock that exists in
the current SystemBuild Catalog. This SuperBlock is analyzed and processed to
generate documentation.

Selection Displays the complete path to the file selected in the Files listing.
Because this name is used for both the RTF file and the docu-
mentation file, any extensions will be stripped before creating the
.rtf  and source file names.
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■ A variable (not in quotes). Variables should be assigned to a string, the string
must be the name of a SuperBlock in the current catalog; it is analyzed and pro-
cessed to generate documentation.

Whenever a file name or other string is included in a command string, it must be
enclosed in quotes, but a variable name must not be in quotes.

name2 is the name for the generated output document file. This value must be a
string or string variable as well. If the file=name2 option is not provided, docu-
mentation will be generated in the file mode1.doc .

name3 is the name of the template file used to tailor the document. This value must
be a string or string variable. If this option is not provided, the template
_documentit.tpl  (in the directory $CASE/DIT/templates/ascii ) is used.

See Appendix A for a complete list of DocumentIt options (used in the second com-
mand syntax).

Examples:

documentit " topSB "

The system generates a real-time file named topSB .rtf . It loads this file and pro-
cesses it to produce the document file. The output file name is topSB .doc .

documentit " topSB ", {template="mytemplate"}

documentit, {model = "topSB", template = "mytemplate"}

Either syntax processes the SuperBlock topSB in the current catalog to produce
documentation, using the template file mytemplate . The output file name is
topSB .doc .

2.1.3 Generating Documentation from the OS

If a model file already exists, it is also possible to execute DocumentIt from the oper-
ating system prompt. The file intended for processing must be a real-time file (.rtf ).
At the operating system prompt, execute the command:

% autostar {options} model_file.rtf

Many of the options are the same as the fields in the documentation generation dia-
log. See Appendix A for a complete list of DocumentIt options.

DocumentIt runs, creating a document file. When the operating system prompt
returns, the process is complete.
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Examples:

% autostar -h

shows a help display.

% autostar -doc -t FM.tpl SysBld_file.rtf

processes the model file SysBld_file.rtf using a template file named
FM.tpl to produce a document file named SysBld_file.doc . It assumes the
template file named FM.tpl  exists in your working directory.

NOTE: The DocumentIt real-time file (.rtf ) input file is not the same as the rich
text format file (.rtf ) word processing output file. Only the file extension
is the same.
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3 Customizing the Generated
Documentation

You can customize DocumentIt-generated output documentation to suit your spe-
cific needs by using templates. Template files are ASCII files containing text, inter-
spersed with template command parameters that specify DocumentIt output.

In addition to template command parameters, template files can also use publishing
software markup commands (for example, Microsoft Word RTF, Interleaf markup,
and FrameMaker MML commands), which DocumentIt writes directly to the ASCII
output file. The markup commands automatically format the document when it is
imported into the corresponding publishing software.

For details about how to use TPL for DocumentIt output, see the Template Program-
ming Language User’s Guide.
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A DocumentIt Options

This appendix provides additional information about invoking DocumentIt. Use this
appendix together with Chapter 2, Invoking DocumentIt.

A.1 Options When Invoking DocumentIt

As described in Chapter 2, DocumentIt can be invoked from the Catalog Browser,
the Xmath Commands window, or the operating system command line. Table A-1
lists the various DocumentIt command-line options.

From the Catalog Browser, select Tools→DocumentIt

From the Xmath Commands window, enter the command (see Section 2.1.2):

documentit options

From the operating system command line, enter the command (see Section 2.1.3):

autostar -doc options

TABLE A-1 Command-Line Options When Invoking DocumentIt

Option from
Xmath

Option from
O/S

Description

file -o A string defining the output file for generated docu-
mentation. If no name is supplied, the top level
SuperBlock name is used with the .doc extension.

See note a

on page A-3.
-h Obtains a help display.
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model See note b

on page A-1.
A text string representing the name of a SuperBlock
in the SystemBuild Editor (e.g., “System”).

msrtf -msw1 Provides special parsing for Microsoft Word docu-
mentation generation. Ignores the \par  parameter
in the rich text format (RTF) when you use @@ and
merges a word when it is divided across two lines.

options -opt A string specifying the name of the options file.
Options are entered in the file using the same syn-
tax as if they were specified in an operating-system
call to AutoCode (outside Xmath), except that op-
tions normally passed as strings must not be
quoted. Command-line options override all the op-
tions in this file, and the RTF file name cannot be
given here. Single line comments are done by using
// characters. See Section A.2 for more information
about the options file.

rtf See note c

on page A-3.
A string specifying the RTF file name.   You can use
the RTF file along with the standalone AUTOCODE
command to regenerate code. The RTF file is gener-
ated using the CREATERTF command.

tpldac -d A string specifying the location of the template dac
file to be used in document generation. Default file
is $XMATH/../case/DIT/templates/ascii/
documentit.dac  (the code template dac) .

tplsrc -t A string specifying the location of the template file to
be used in document generation. The default file is
$XMATH/../case/DIT/templates/ascii/
documentit .tpl  (the code template).

TABLE A-1 Command-Line Options When Invoking DocumentIt (Continued)

Option from
Xmath

Option from
O/S

Description
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A.2 Using the autostar.opt File

If you invoke DocumentIt with the same options consistently, you can put these op-
tions into an options file, saving a lot of error-prone, repetitive typing each time you
invoke Documentit. DocumentIt reads the options file at startup, and performs the
options as though you had entered them on the command line. Although you can
use an options file whether you invoke DocumentIt from the Xmath Commands win-
dow or the operating system command line, the only options that you can specify in
the options file are operating system command-line options.

The default options file is autostar.opt . If you have an autostar.opt file in the
current working directory from which you invoke DocumentIt, the options in that
file will be executed when you invoke DocumentIt. If you specify an option on the
command line that is also in the options file, the command-line option overrides the
same option in the options file (see Example A-1 and the paragraphs following).

For different applications, you might need to invoke DocumentIt differently. For this
reason, you can have multiple options files. To invoke DocumentIt with an options
file other than autostar.opt , specify the name of the options file when you invoke
DocumentIt (see Example A-2 and the paragraphs following).

typecheck See note a

on page A-3.
Boolean (default=1). When TRUE, this option en-
ables the checking of variable types for the
SystemBuild analyzer. Typechecking is always done
by default.

vars See note a

on page A-3.
Boolean (default=1). When TRUE, this flag forces
%variables in the Xmath workspace to be used.
When FALSE, SystemBuild default block form val-
ues will be used.

a. Xmath does not have a help  keyword, but has the command help autocode  for
Netscape help.

b. This Xmath option is used for creating the .rtf file. When invoking from the O/S,
the .rtf  file must already exist; therefore, there is no O/S option equivalent.

c. The name of the .rtf  file must always be specified when invoking from the
command line.

TABLE A-1 Command-Line Options When Invoking DocumentIt (Continued)

Option from
Xmath

Option from
O/S

Description
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Options are entered in the options file using the same syntax as if they were speci-
fied in the command line. The exception is that map specifications are not enclosed
between quotes. Options can be on one line, separate lines, or a combination. The
RTF file name cannot be specified in the options file. Single line comments are pre-
ceded and followed by // characters.

Example A-1 shows an options file.

EXAMPLE A-1: Example autostar.opt  Options File

// Sample options file //
-t c386_c860_mb2.tpl
-o myoutput

To use this file, invoke DocumentIt as follows:

autostar -doc model.rtf

This invokes DocumentIt with the autostar.opt  options file.

Consider the following command:

autostar -doc -o myoutput3 model.rtf

The options file is again used, but the output file option (-o ) is specified on the com-
mand line, so it overrides the corresponding command in the options file. The out-
put documentation will be in file myoutput3 , not in file myoutput as specified in
the options file.

Example A-2 shows an options file called myopt.opt .

EXAMPLE A-2: Example Options File Called myopt.opt

// Sample options file //
-t c386_c860_mb2.tpl
-o myoutput2

To use this file, invoke DocumentIt as follows:

autostar -doc -opt myopt.opt model.rtf

This invokes DocumentIt with the myopt.opt  options file.
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So, if you have both of the above option files (shown in Examples A-1 and A-2) in
your directory, invoking autostar without the -opt option puts the generated docu-
mentation into file myoutput (the autostar.opt options file is used). Invoking au-
tostar with the -opt myopt.opt option as shown above puts the generated
documentation into file myoutput2  (as specified in the myopt.opt  file).
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B Generating Documents Using
FrameMaker

This appendix provides instructions for using the FrameMaker documentation
example. This includes describing how to:

■ Generate documents and encapsulated PostScript files.

■ Import encapsulated PostScript files into a generated document automatically
and manually.

■ Format table data for FrameMaker.

All FrameMaker documentation example files are located in:

$CASE/DIT/templates/fmaker/general

B.1 Using Your Own Templates

If you want to generate documentation using your own templates, you might con-
sider copying the supplied example files and then modifying them. The purpose of
each file is given in Table B-1 on page B-2. FrameMaker markup language (MML)
commands are listed in Table B-2 on page B-3.
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TABLE B-1 FrameMaker Example Files

Filename Description

fmgp.tpl This template file determines what informa-
tion will be extracted from the model to cre-
ate an ASCII output file. Additionally,
fmgp.tpl  embeds FrameMaker MML com-
mands, which define how the document will
be formatted when it is imported into
FrameMaker. Finally, the template also em-
beds an MML command that calls the in-
clude file fmgpinc.mml , which defines what
MML commands FrameMaker should recog-
nize from the FrameMaker template
fmgp.doc .

fmgpinc.mml This include file specifies what MML com-
mands the FrameMaker template file
fmgp.doc  should recognize. However, the
actual format definitions of these commands
are not specified in this include file; rather,
the format specifications for each MML com-
mand are incorporated into fmgp.doc . All
MML commands listed in this include file are
given in Figure B-2. The table also gives a
brief description of each MML command as it
is defined by fmgp.doc .

fmgp.doc This is a supplied FrameMaker template into
which you must import an ASCII data file
generated by DocumentIt using the
DocumentIt template fmgp.tpl .

fmgpTOC.doc This FrameMaker template receives the table
of contents you generate from fmgp.doc.  It
is important to consider that FrameMaker
normally generates a TOC file automatically
from a document file (but no format is speci-
fied). The purpose of this file is to provide a
suitable format for the TOC, rather than
requiring you to develop one.

Controller_Logic_gen.dat Controller logic model.
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TABLE B-2 FrameMaker MML Commands

Command Description

<Author> Command on the title page; formats the name of the au-
thor providing the document (see Figure B-2).

<body1> Normal text paragraph format.

<body2> Indented text paragraph which can be use to align with
the text in a numbered list (first level number).

<body3> Indented text paragraph which can be use to align with
the text in a numbered list (second level number).

<bull1> First level bulleted list.

<bull2> Second level bulleted list.

<chap> Chapter title.

<CoBody> Name of the company providing the document given on
the title page (see Figure B-2).

<Date> Title page entry for the document date (see Figure B-2).

<DocTitle> Document title (see Figure B-2).

<EXample> Numbered title of an example (automatic numbering).

<EXinit> Numbered title of an example (reset count to 1).

<EXtext> Text format for programming example.

<FIGcap> Automatically numbered figure caption.

<head1> First heading level.

<head2> Second heading level.

<head3> Third heading level.

<head4> Fourth heading level.

<head5> Fifth heading level.

<list1> Numeric list (automatic numbering).

<list1init> Numeric list (automatic numbering reset to 1).

<list2> Alpha list (automatic numbering).

<list2init> Alpha list (automatic numbering reset to a).

<NOTE> Note paragraph with the word NOTE included.

<NOTE+> Indented paragraph that aligns with the text in the NOTE
paragraph (the word NOTE is not included). This is used
when a note has a second paragraph.

<Rev> Revision of the document on the title page (see
Figure B-2).

<TBLcap> Automatically numbered table caption.
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B.2 Generating a Sample Document

To generate a sample document using DocumentIt and FrameMaker, follow these
steps:

NOTE: If you want to generate a document from your own model, follow the same
steps given in this example, but use your own model for document
generation.

1. Create a directory in which you want the output document to reside.

2. Copy all files from:

UNIX:      $CASE/DIT/templates/fmaker/general
Windows:    %CASE%\DIT\templates\fmaker\general

to the document directory.

3. From the Catalog Browser File menu, select Load.

4. Browse through the document directory and double-click to load the file
Controller_Logic_gen.dat .

5. In the Catalog pane of the Catalog Browser, select the top-level SuperBlock (in
this case, Controller_Logic).

6. From the Catalog Browser, select Tools→DocumentIt. The Generate Documen-
tation dialog appears.

7. In the File name  field, enter Controller_Logic.mml .

NOTE: An ASCII file with MML markup commands must have a file extension
of .mml  to be formatted by FrameMaker.

8. With the Block Parameters  combo box, select %Vars from Xmath .

9. In the Template File field, specify fmgp.tpl  as the template file.

10. Select the Typecheck  check box.

11. To generate the MML document file, click OK.
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B.2.1 Changing the Generic Title Page

The MML file that you have generated (in this case, Controller_Logic.mml )
includes a generic title page that appears as shown in Figure B-1 after it is imported
into FrameMaker. If you want to change the data on the title page, you can accom-
plish this in three different ways:

● Using a text editor you can edit the fmgp.tpl data. Figure B-2 shows the
data in the fmgp.tpl file that produces the title page shown in Figure B-1.
You should make these changes to fmgp.tpl before you generate the docu-
ment from SystemBuild. All subsequent documents generated by Docu-
mentIt using fmgp.tpl will continue to have your new title page (until you
change the contents of fmgp.tpl  again).

● Using a text editor you can edit the MML output file you have just gener-
ated. Figure B-2 shows the data in the example file
Controller_Logic.mml that produces the title page shown in Figure B-1.
If you regenerate the document, you will have to edit this file again.

● If you are familiar with FrameMaker, you can edit the title page after you
import the data into FrameMaker.

If your MML output files contain less than (<) or greater than (>) characters from
your model, you must use your text editor to place a backslash (\) character in front
of these characters. This is required because these characters will otherwise be in-
terpreted as invalid MML commands when the *.mml file is imported into
FrameMaker.
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FIGURE B-1 Generic Title Page
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B.2.2 Generating an .eps  file from SystemBuild

1. To place an illustration in your document, you must insert an anchored frame
where you want the figure to appear. Two anchored frames are inserted into this
example so that you can see how they work. For details on .eps files, refer to
the Template Programming Language User’s Guide. You can insert an anchored
frame in your document in one of the following ways:

● Using a text editor, insert @include_img()@ to automatically import the
illustration when you generate the document.

You must edit the .eps file generated from SystemBuild in the text editor
and change the first line as follows:

%!PS-ADOBE-1.0
to
%!PS-ADOBE-3.0 EPSF-3.0

● Using a text editor, you can insert the TPL function @small_frame()@ (5”
x5” frame) or @large_frame()@ (7” x5” frame) in fmgp.tpl where you
want the figure to appear. You should make these changes to fmgp.tpl be-
fore you generate the document from SystemBuild. After the document is
processed and imported into FrameMaker, a blank frame will be placed into

<DocTitle>
Software Design Document
<Author>
Author's Name
<Rev>
X.X
<Date>
November 17, 1998
<CoBody>
Company Name

Street Address

City, State ZIP

FIGURE B-2 Title Page Data in fmgp.tpl  and controller_logic_gen.mml
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your document in the location you specified. Refer to your FrameMaker doc-
umentation to use the capture feature to capture and import the figure that
you want into the anchored frame.

● Using a text editor you can insert the MML command

<AFrame <BRect 0 0 h” w”>>

into the ASCII output file you have just generated (where the variables h
and w are the height and width of the frame, respectively). After the docu-
ment is imported into FrameMaker, a blank frame will be placed into your
document in the location you specified. Refer to your FrameMaker docu-
mentation to use the capture feature to capture and import the figure that
you want into the anchored frame.

● If you are familiar with FrameMaker, you can create an anchored frame and
import the figure you want directly into your FrameMaker document.

i. Highlight the top level SuperBlock (Controller_Logic).

ii. Select File→Page Setup to make any adjustments to the image before
creating the graphics file. In this case, accept the defaults.

iii. Select File→Print to File.

iv. From the format pull-down, select EncapPostScript .

v. From the output pull-down, select Separate files .

vi. Click OK.

NOTE: If the .eps illustration is too large for the anchored frame, use the
FrameMaker Graphics Scale option to adjust the size.

2. From the system prompt in the document  directory, start FrameMaker.

3. From FrameMaker, open fmgp.doc . You will find a blank file, with the excep-
tion of vertical lines on the left side of the page.

4. From the pull-down menu, select File→Import.

5. Select Copy File into Document .

6. Select Controller_Logic.mml  and click OK.
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7. After the import is complete, you will still have a blank page, except for a single
paragraph text symbol at the top of the page somewhat hidden in the top por-
tion of the vertical lines). Select the paragraph symbol and delete it.

The title page of the Software Design Document fills the page. (Do not be con-
cerned if the vertical lines do not remain intact; they will be restored as soon as
you page through the document.)

NOTE: Do not save this file until you are told to do so.

B.2.3 Putting Information in Table Format

1. Page through the document to ensure it meets your needs. If you have informa-
tion that you want to be in table format, follow the steps below, beginning with
a. If you have no tables, skip to step 2 on page B-10.

a. Select all the data you want to include in the table, but do not include the
last paragraph symbol in the last row of table data (see Figure B-3 for an ex-
ample of exactly what information you need to select for reformatting).

b. From the pull-down menu, select Table→Convert to Table. When the Con-
vert to Table dialog appears, leave the settings intact and click OK.

c. From the pull-down menu, select Table→Resize Columns. When the Resize
Columns dialog appears, click on By Scaling to Widths Totalling ; change the value

Do not include last
paragraph symbol

Table Data

FIGURE B-3 Marking Data for Table Formatting

of table data
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to 6.25” and click OK. Make sure that the whole table is selected when you
do this. At this point you can resize individual columns if necessary.

You can also click and drag to highlight one or more table columns. Click to
grab the left column handles, and pull out or push in to resize the column.

d. Delete any extraneous paragraph symbols that may have appeared below
the table during the conversion process (this is necessary due to the way
FrameMaker converts tables).

e. Perform steps a through d above for each table you have in the document.

2. From the pull-down menu, select File→Generate.

3. Click List Table of Contents . Then, click Generate .

4. Leave all the current settings in the Set Up Table of Contents dialog intact and
click OK.

5. The fmgpTOC.doc file now appears on the screen with a complete list of sec-
tions and subsections. However, since FrameMaker lists all items in the order in
which they appear in a document, some minor formatting is required for the list
of figures and tables. Complete these tasks as follows:

a. Page down through the TOC. Using the Cut and Paste features under the
Edit pull-down menu, put all figure references at the end of the Table of
Contents. Do the same thing for all table references, so they follow the fig-
ures.

b. At the first figure entry (now near the end of the Table of Contents), put the
cursor in front of the Figure 1  entry.

c. Type in the word “Figures” and press ENTER.

d. Click once on the word “Figures.”

e. Click the Paragraph Catalog symbol in the upper right corner of the page to
display the Paragraph Catalog. In the catalog, select the paragraph type
TabFigTC .

The heading for the list of figures is now formatted correctly.

f. Repeat this process for the list of tables.

6. Select the fmgp.doc frame. From the File pull-down menu, select Save As and
assign a new file name to your document file.
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7. (Optional) To print the document, select File→Print.

8. Select the fmgpTOC.doc frame. From the File pull-down menu, select Save As .
You must specify the identical path and file name as you did in the previous
step for your new document file, only append “TOC” to the file name before the
extension (see the example that follows).

This scheme allows you to generate TOCs in the future (when you modify your
document) without having to construct a new TOC template.

9. You now have a new document and your original templates have remained in-
tact.

NOTE: See Using Your Own Templates on page B-1 for information about using
your templates instead of the supplied templates.

Original File Name → New File Name

fmgp.doc → FMsample1.doc

fmgpTOC.doc → FMsample1TOC.doc
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C Generating 2167A Documents
Using FrameMaker

This appendix describes how to use the FrameMaker 2167A example. This includes
describing how to:

■ Generate documents and encapsulated PostScript files.

■ Import encapsulated PostScript files into a generated document automatically
and manually.

■ Format table data for FrameMaker.

All FrameMaker 2167A example files are located in:

$CASE/DIT/templates/fmaker/milstd (Sun)

C.1 Using Your Own Templates

If you want to generate documentation using your own templates, you might want to
consider copying the supplied example files and then modifying them. The purpose
of each file is given in Table C-1 on page C-2. FrameMaker markup language (MML)
commands are listed in Table C-2 on page C-3.
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TABLE C-1 FrameMaker 2167A Example Files

Filename Description
fmmil.tpl This template file determines what informa-

tion will be extracted from the model to cre-
ate an ASCII output file. Additionally,
fmmil.tpl  embeds FrameMaker MML com-
mands, which define how the document will
be formatted when it is imported into
FrameMaker. Finally, the template also em-
beds an MML command that calls the in-
clude file fmmilinc.mml , which defines
what MML commands FrameMaker should
recognize from the FrameMaker template
fmmil.doc .

fmmilinc.mml This include file specifies what MML com-
mands the FrameMaker template file fm-
mil.doc  should recognize. However, the
actual format definitions of these commands
are not specified in this include file; rather,
the format specifications for each MML com-
mand are incorporated into fmmil.doc . All
MML commands listed in this include file are
given in Table C-2. The table also gives a
brief description of each MML command as it
is defined by fmmil.doc .

fmmil.doc This is a supplied FrameMaker template into
which you must import an ASCII data file
generated by DocumentIt using the
DocumentIt template fmmil.tpl .

fmmilTOC.doc This FrameMaker template receives the table
of contents you generate from fmmil.doc. It
is important to consider that FrameMaker
normally generates a TOC file automatically
from a document file (but no format is speci-
fied). The purpose of this file is to provide a
suitable format for the TOC, rather than re-
quiring you to develop one.
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TABLE C-2 FrameMaker 2167A MML Commands

Command Description
<Author> Last command on the title page; formats the name of the

company providing the document (see Figure C-2).
<body1> Normal text paragraph format.
<body2> Indented text paragraph which can be use to align with

the text in a numbered list (first level number).
<body3> Indented text paragraph which can be use to align with

the text in a numbered list (second level number).
<bull1> First level bulleted list.
<bull2> Second level bulleted list.
<CDRL> Title page CDRL sequence number (see Figure C-2).
<chap> Chapter heading level.
<Client> Title page entry for the name of the client for who the doc-

ument was prepared (see Figure C-2).
<contract> Title page entry for the contract number (see Figure C-2).
<DocTitle> Document title (see Figure C-2).
<EXample> Numbered title of an example (automatic numbering).
<EXinit> Numbered title of an example (reset count to 1).
<EXtext> Text format for programming example.
<FIGcap> Automatically numbered figure caption.
<head1> First heading level (e.g., 1.1).
<head2> Second heading level (e.g., 1.1.1).
<head3> Third heading level (e.g., 1.1.1.1).
<head4> Fourth heading level (e.g., 1.1.1.1.1).
<head5> Fifth heading level (e.g., 1.1.1.1.1.1).
<list1> Numeric list (automatic numbering).
<list1init> Numeric list (automatic numbering reset to 1).
<list2> Alpha list (automatic numbering).
<list2init> Alpha list (automatic numbering reset to a).
<NOTE> Note paragraph with the word NOTE included.
<NOTE+> Indented paragraph that aligns with the text in the NOTE

paragraph (the word NOTE is not included). This is used
when a note has a second paragraph.

<PrepBy> Title page entry (see Figure C-2).
<PrepFor> Title page entry (see Figure C-2).
<Rev> Revision and date entry on the title page (see Figure C-2).
<TBLcap> Table caption.
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C.2 Generating the 2167A Document

To generate the sample 2167A document using DocumentIt and FrameMaker, follow
these steps:

NOTE: If you want to generate a document from your own model, follow the same
steps given in this example, but use your own model for document
generation.

1. Create a directory in which you want the output document to reside.

2. Copy all files from:

UNIX:      $CASE/DIT/templates/fmaker/general
Windows:   %CASE%\DIT\templates\fmaker\general

to the document directory.

3. From the Catalog Browser File menu, select Load.

4. Browse through the document directory and double-click to load the file
Controller_Logic_mil.dat .

5. In the Catalog pane of the Catalog Browser, select the top-level SuperBlock (in
this case, Controller_Logic).

6. From the Catalog Browser, select Tools→DocumentIt. The Generate Documen-
tation dialog appears.

7. In the File Name field, enter Controller_Logic_mil.mml .

NOTE: An ASCII file with MML markup commands must have a file extension
of .mml  in order to be formatted by FrameMaker.

8. With the Block Parameters  combo box, select %Vars from Xmath .

9. In the Template File field, specify fmgp.tpl  as the template file.

10. Click the Typecheck  check box.

<TitlePar1> Title page entries (see Figure C-2).
<TitlePar2> Title page CSCI name and system name entries (see

Figure C-2).

TABLE C-2 FrameMaker 2167A MML Commands (Continued)

Command Description
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11. To generate the MML document file, click OK.

C.2.1 Changing the Generic Title Page

The MML file that you have generated (in this case, controller_logic_mil.mml )
includes a generic title page that appears as shown in Figure C-1 after it is imported
into FrameMaker. If you want to change the data on the title page, you can accom-
plish this in three different ways:

■ Using a text editor you can edit the fmmil.tpl data. Figure C-2 shows the data
in the fmmil.tpl file that produces the title page shown in Figure C-1. You
should make these changes to fmmil.tpl before you generate the document
from SystemBuild. All subsequent documents generated by DocumentIt using
fmmil.tpl will continue to have your new title page (until you change the con-
tents of fmmil.tpl  again).

■ Using a text editor you can edit the MML output file you have just generated.
Figure C-2 shows the data in the example file controller_logic_mil.mml
that produces the title page shown in Figure C-1. If you regenerate the docu-
ment, you will have to edit this file again.

■ If you are familiar with FrameMaker, you can edit the title page after you import
the data into FrameMaker.

NOTE: If your output files contain less than (<) or more than (>) characters from
your model, you must use your text editor to place a backslash (\)
character in front of these characters. This is required because these
characters will otherwise be interpreted as invalid MML commands when
the *.mml  file is imported into FrameMaker.
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FIGURE C-1 Generic Title Page
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C.2.2 Generating an .eps  file from SystemBuild

To place an illustration in your document, you must insert an anchored frame
where you want the figure to appear. Two anchored frames are inserted into this ex-
ample so that you can see how they work. For details on .eps files refer to the Tem-
plate Programming Language User’s Guide. You can insert an anchored frame in
your document in one of the following ways:

■ Using a text editor, insert @include_img()@ to import the illustration auto-
matically when you generate the document.

FIGURE C-2 Title Page Data in fmmil.tpl  and controller_logic _mil .mml

<Rev>
Revision X.X: September 9, 1999
<DocTitle>
Software Design Document
<TitlePar1>
For The
<TitlePar2>
CSCI NAME
<TitlePar1>
Of
<TitlePar2>
System Name
<contract>
XXXXXXX
<CDRL>
XXXXXXXXXXX
<PrepFor>
Prepared for:
<Client>
Contracting Agency Name, Department Code
<PrepBy>
Prepared by:
<Author>
Integrated Systems, Inc.
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You must edit the .eps file generated from SystemBuild in the text editor and
change the first line as follows:

%!PS-ADOBE-1.0
to
%!PS-ADOBE-3.0 EPSF-3.0

■ Using a text editor, you can insert the tpl function

@small_frame()@  (5” x5” frame) or @large_frame()@  (7” x5” frame)

in fmgp.tpl where you want the figure to appear. You should make these
changes to fmgp.tpl before you generate the document from SystemBuild. Af-
ter the document is processed and imported into FrameMaker, a blank frame
will be placed into your document in the location you specified. Refer to your
FrameMaker documentation to use the capture feature to capture and import
the figure that you want into the anchored frame.

■ Using a text editor you can insert the MMLcommand <AFrame <BRect 0 0 h”
w”>> into the ASCII output file you have just generated (where the variables h
and w are the height and width of the frame, respectively). After the document is
imported into FrameMaker, a blank frame will be placed into your document in
the location you specified. Refer to your FrameMaker documentation to use the
capture feature to capture and import the figure that you want into the an-
chored frame.

■ If you are familiar with FrameMaker, you can create an anchored frame and im-
port the figure you want directly into your FrameMaker document.

a. Highlight the top level SuperBlock (Controller_Logic).

b. Select File→Page Setup to make any adjustments to the image before creat-
ing the graphics file. In this case, accept the defaults.

c. Select File→Print to File.

d. From the format pull-down, select EncapPostScript .

e. From the output pull-down, select Separate files .

f. Click OK.

NOTE: If the .eps illustration is too large for the anchored frame, use the
FrameMaker Graphics Scale option to adjust the size.
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The following message appears in the SystemBuild menu bar to confirm that a
hard copy .eps file was generated:

5 SuperBlock(s) hardcopied into file Controller_Logic.eps

1. From the system prompt in the document  directory, invoke FrameMaker.

2. From FrameMaker open fmmil.doc . You will find a blank file.

3. From the pull-down menu, select File→Import.

4. Click on Copy File into Document.

5. Select Controller_Logic_mil.mml  and click OK.

6. After the import is complete, you will still have a blank page except for a single
paragraph text symbol at the top of the page. Select the paragraph symbol and
delete it. The Software Design Document title page will fill the page.

NOTE: Do not save this file until you are prompted to do so.

C.2.3 Putting Information in Table Format

Page through the document to ensure it meets your needs. If you have information
that you want to be in table format, follow the steps below, beginning with a. If you
have no tables, skip to step 7 on page C-10.
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1. Select all the data you want to include in the table, but do not include the last
paragraph symbol in the last row of table data (see Figure C-3 for an example of
exactly what information you need to select for reformatting).

2. From the pull-down menu, select Table→Convert to Table. When the Convert to
Table dialog appears, leave the settings intact and click OK.

3. From the pull-down menu, select Table→Resize Columns. When the Resize Col-
umns dialog appears, click on By Scaling to Widths Totalling ; change the value to
6.25” and click OK. Make sure that the whole table is selected when you do this.
At this point you can resize individual columns if necessary.

4. You can also click and drag to highlight one or more table columns. Click the
left mouse to grab the left column handles, and pull out or push in to resize the
column.

5. Delete any extraneous paragraph symbols that may have appeared below the
table during the conversion process (this is necessary due to the manner in
which FrameMaker converts tables).

6. Perform the above steps for each table you have in the document.

7. From the File pull-down menu, select Generate.

8. Click List Table of Contents , and then click Generate .

Do not include last
paragraph symbol

Table Data

FIGURE C-3 Marking Data for Table Formatting

of table data
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9. Leave all the current settings in the Set Up Table of Contents dialog intact and
click OK.

10. The file fmmilTOC.doc now appears on the screen with a complete list of sec-
tions and subsections. However, since FrameMaker lists all items in the order in
which they appear in a document, some minor formatting is required for the list
of figures and tables. Complete these tasks as follows:

a. Page down through the TOC. Using the Cut and Paste features under the
Edit pull-down menu, put all figure references at the end of the Table of
Contents. Do the same thing for all table references, so they follow the fig-
ures.

b. At the first figure entry (now near the end of the Table of Contents), put the
cursor in front of the Figure 1  entry.

c. Type in the word “Figures” and press Enter.

d. Click once on the word “Figures.”

e. Click on the Paragraph Catalog symbol in the upper right corner of the page
(this will display the Paragraph Catalog). In the catalog, click on the para-
graph type TabFigTC . The heading for the list of figures is now formatted
correctly.

f. Repeat this process for the list of tables.

11. Select the fmmil.doc frame. From the File pull-down menu, select Save As
and assign a new file name to your document file. If you wish, you can print the
file at this time.

12. Select the fmmilTOC.doc frame. From the File pull-down menu, select Save
As. Now, you must specify the identical path and file name as you did in the
previous step for your new document file, only append “TOC” to the file name
before the extension (see the example that follows).

This scheme allows you to generate TOCs in the future (when you modify your
document) without having to construct a new TOC template.

13. You now have a new document and your original templates have remained in-
tact. You can close your files now if you want.

Original File Name → New File Name

fmmil.doc → FMsample1.doc

fmmilTOC.doc → FMsample1TOC.doc
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NOTE: See Using Your Own Templates on page C-1 for information about using
your templates instead of the supplied templates.

dit.book  Page 12  Tuesday, September 28, 1999  8:47 AM



D-1

D

D Generating 2167A Documents
Using Interleaf

Here are instructions for using the Interleaf 2167A example. This tutorial tells how
to:

■ Generate documents and encapsulated PostScript files.

■ Import epsf files into a generated document automatically and manually.

■ Format table data for MS Word.

All Interleaf 2167A example files are located in:

$CASE/DIT/templates/ileaf/milstd (Sun)

D.1 Using Your Own Templates

If you want to generate documentation using your own templates, you might want to
consider copying the supplied example files and then modifying them. The purpose
of each file is given in Table D-1 on page D-2. Interleaf markup commands are listed
in Table D-2 on page D-2.
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TABLE D-1 Interleaf 2167A Example Files

Filename Description

ilmil.tpl This template file determines what information
will be extracted from the model to create an
ASCII output file. Additionally, ilmil.tpl em-
beds Interleaf markup commands, which de-
fine how the document will be formatted when
it is opened under Interleaf. Finally, the tem-
plate also embeds a markup command that
calls the include file ilmilinc , which defines
how the document will be formatted by Inter-
leaf.

ilmilinc This include file specifies the markup com-
mands that Interleaf will use to format the
ASCII output file generated by DocumentIt. All
markup commands listed in this include file
are given in Figure D-2. The table also gives a
brief description of each command as it is de-
fined by ilmilinc .

Controller_Logic_mil.dat Controller logic model.

TABLE D-2 Interleaf Markup Commands

Command Description

<“Author”> Command on the title page that formats the name of the
company providing the document (see Figure D-2).

<“body1”> Normal text paragraph format.

<“body2”> Indented text paragraph which can be use to align with
the text in a numbered list (first level number).

<“body3”> Indented text paragraph which can be use to align with
the text in a numbered list (second level number).

<“CDRL”> Title page CDRL sequence number (see Figure D-2).

<“chap”> Chapter heading level.

<“Client”> Title page entry for the name of the client for who the doc-
ument was prepared (see Figure D-2).
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<“contract”> Title page entry for the contract number (see Figure D-2).

<“DocTitle”> Document title (see Figure D-2).

<“dummy”> First paragraph on the title page. This is an empty place
holder required to provide the correct spacing from the top
of the page.

<“FIGcap”> Automatically numbered figure caption.

<“head1”> First heading level (e.g., 1.1).

<“head2”> Second heading level (e.g., 1.1.1).

<“head3”> Third heading level (e.g., 1.1.1.1).

<“head4”> Fourth heading level (e.g., 1.1.1.1.1).

<“head5”> Fifth heading level (e.g., 1.1.1.1.1.1).

<“list1”> Upper case Alpha list (automatic numbering).

<“list2”> Numeric list (automatic numbering).

<“list3”> Lower case alpha list (automatic numbering).

<“NOTE”> Note paragraph with the word NOTE included.

<“NOTE+”> Indented paragraph that aligns with the text in the NOTE
paragraph (the word NOTE is not included).
This is used when a note has a second paragraph.

<“PrepBy”> Title page entry (see Figure D-2).

<“PrepFor”> Title page entry (see Figure D-2).

<“Rev”> Revision and date entry on the title page (see Figure D-2).

<“row”> Table row.

<“TBLcap”> Table caption.

<“TBLhead”> Column headings in a table.

<“TitlePar1”> Title page entries (see Figure D-2).

<“TitlePar2”> Title page CSCI name and system name entries
(see Figure D-2).

TABLE D-2 Interleaf Markup Commands

Command Description
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D.2 Generating the 2167A Document

To generate the sample 2167A document using DocumentIt and Interleaf, follow
these steps:

NOTE: If you want to generate a document from your own model, follow the same
steps given in this example, but use your own model for document
generation.

1. From your system prompt, go to your Interleaf desktop directory (do not invoke
Interleaf) using the change directory  command.

2. Copy all files from:

UNIX:     $CASE/DIT/templates/fmaker/general
WIN95/NT:  %CASE%\DIT\templates\fmaker\general

to the document directory.

3. From the Catalog Browser File menu, select Load.

4. Browse through the document directory and double-click to load the file
Controller_Logic_mil.dat .

5. In the Catalog pane of the Catalog Browser, select the top-level SuperBlock (in
this case, Controller_Logic).

6. From the Catalog Browser, select Tools→DocumentIt. The Generate Documen-
tation dialog will appear.

7. In the File Name field, enter Controller_Logic_mil.asc .

8. With the Block Parameters  combo box, select %Vars from Xmath .

9. In the Template File field, specify ilmil.tpl  as the template file.

10. Click the Typecheck  check box.

11. To generate the ASCII document file, click OK.
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D.2.1 Changing the Generic Title Page

12. The ASCII file that you have generated (in this case,
controller_logic_mil.asc ) includes a generic title page that appears as
shown in Figure D-1 after it is opened from Interleaf. If you want to change the
data on the title page, you can accomplish this in three different ways:

● Using a text editor you can edit the ilmil.tpl data. Figure D-2 shows the
data in the ilmil.tpl file that produces the title page shown in
Figure D-1. You should make these changes to ilmil.tpl before you gen-
erate the document from SystemBuild. All subsequent documents gener-
ated by DocumentIt using ilmil.tpl will continue to have your new title
page (until you change the contents of ilmil.tpl  again).

● Using a text editor you can edit the ASCII output file you have just gener-
ated. Figure D-2 shows the data in the example file
controller_logic_mil.asc that produces the title page shown in
Figure D-1. If you regenerate the document, you will have to edit this file
again.

● If you are familiar with Interleaf, you can edit the title page after you have
opened the file from Interleaf.

13. From the system prompt, invoke Interleaf.

14. From Interleaf open Controller_Logic_mil.asc .

15. After the file is opened, you will see that it is completely formatted.

16. If the new document meets your specifications, you can save and print it.

NOTE: See Using Your Own Templates on page D-1 for information about using
your templates instead of the supplied templates.

You can use the DocumentIt template ilmil.tpl and its associated include file
ilmilinc in precisely the same manner for your own models to generate a docu-
ment using Interleaf.

To generate documentation using your own templates, copy the supplied example
files and modify them. The purpose of each file is given in Table D-1 on page D-2.

dit.book  Page 5  Tuesday, September 28, 1999  8:47 AM



Generating 2167A Documents Using Interleaf DocumentIt User’s Guide

D-6

FIGURE D-1 Generic Title Page
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FIGURE D-2 Title Page Data in ilmil.tpl and controller_logic_mil.doc

<“Rev”>
 Revision X.X: November 26, 1993

<“DocTitle”>
 Software Design Document

<“TitlePar1”>
 For The

<“TitlePar2”>
 CSCI NAME

<“TitlePar1”>
 Of

<“TitlePar2”>
 System Name

<“contract”>
 XXXXX.XX

<“CDRL”>
XXXXXX.nnn

<“PrepFor”>
 Prepared for:

<“Client”>
Contracting Agency Name, Department Code

<“PrepBy”>
 Prepared by:

<“Author”>
 Integrated Systems, Inc.

dit.book  Page 7  Tuesday, September 28, 1999  8:47 AM



Generating 2167A Documents Using Interleaf DocumentIt User’s Guide

D-8

D.2.2 Adding a Plot or SystemBuild Diagram to an Interleaf Document

17. To place a plot or SystemBuild diagram in your Interleaf document, perform the
following procedure:

a. Use the hardcopy command to create a postscript file of each plot or
SystemBuild diagram you want to include.

b. You must then convert each postscript file to an Interleaf image file. The fol-
lowing diagram illustrates the conversion process (using psfilt ) for each
postscript file.

Run each postscript file through the Interleaf psfilt filter by selecting
custom→misc→psfilt.

NOTE: If the psfilt filter is not set up, consult your Interleaf manual
for instructions on how to set it up.

18. Use the include_img() segment to add the image to your generated docu-
ment. (Consult Chapter 3 of the TPL User’s Guide for information about
include_img() .) Perform the following procedure:

a. At the bottom of the $ISIHOME/ platform /case/DIT/templates/il-
eaf/milstd/ilmil.tpl template file is a SEGMENT include_img() line.
Example D-1 on page D-9 shows a portion of this SEGMENTsection (details
of the frame itself are omitted).

Include this SEGMENT section in your own tpl file.

file.ps psfilt file.ps1.img
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EXAMPLE D-1: Example of include_img() in tpl File

@SEGMENT include_img()@

<Frame,

Name = “floating”,
Placement = Following Anchor,
Horizontal Alignment = Center,
Width = 6.50 Inches,
Width = Page Without Margins,
Height = 9 Inches,
Height = Page Without Margins,
Page # = Autonum,
Diagram =

V11,
(g9,1,0,
(i18,1,0,,0,0,8.5333325,0,0,10.9999992,0,0,2559,3299,1,0,7,0,0,8.5333325,10.999
 9992,673657859,1,2559,0,0,3299,0,0,2559,3299,0,0,0,0,0,2559,3299,1,255,
 @sb_mangled_name_s.ps1.img,2,639,0,0,824,0,0,2559,3299,0,0,0,0,0,486,674,1,1,
3157  (X0,3157,FBC8FCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCFCF
CFCFC

                                       .     (rest
                                       .      of
                                       .      frame)

   FC91F9C706070EC7010AFCA1E50114FCA1EB0128FCA1F029FC9AC9E12D71FC9AC9DE5D79FCA1
   CAC1C896DFE4FF))
(E16,0,0,,5,1,1,0.0533333,1,15,0,0,1,0,0,0,1,5,127,7,0,0,7,0,1,1,0.0666667,0.06
 66667,6,6,0,0.0666667,6))>

@ENDSEGMENT@

b. Scope on a SuperBlock. The @include_img() @ statement in the SEGMENT
section will include the currently scoped SuperBlock’s image file in your
generated document.

If you wish, you can customize the image in the include_img() segment
(see Example D-1). Consult your Interleaf manual. You should be familiar
with Interleaf markup language.

c. To incorporate a plot, make a copy of the include_img() segment
(Example D-1), and replace @sb_name_s@.psl.img (highlighted in
Example D-1) with the name of your plot image file.
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E Generating Documents Using
Microsoft Word

This appendix describes how to use the Microsoft® Word documentation example.
This includes describing how to:

■ Generate documents and encapsulated PostScript™ files.

■ Import encapulated PostScript (.eps ) files into a generated document automat-
ically and manually.

■ Format table data for Microsoft Word.

All Microsoft Word documentation example files for Windows platforms, including a
sample file that demonstrates these tasks, are located in the
%CASE%\DIT\templates\msword\general\mswgp.wrd  file.

E.1 Using Your Own Templates

To customize your generated document, make a copy of this file in your local direc-
tory and make appropriate changes. You must regenerate your document, every
time you make changes to mswgp.tpl  and mswgp.wrd .

If you want to generate documentation using your own templates, consider copying
the supplied example files and then modifying them. The purpose of each file is
given in Table E-1 on page E-2.

NOTE: Your templates must be in rich text format (RTF), with TPL commands
included. Do not make a template in Microsoft Word format.

The mswgp.tpl and mswgp.wrd files are in the %CASE%\DIT\templates
\msword\general directory. The Controller_Logic_gen.dat file is in the
%CASE%\DIT\templates\ascii  directory.
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E.2 Generating a Sample Document

To generate a sample document using DocumentIt and Microsoft Word, follow these
steps:

NOTE: If you want to generate a document from your own model, follow the same
steps given in this example, but use your own model for document
generation.

1. Create a directory where you want the output document to reside.

2. Copy all files from:

%CASE%\DIT\templates\msword\general

to the document directory.

TABLE E-1 Microsoft Word Documentation Example Files

Files in %CASE%\DIT\templates\msword\general :

mswgp.tpl The template file you must specify when using
DocumentIt to generate an ASCII output file
for use with the Word general purpose docu-
mentation. It determines what information is
extracted from the model to create an ASCII
output file.

mswgp.wrd This is a template file included in the
mswgp.tpl  file. This file specifies RTF com-
mands, which are recognized by Word. It con-
tains the template TPL command to search the
model for SuperBlocks and Blocks, and has
RTF commands embedded with template TPL
commands to generate the output document.
You can load this file into Word to change the
template program or font settings for the title/
section names. The changes appear when you
regenerate the document. Load this document
into MS Word, to see what the generated docu-
ment will look like.

Files in %CASE%\DIT\templates\ascii :

Controller_Logic_gen.dat Controller logic model.
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3. From the Catalog Browser select File→Load.

4. Browse through the document directory and double-click to load the file
Controller_Logic_gen.dat .

5. In the Catalog pane of the Catalog Browser, select the top-level SuperBlock (in
this case, Controller_Logic).

6. From the Catalog Browser, select Tools→DocumentIt. The Generate Documen-
tation dialog appears.

7. In the File name field, enter Controller_Logic.doc . This output file is created in
your working directory unless you specify another path.

8. With the Block Parameters  combo box, select %Vars from Xmath .

9. In the Template File field, specify msgwp.tpl  as the template file.

10. Click the Typecheck  check box.

11. Click the MS Word check box.

12. To generate the document file, click OK.

If you have any graphics files to include in the document, follow the steps below, be-
ginning with Section E.2.1. If you have no graphics to include, skip to step 1 on
page E-5.

NOTE: After you generate a document file, you may need to or want to make
format changes to select desired fonts, font sizes, and other typographic
choices.
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E.2.1 Generating an .eps  file from SystemBuild

To generate an .eps  file from SystemBuild, take these steps:

1. Highlight the top level SuperBlock (Controller_Logic).

2. Select File→Page Setup to make any adjustments to the image before creating
the graphics file. In this case, accept the defaults.

3. Select File→Print to File.

4. From the format pull-down, select EncapPostScript .

5. From the output pull-down, select Separate files .

6. Click OK.

7. By default DocumentIt automatically includes all the SuperBlock diagrams in
the generated document. This is done by inserting template function
@include_img@ under every SuperBlock scope where the image is to be in-
cluded. The template mswgp.tpl is written to handle only importing .eps files
into the Word document. The generated document has links to the .eps files in
your local directory. So every time you update the graphics file, it will be auto-
matically reflected in your generated document. For details on .eps files refer to
the Template Programming Language User’s Guide.

@include_img()@ is a template TPL segment defined in mswgp.tpl . This segment
contains the RTF commands to include a graphics file named
@sb_mangled_name_s@.eps . The @sb_mangled_name_s@ token is filled in with
the appropriate SuperBlock when you scope to a particular SuperBlock. For details
on scoping SuperBlocks, refer to the Template Programming Language User’s Guide.
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A typical example to include SuperBlock 1 graphics into your document would look
like this:

@SCOPE SUPERBLOCK 1@
@include_img()@

E.2.2 Changing the Generic Title Page

1. The document file that you have generated (in this case,
Controller_Logic.doc ) includes a generic title page that appears after it is
imported into Microsoft Word (as shown in Figure E-1 on page E-6). If you want
to change the data on the title page or change the template TPL commands, you
can accomplish this in three different ways (see Using Your Own Templates on
page E-1):

● If you are familiar with Microsoft Word, load the file mswgp.wrd . Word inter-
prets the RTF in this file and displays the template program commands
along with chapter titles, section headings. you can edit the title page in the
first page and save the document (after you open the document in Word). All
subsequent documents generated by DocumentIt using mswgp.wrd will
continue to have your new title page (until you change mswgp.wrd  again).

● Using a text editor you can edit the mswgp.wrd file. If you are familiar with
RTF format, you can search for title generation and modify it there. You
should make these changes to mswgp.wrd before you generate the docu-
ment from SystemBuild. All subsequent documents generated by
DocumentIt using mswgp.wrd will continue to have your new title page (un-
til you change mswgp.wrd  again).

● Using a text editor you can edit the output document you have just gener-
ated. If you are familiar with RTF format, you can search for title generation
and modify it there. If you regenerate the document, you will have to edit
this file again.

2. Generate a new DocumentIt output file.

3. Start Microsoft Word.

4. From the File  pull-down menu, select Open.

5. In the Open dialog, select Controller_Logic.doc and click OK. You can verify
your changes in the new output file.
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If you have graphics files you want to include in the document, see Importing Graph-
ics. If you have tabular information, see Creating Tables.

E.2.3 Importing Graphics

1. To place an illustration in your document manually, you must insert an an-
chored frame in the page where you want the figure to appear. You can insert an
anchored frame in your document by selecting the Insert pull-down menu. A
blank frame will be placed into your document in the location you specified.

2. Now you can select Picture under the Insert pull-down menu. There you can se-
lect the graphics file you want to import. Click Link to File in the dialog, to create a
link to your graphics file. Refer to your Microsoft Word documentation for more
information about using the Insert utility to insert and import pictures.

FIGURE E-1 Generic Title Page
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E.2.4 Creating Tables

You can use DocumentIt to format tabular data to open as formatted tables when
opened in Microsoft Word. These tables display as “standard” Microsoft Word tables.
To see an example, generate the example document, and then examine the
mswgp.wrd template file using Microsoft Word. For information on how to create
tables, see the procedure in the next section.

E.2.5 Converting Tabular Data to Tables

To set up tabular data so the DocumentIt template converts them to Microsoft Word
tables, the input data must have Tab characters (>) separating columns and end-of-
paragraph characters (¶) separating rows.  Follow these steps to create a table.

1. Select all the data you want to include in the table, but do not include the last
paragraph symbol in the last row of table data (see Figure E-2 for an example of
exactly what information you need to select for reformatting).

2. From the pull-down menu, select Table→Convert Text to Table. When the Con-
vert Text to Table dialog appears, select AutoFormat and select “Grid 5” under that
and then leave the settings intact and click OK for the AutoFormat and click OK
for the Text to Table dialog. You can choose any design under the AutoFormat.

Do not include last
paragraph symbol

Table Data

FIGURE E-2 Marking Data for Table Formatting

of table data
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3. Delete any extraneous paragraph symbols that may have appeared below the
table during the conversion process (this is necessary due to the way Microsoft
Word converts tables).

4. Perform the above steps for each table you have in the document. If you are go-
ing to choose the same Format for all the tables, then follow step a, and select
Repeat Text to Table under the Edit pull-down menu; this will repeat the macro
for the table conversion.

5. Save your document.

E.2.6 Creating a Table of Contents

The DocumentIt template is unable to generate a table of contents (TOC); however,
the template does create sections within the document so that it is easy to have
Microsoft Word generate the TOC.

1. Go to the Table of Contents page in the document and place the cursor on that
page.

2. From the pull-down menu, select Insert→Index and Tables. When the dialog ap-
pears, click List Table of Contents .

3. Leave all the current settings in the Set Up Table of Contents dialog intact and
click OK.

Microsoft Word fills up the page with the Table of Contents. As Word lists all
items in the order in which they appear in a document, some minor formatting
is required for the list of figures. Repeat this process for the list of tables.

4. From the pull-down menu, select File→Save to save the document.

dit.book  Page 8  Tuesday, September 28, 1999  8:47 AM



F-1

F

F Generating ASCII Documents

This appendix describes how to use the ASCII document example. All ASCII docu-
ment example files are located in:

UNIX:     $CASE/DIT/templates/ascii/general
Windows:   %CASE%\DIT\templates\ascii\general

The files in this directory are:

NOTE: If you want to generate a document from your own model, follow the same
steps given in the example that follows, but use your own model for
document generation.

To generate the sample ASCII document using DocumentIt, follow these steps:

1. Create a directory for the output document (for example, docout ).

2. Copy the template files from:

UNIX:     $CASE/DIT/templates/ascii/general
Windows:   %CASE%\DIT\templates\ascii\general

to the document  directory.

3. From the Catalog Browser File menu, select Load.

documentit.tpl This is the supplied default template file that is
used by DocumentIt to generate an ASCII out-
put file when no other template file is specified.

Controller_Logic_gen.dat Controller logic model
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4. Browse through the document directory and double-click to load the file
Controller_Logic_gen.dat .

5. In the Catalog pane of the Catalog Browser, select the top-level SuperBlock (in
this case, Controller_Logic).

6. From the Catalog Browser, select Tools→DocumentIt. The Generate Documen-
tation dialog appears.

7. In the File name field, enter a name for your document (for example,
Controller_Logic _gen .txt) .

8. With the Block Parameters  combo box, select %Vars from Xmath .

9. In the Template File field, specify documentit.tpl  as the template file.

10. Select the Typecheck  check box.

11. To generate the ASCII document file, click OK.

You can use the default template documentit .tpl to generate an ASCII document
for any valid model.

To generate documentation using your own templates:

■ Copy documentit.tpl file.
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■ Modify it to your specifications using the TPL programming information
described in the Template Programming Language User’s Guide. You can also
embed markup language commands to import the ASCII files into your software
publishing application, or print the document.
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template programming language

See the Template Programming
Language User’s Guide.

templates 1-3

examples 1-3
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See also the "TPL User’s Guide."
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user-written B-1, C-1, D-1, E-1, F-2
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See the Template Programming
Language User’s Guide.
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See "templates."
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Technical Support and Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/training for self-paced tutorials, videos, 
and interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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