
Getting Started with the LabVIEW™ Mobile Module
The LabVIEW Mobile Module extends the LabVIEW graphical development environment to Mobile
devices so you can create applications that run on Windows Mobile and Pocket PC. You can create
portable solutions for a wide spectrum of applications, such as field test systems, remote control and
monitoring systems, and portable data acquisition systems.

This manual contains installation instructions for additional tools you might need to use with the Mobile
Module and a tutorial that shows you how to create a LabVIEW project and build, run, deploy, and
debug a Mobile application. Refer to the LabVIEW Mobile Module Readme, available by opening
readme_Mobile.html on the installation media, for system requirements and instructions about
installing the Mobile Module.
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Installing Additional Tools
After installing the Mobile Module, you might need to install additional tools on the target depending
on the functionality you need.

Shared Variable Support
To use front panel data binding and Shared Variable nodes in Mobile applications, you must install the
latest version of shared variable support on the target.

Complete the following steps to install or uninstall support for shared variables on a Mobile target .
1. Connect the device to the host computer using ActiveSync/FTP.
2. Navigate to and run labview\PDA\Utilities\Variables\PocketPC\Setup.exe.

Tip You also can right-click the target in the Project Explorer window and select
Install»Support for Shared Variables from the shortcut menu.



PNG Image Support
You must install support for PNG images on the target if the VI contains PNG images on the user
interface.

Complete the following steps to install or uninstall support for PNG images on a Mobile device using
ActiveSync/FTP.
1. Connect the device to the host computer using ActiveSync/FTP.
2. Navigate to and run labview\PDA\Utilities\LVPNG\PocketPC\Setup.exe.

Tip You also can right-click the target in the Project Explorer window and select
Install»Support for PNG Images from the shortcut menu.

NI-VISA Support
You must install NI-VISA on the target to use VISA in Mobile applications. If you did not install
NI-VISA when you installed the Mobile Module, select Start»All Programs»National
Instruments»VISA»Windows Mobile Driver Installation.

Tip You also can right-click the target in the Project Explorer window and select
Install»Support for NI-VISA from the shortcut menu.

WIDCOMM Bluetooth DLLs
You can use the WIDCOMMBluetooth DLLs on a Mobile device to run applications that use Bluetooth
communication if you do not have the Microsoft Bluetooth driver.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.
1. Connect to ActiveSync on the host computer.
2. On the host computer, run labview\PDA\Utilities\Bluetooth\Setup.exe to install the

DLLs on the device.

Tip You also can right-click the target in the Project Explorer window and select
Install»Support for WIDCOMM Bluetooth from the shortcut menu.

Refer to README.txt, located in the labview\PDA\Utilities\Bluetooth directory, for more
information about manually installing the WIDCOMM Bluetooth DLLs.

Note The Mobile Module supports the WIDCOMM BTW-CE 1.4 or later driver. Do not
install the WIDCOMM Bluetooth DLLs if you are using the Microsoft Bluetooth driver or
you receive an error when you use the Bluetooth VIs and functions. If your device uses the
Broadcom Bluetooth driver, install the LabVIEWWIDCOMMBluetooth driver by manually
copying LVBtw.dll from the labview\PDA\Utilities\Bluetooth directory to the
Windows directory. Do not run Setup.exe and do not copy BtCoreIf.dll or
BtSdkCE30.dll if they already exist on the device.

LabVIEW SMS Client
You must install and run the LabVIEW SMS Client, which is located in
labview\PDA\Utilities\SMS\device\Setup.exe, on the host computer to receive ShortMessage
Service (SMS) messages or to use the Request Make Call VI. The LabVIEW SMS Client notifies the
Mobile application if there is an incoming SMS message and stores the incoming message in
LVSMSClient.dat, which is located in the \Program Files\National
Instruments\labview\SMS directory on the target.
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Complete the following steps to install or uninstall the LabVIEW SMS Client on a Mobile target.
1. Perform a soft reset on the device. Refer to your device documentation for information about

performing soft resets.
2. Connect the device to the host computer using ActiveSync.
3. Run Setup.exe on the host computer to install or uninstall the required DLLs.

You also can right-click the target in the Project Explorer window and select Install»Support for
SMS Client from the shortcut menu.

NI-DAQmx Base
You can download the latest version of NI-DAQmx Base for use with Mobile devices from the National
Instruments Web site. After you complete the NI-DAQmx Base installation, you must copy the driver
files to the device.

Complete the following steps to install NI-DAQmx Base on the Mobile device.
1. Select Start»Programs»National Instruments»NI-DAQmx Base»Utilities.
2. Launch the Driver Installation utility that corresponds to the Mobile device.
3. Check the device screen to see if any additional steps are requested, such as replacing an older

driver.

Refer to the NI-DAQmx Base Readme and the NI-DAQmx Base 3.x Getting Started Guide for more
information about NI-DAQmx Base.

Windows Mobile Emulators
Emulators are tools you can use during development to run and test Mobile VIs quickly without having
to download the application to the target.

ARM Emulators
If you are using ARM-based emulators, you must install Virtual PC 2007.

(Windows Vista) If you want to use emulators on the host computer, you must download the Microsoft
Device Emulator 2.0.

DownloadVirtual PC 2007 and theMicrosoft Device Emulator 2.0 from theMicrosoft Download Center
at www.microsoft.com/downloads.

x86 Emulators
(Windows XP) On the host computer, the Mobile Module installs ARM targets, including emulators,
for Windows Mobile and Pocket PC. If you need x86 emulator targets, install the following Microsoft
eMbedded Visual Tools:
• Microsoft eMbedded Visual C++ 4.0
• Microsoft eMbedded Visual C++ SP 4 or later
• SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni.com/info and enter the Info Code pdaevc
for the most recent information about downloading and installing theMicrosoft eMbedded Visual Tools.

Tutorial
Use this tutorial to learn how to use the Mobile Project Wizard to create a LabVIEW project and build,
run, and debug a Mobile application.

The VI in this tutorial simulates a sine wave with configurable offset and frequency values and displays
the result in a graph.
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Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and non-LabVIEW files, create build
specifications for building a Mobile VI into an application, and deploy the application to the target. You
must use a project to build a Mobile VI into an application.

Using the Mobile Project Wizard, complete the following steps to create a LabVIEW project, add the
target, and add an existing VI to the project.
1. Launch LabVIEW. In the Getting Started window, selectMobile Project from the Targets

pull-down menu. Click the Go button to launch the Mobile Project Wizard.
2. Define the project information as shown in Figure 1.

a. Select New Mobile project, import VI from the Project type pull-down menu to create the
LabVIEW project using an existing VI.

Tip The blank VI project type creates a project with a newMobile template VI rather
than importing an existing VI.

b. Specify a project name and the location where you want to save the project and the VI in the
Project location text box. Save the project to a location other than the default location so you
do not overwrite the shipping example with your changes. The default project name is
Untitled project.lvproj. For this tutorial, name the project Mobile Tutorial.lvproj
in the Project location text box.

c. Click the Browse button next to the VI path text box and navigate to labview\examples\
WindowsMobile\tutorial\Mobile Tutorial.vi to select the VI to import. Click the
OK button to add the VI to the project you are creating.
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Figure 1. Defining the Project Information

3. Click the Next button.
4. SelectWindows Mobile 5.0 Pocket PC Emulator from the Device type pull-down menu, as

shown in Figure 2.
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Figure 2. Selecting the Target

Note You might see additional targets for Windows Mobile or Pocket PC if you
configure additional devices through the Microsoft Device Emulator Manager.

5. Click the Next button.
6. Click the Finish button. Because theCreate a build specification checkbox contains a checkmark,

as shown in Figure 3, theMobile Build Specification Properties dialog box opens. Refer to the
Creating the Build Specification section for more information about creating a build specification.
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Figure 3. Previewing the Project

Creating the Build Specification
Build specifications contain the build settings and code generation options to use when you build a
Mobile VI into an application. You can create the build specification when you create a project or wait
until you are ready to build the application. You must create a build specification before you can build
a Mobile VI into an application.

You can have multiple build specifications for the same target. For example, you might want one build
specification that generates debugging information and another build specification that does not generate
this extra information.

Note This tutorial creates the build specification through the Mobile Project Wizard. You
also can create a build specification at any time by right-clicking Build Specifications under
the target in the Project Explorer window and selecting New»Mobile Application (EXE)
from the shortcut menu.

Complete the following steps to create a Mobile build specification.
1. Define the settings for the Mobile application, as shown in Figure 4.

a. Enter Mobile Tutorial in the Build specification name text box. This is the name that
appears under Build Specifications in the Project Explorer window.

© National Instruments Corporation 7 Getting Started with the LabVIEW Mobile Module



b. (Optional) By default, the name of the application is the same as the top-level VI. If you do
not want to use the top-level VI name for the application name, remove the checkmark from
the Same as top-level VI checkbox and enter a name in the Target filename text box.

c. Browse to and select the destination directory for the application on the host computer, which
is where LabVIEW saves the .exe, in the Destination directory text box.

d. Enter the destination directory for the application on the target in the Remote path for target
application text box.

Figure 4. Defining the Application Information

Note Although it is common to use the same name for the VI, application, and
build specification, you are not required to do so.

2. (Optional) Click the Help button to open the LabVIEW Help and read a description of each build
setting.

3. Select theDevice Information category to view which target and processor this build specification
applies to.

4. Select the Source Files category to select the source files to include when you build the VI into an
application. When you use the Mobile Project Wizard to create a build specification, LabVIEW
automatically uses the VI you import as the top-level VI. When you create build specifications
outside of the wizard, you must manually select the top-level VI and click the blue arrow button
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to move the VI to the Top-level VI text box, as shown in Figure 5. Mobile applications can have
only one top-level VI.

Figure 5. Selecting the Source Files

Note The Source File Settings andMachine Aliases categories are not used in this
tutorial. You use the Source File Settings page to view and set VI-level code generation
options. You use theMachine Aliases page to overwrite the default IP address of a target
hosting shared variables so you can move the shared variables to a different host without
rebuilding the application. Refer to the Using Shared Variables (Mobile Module) topic
in the LabVIEW Help for more information about using shared variables.

5. Select theGenerated Files category to view the filenames and paths to the files theMobileModule
generates when you build the VI into an application.

6. Click the OK button. The build specification you just created appears in the Project Explorer
window under the Mobile target, as shown in Figure 6.
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Figure 6. Project Explorer Window

7. Select File»Save Project in the Project Explorer window to save the project. LabVIEW saves
any build specifications with the project.

Building the VI into an Application and Deploying
After you develop the VI on the host computer, you build the VI into an executable application that you
can run on a target. Select one of the options in the Using the Shortcut Menu section or the Using the
Run Button section of this manual to build, deploy, and run the application.

Click the Run button in the application on the target to start simulating the sine wave.

Note ARM emulators for Windows Mobile require a few minutes to load the OS before you
see the application running on the emulator target.

Using the Shortcut Menu
Right-click the build specification in the Project Explorer window and select one of the following
options from the shortcut menu:
• Deploy—Builds the VI into an application, if necessary, and deploys the application to the target.

This option does not run the application automatically.
• Run—Builds the VI into an application, if necessary; deploys the application to the target; and

runs the application automatically.
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• Build—Builds the VI into an application. This option does not deploy or run the application
automatically.

Note An Application Builder Information dialog box may appear when you deploy, run,
build or debug the application. By default, the Application Builder configures new build
specifications to include compiler optimizations that optimize the run-time performance of
your build application. However, if the target for your build specification does not support
SSE2 instructions, you must remove the checkmark from the Enable SSE2 optimization
checkbox on the Advanced page of the Properties dialog box for the relevant build
specification. For more information about enabling and disabling SSE2 optimizations, refer
to the Verifying That Target Hardware Supports SSE2 Instructions topic in the LabVIEW
Help.

Using the Run Button
When you run a VI under the Mobile target in the Project Explorer window, the Run button behaves
differently from when you run a VI under My Computer in the Project Explorer window:
• If you want to build, deploy, and run—Click the Run button in a VI to build the VI into an

application, deploy the application to the target, and run the application on the target.
• If you want to build without deploying or running—Press the <Ctrl> key while you click the

Run button in a VI to build the VI into an application without deploying or running the application.

Note LabVIEW prompts you to create a build specification if you do not have an existing
build specification for the VI. If you have multiple build specifications, LabVIEW prompts
you to select a build specification in the Select a Build Specification dialog box. Alternatively,
you can specify a default build specification by right-clicking a build specification in the
Project Explorer window and selecting Set as Default from the shortcut menu. LabVIEW
indicates the default build specification with a green square around the build specification
glyph in the Project Explorer window.

Closing the Application
Tap the Exit button in the application on the Mobile target to close the application.

Debugging the Application
Youmust create a build specification that enables debugging before you can debug aMobile application.
Enabling debugging generates extra debugging information and can significantly increase the size of
the application.

When LabVIEW on the host computer connects to the Mobile target, the application runs on the target.
The front panel is fully functional on the target. However, the front panel controls have no effect on the
application, and the indicators in the VI on the host computer do not reflect the execution of the application
on the target.

The block diagram acts as a conduit between the application running on the target and the VI running
on the host computer, where you can probe signals, set breakpoints, and step through code as you do in
any other VI.

Tip You can modify an existing build specification by double-clicking the build specification
in theProject Explorerwindow or right-clicking the build specification and selectingProperties
from the shortcut menu. This tutorial creates a second build specification for debugging.
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Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification.
1. Right-click Build Specifications under the Mobile target and select New»Mobile Application

(EXE) from the shortcut menu to open theMobile Build Specification Properties dialog box.
2. Enter (Debug) Mobile Tutorial in the Build specification name text box.
3. Remove the checkmark from the Same as top-level VI checkbox so you can change the application

name.
4. Enter (Debug) Mobile Tutorial.exe in the Target filename text box.
5. Place a checkmark in the Enable debugging checkbox to generate debugging information when

you build the VI into an application, as shown in Figure 7.

Figure 7. Creating the Debugging Build Specification

6. Select Source Files from the Category list and selectMobile Tutorial.vi in the Project Files list.
Click the blue right arrow button to move the VI from the Project Files list to the Top-level VI
text box.

7. Click the OK button. The build specification you just created appears in the Project Explorer
window, as shown in Figure 8.
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Figure 8. Two Build Specifications in the Project Explorer Window

Adding a Probe to the VI
Probes display information about the data that passes through a wire. As you interact with the application
on the target, you can see the data passing through the wire in the corresponding VI on the host computer.

Complete the following steps to add a probe to the Mobile Tutorial VI.
1. SelectWindow»Show Block Diagram in the VI to open the block diagram if it is not visible.

Tip Double-click the VI in the Project Explorer window to open the VI if the VI is not
already open.

2. Right-click the wire connecting the Frequency control to the For Loop and select Probe from the
shortcut menu.

A floating ProbeWatchWindow appears when you create a probe. LabVIEW numbers the probes
automatically and displays the same number in a glyph on the wire you probe, as shown in
Figure 9.
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Figure 9. Adding a Probe to the Block Diagram

Deploying and Debugging a Mobile Application
You must use the debugging build specification to deploy the application, which contains debugging
information, to the target before the probe in the VI on the host computer can update the values passing
through the wire.

Complete the following steps to deploy and debug the Mobile application.
1. Right-click the debugging build specification you want to build and deploy and select Debug from

the shortcut menu. Save any VIs if prompted.
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LabVIEW builds the VI into an application, deploys the application to the target, and runs the
application on the target as shown in Figure 10. A new instance of the emulator opens each time
you build and deploy an application.

Figure 10. Running the Application on the Emulator

2. Click the Run button in the application on the target.
3. Move the Frequency slider in the application running on the target and click theRun button again.

The value in the Probe Watch Window on the block diagram updates as you move the slider in
the application on the target.

Note Any changes you make on the front panel of the Mobile VI on the host computer
have no effect on the application running on the target.

4. Click the Exit button in the application on the target to stop the application and end the debugging
session.

Related Documentation
LabVIEW includes documentation for new and experienced LabVIEW users. The following documents
contain information that you might find helpful as you use the Mobile Module:
• LabVIEW Help—Refer to the LabVIEW Help, available by selecting Help»LabVIEW Help in

LabVIEW, for information about LabVIEW programming concepts, step-by-step instructions for
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using LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus,
and tools. Refer to theMobile Module book on the Contents tab of the LabVIEW Help for
information specific to the Mobile Module and Mobile applications. The LabVIEW Help uses
(Mobile) in the index to indicate Mobile-specific topics.

• LabVIEWMobile Module Readme—Refer to the LabVIEWMobile Module Readme, available
by selecting Start»All Programs»National Instruments»LabVIEW»Readme and opening
readme_Mobile.html, for last-minute information and known issues.

• Mobile Module Examples—Use the Mobile Module examples to learn how to use certain VIs
and functions as well as a starting point for developing your ownMobile VIs and applications.
You can modify an example to fit an application, or you can copy and paste from one or more
examples into a VI that you create. Browse or search the example VIs with the NI Example
Finder by selecting Help»Find Examples.

• NI-DAQmx Base 3.x Getting Started Guide
• NI-DAQmx Base Readme
• Documentation for your device.
• LabVIEW PDFs—In addition to this document, the Getting Started with LabVIEW manual,

LabVIEW Quick Reference Card, LabVIEW Release Notes, and LabVIEW Upgrade Notes are
available as PDFs by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEWManuals.

Note You must have Adobe Reader installed to view the PDFs. Refer to the Adobe
Systems Incorporated Web site at www.adobe.com to download Adobe Reader. Refer
to the National Instruments Product Manuals Library at ni.com/manuals for updated
documentation resources.

LabVIEW, National Instruments, NI, ni.com, the National Instruments corporate logo, and the Eagle logo are
trademarks of National Instruments Corporation. Refer to the Trademark Information section at ni.com/trademarks
for other National Instruments trademarks. Other product and company namesmentioned herein are trademarks
or trade names of their respective companies. For patents covering National Instruments products/technology,
refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the
National Instruments Patent Notice at ni.com/patents. Refer to the Export Compliance Information at
ni.com/legal/export-compliance for the National Instruments global trade compliance policy and how to
obtain relevant HTS codes, ECCNs, and other import/export data.
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