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About This Manual

This manual, NI DIAdem: Acquiring and Visualizing Data, explains how to create block 
diagrams for solving measurement tasks and how to design visualizations. 

The first chapter describes how you create a block diagram step by step, without measurement 
hardware. You select a data source, display instruments and operating instruments and define a 
condition to control when the data is saved.

The second chapter describes how to configure measurement hardware and to register the 
hardware in DIAdem. You can use one of the interfaces that DIAdem supports, to communicate 
with external measurement devices.

The third chapter describes how to select a block for each function, and how to connect the 
blocks to suit the task. DIAdem distinguishes between data buses, control buses, system buses, 
packet buses, alarm buses, and text buses, each of which transports different signals. You can 
save and import partial tasks of a block diagram as a subdiagram block. 

The fourth chapter describes the visualization associated with the block diagram and explains 
the available display and operating functions. In DIAdem VISUAL you position the display 
instruments and the input instruments and you group the instruments on VISUAL pages. In 
DIAdem DAC you connect display blocks to create event-related visualizations. 

The fifth chapter describes how to use packet processing in order to acquire data in packets, to 
process the data, and to show the data in a 3D display. With packet processing you can increase 
the throughput, use special measurement hardware, or use manual display instruments which 
you can operate during a measurement.

The sixth chapter describes the alarm system that you use to monitor processes by generating 
alarms, displaying alarms, sending alarms in e-mails, and recording alarms. The user can delete 
the alarms as soon as the cause has been found and eliminated.

The seventh chapter describes the basics of digital data acquisition and discusses topics such as 
the resolution, the measurement range, and the sampling rate. The chapter also describes the 
measurement modes available in DIAdem.

Conventions
The following conventions are used in this manual:

<> Angle brackets indicate a key you press to perform a function, for 
example, <Ctrl> for the control key.

» The » symbol leads you through nested menu items and dialog box 
options to a final action. The settings Help»Examples instruct you to 
open the Help menu and select the menu item Examples. 
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This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in DIAdem, such 
as menu items and dialog box options. Parameters are also in bold type.

italic Italic text denotes variables, emphasis, cross-references, or an 
introduction to important concepts. 

monospace Text in this font denotes text or characters that you should enter from 
the keyboard, such as sections of code, programming examples, and 
syntax examples. This font is also used for the proper names of disk 
drives, paths, folders, programs, subprograms, subroutines, device 
names, functions, operations, commands, variables, controls, events, 
methods, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the 
computer automatically outputs to the screen. 

Related Documentation
For more information on DIAdem, refer to the following documentation:

• Getting Started with NI DIAdem

You can use this DIAdem manual to familiarize yourself with DIAdem features and how to 
use them. The manual includes exercises for mining, analyzing, presenting data, and 
combining several steps into a script. 

• NI DIAdem: Data Mining, Analysis, and Report Generation

This DIAdem manual explains the structure of DIAdem and how to use DIAdem to mine 
data, to run analyses, to create reports, and to combine all functions in a script.

• DIAdem Help, which you open by selecting Help»Contents, or <F1>.

The DIAdem help offers you procedures and dialog box help for each panel, as well as 
references to functions, commands, and variables for programmers. 

• NI DataFinder Server Edition: Search Engine for Technical Data

This manual describes how you use the DataFinder server to index data files in networks. 
Users connect DIAdem with a DataFinder server to search for the indexed data. 
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1
Getting Started with DIAdem DAC

With DIAdem DAC and DIAdem VISUAL you acquire data, control processes, and visualize 
data. In DIAdem DAC you create block diagrams to acquire measurement values and to process 
and output the measurement values during the measurement. In DIAdem VISUAL you design 
the visualization to display the acquired and calculated measurement values and to influence the 
measurement with input instruments.

DIAdem is the interactive National Instruments software for finding and managing technical 
data, for mathematically and graphically-interactively analyzing data, and for presenting data in 
reports. In a uniform environment, DIAdem offers a unique combination of tools that are tailored 
to the requirements of technicians, engineers, and scientists. All tools can be adjusted to your 
requirements and can be automated in scripts. 

Acquiring Measurement Data
In DIAdem DAC you select functions blocks from the various function groups and connect them 
with signal buses, to create block diagrams. The measurement data is transferred from data 
sources to processing blocks, display instruments, and output blocks. 

To create a block diagram with a simulated signal source, complete the following steps:

Note You can substitute simulation signals later with measured data.

1. Select DIAdem DAC.

2. Click New Block Diagram.

3. Click Simulation Inputs on the group bar.
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4. Click Function Generator in this function group.

5. Click Display Instruments on the group bar.

6. Click Numeric Display in this function group.

DIAdem inserts every new block in the top left corner of the workspace in DIAdem DAC. 

7. Drag the Digits1 block to the right of the Generator1 block.

8. Click the output on the right side of the Generator1. Left-click and and drag the green bus 
to the input on the left side of the Digits1 block. As soon as OK appears on the cursor, you 
can release the mouse button. 

The data source and the display instrument are now linked with a green data bus similar to 
Figure 1-1. 

Figure 1-1.  Block Diagram with Function Generator and Digits Display
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9. Click Start Display on the toolbar. 

DIAdem opens the DIAdem VISUAL panel and displays the simulated sine values in Digits 
display.

10. Click Stop Measurement.

Saving Measurement Data
Until now you have displayed the signal values, but the values are not yet saved. To document 
processes and to check results, DIAdem must save measurement values. 

To save the measurement data, complete the following steps.

1. Select DIAdem DAC.

2. Click System on the group bar. 

3. Click Save Data with Trigger in this function group. 

4. Position the Save1 block below the Digits display.

5. Click the green data bus and drag the bus to the data input of the Save block as shown in 
Figure 1-2.

6. Double-click the Save1 block.

a. Select Parameters.

b. Enter 1000 as the Number of values.

c. Click OK.
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7. Click Start Measurement. 

DIAdem stops the measurement as soon as 1,000 values are saved.

8. Select DIAdem DAC. 

The new channels Time1 and Generator1_1 are now visible in the default group of the 
Data Portal.

Figure 1-2.  Extended Block Diagram with Data Storage
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Monitoring Measurement Signals
In control blocks you define conditions for monitoring and controlling measurements. 

To save measurement values in relation to a condition, complete the following steps. 

1. Click Simulation Inputs on the group bar.

2. Click Slider Control in this function group. 

3. Position the Slider1 block below the Generator.

4. Click Control on the group bar.

5. Click Window in this function group. 

6. Position the Window1 block next to the Slider control.

7. Drag a green bus from the output on the Slider control to the input on the Window 
condition.

8. Double-click the Window1 block. 

a. Enter the lower limit -5 and the upper limit 5 in the signal list, as shown in Figure 1-3. 

b. Select Window exit as the Window Type.
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Figure 1-3.  Setting the Window Condition

c. Click OK.

9. Click the data bus between the Slider1 block and the Window1 block, and drag a new bus 
to the green bus between the Generator1 block and the Digits1 block.

The 2 at the input of the numeric display indicates that two signals now reach the block on 
this data bus.

10. Drag a bus from the output at the lower edge of Window1 to the input with the triangle at 
the top edge of the Save1 block, as shown in Figure 1-4.

This creates a red control bus that DIAdem uses to trigger data storage. Always connect 
control buses at the top or at the bottom of a block.
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Figure 1-4.  Extended Block Diagram with Slider Control and Window Condition

Storage Display
To display when the storage starts complete the following steps.

1. Click Display Instruments on the group bar.

2. Click Graphics in this function group.

3. Position the graphic to the right of the Save1 block.

4. Click the red control bus above Save1 and drag the control bus to the input with the triangle 
at the upper edge of the Graphics1 block, as shown in Figure 1-5.
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Figure 1-5.  Extended Block Diagram with a Storage Display

Visualizing Measurements
You can arrange the input instruments and display instruments, which are integrated in the block 
diagram, in DIAdem VISUAL and you can configure each instrument individually. 

To design the visualization complete the following steps.

1. Select DIAdem VISUAL.

The three instruments Slider Control, Numeric Display, and Graphic are staggered at the 
top left of the display area of DIAdem VISUAL.

2. Select the three instruments.

3. Click Align Horizontal Intervals and then Center Horizontally.

4. Click into the workspace to deselect it.
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5. Double-click the empty display instrument Graphic1. 

a. Select Parameters. 

b. Click Browse and load the file Saving.jpg.

c. Enable Keep aspect ratio.

d. Click OK.

6. Click Start Measurement. 

7. Drag the slider control up and down. 

As soon as the slider control leaves the specified window range of -5 to 5, DIAdem starts 
saving the measurement values and displaying the ongoing saving process as shown in 
Figure 1-6.

Figure 1-6.  Visualization with Input Instruments and Display Instruments

8. Click Stop Measurement or wait until DIAdem measures the specified 1,000 values and 
saves the values in new channels in the Data Portal.

9. Click Save Block Diagram As to save the block diagram.
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2
Installing Measurement Hardware 
and Communicating via Interfaces

To use DIAdem for measurements and open and closed-loop control, you need a measurement 
acquisition board that you can plug into the computer, or an external measurement device that 
you connect to the computer via an interface. You use the associated driver to access the 
measurement hardware. The function groups for the inputs and outputs contain blocks with 
prepared functions for connecting hardware and communicating via interfaces.

Installing Measurement Hardware
After you have installed the plug-in board on the computer or have connected an external 
measurement device through USB, the operating system prompts you to install the driver of the 
hardware manufacturer after the computer starts. Next you register the associated DIAdem 
driver, which communicates with the hardware driver, in DIAdem DAC. You can then assign 
driver functions to function groups in DIAdem DAC.

Installing the Hardware Drivers
Install DIAdem and the driver libraries supplied with your hardware and register the installed 
hardware on the operating system.

To use hardware from National Instruments, install the driver library NI-DAQmx and the 
Measurement & Automation Explorer (short NI MAX) where you configure the device 
parameters and the channel parameters of the hardware. You open NI MAX in the Windows 
Start menu. NI MAX lists the installed hardware and software from National Instruments in a 
tree view. Double-click Devices and Interfaces to display the installed acquisition boards and 
connected measurement devices. If you select an item, NI MAX displays the board properties. 
Click Self-Test to test the hardware. Click Test Panels to check the board functions.

To access National Instruments hardware with DIAdem, you create channels in NI MAX for all 
the required inputs and outputs. In DIAdem, you use the channel names specified in NI MAX to 
access these channels. To create a global NI-DAQmx channel, right-click Data Neighborhood 
in the tree and select New from the context menu. Select Global NI-DAQmx Virtual Channel. 
The Channel Wizard guides you through the configuration and specifies the measurement mode 
and the terminal. NI MAX lists all the virtual channels in the Data Neighborhood branch of the 
tree hierarchy as shown in the following figure. A wizard helps you define a two-point 
calibration on the Calibration tab. Scaling data delays data acquisition, which means that the 
channels are no longer real-time. To acquire data in real time, you can scale the measured values 
later in DIAdem, instead of in NI MAX.
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Figure 2-1.  Creating a NI-DAQmx Channel in the Measurement & Automation Explorer 
(NI MAX)

Registering and Configuring DIAdem Drivers
The DIAdem driver links the driver library of the manufacturer to DIAdem DAC. DIAdem 
drivers are in DLLs (DLL: Dynamic Link Library), which you register in DIAdem by selecting 
Settings»Options»Extensions»GPI Extensions. Click Default to check whether the DLL that 
is required for your hardware is already registered in DIAdem. Click Add to load an additional 
DLL. You can obtain the DIAdem driver and the driver library from the hardware manufacturer.

The DLL GfSnidaq.dll is required for communication between the driver library 
NI-DAQmx and DIAdem, and is registered by default, which means that the associated driver 
block is already in the driver inputs and driver outputs. To use the channels that are defined in 
NI MAX for data acquisition, open the Driver Inputs function group and click NI-DAQmx 
Driver. Double-click the block to open the block dialog box and select the channels you want. 
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Figure 2-2.  Using NI-DAQmx Channels in DIAdem

After the registration of most DIAdem drivers in DIAdem DAC, you must select Settings»
Single Point Processing»Driver Function Groups to specify which functions the driver offers 
for acquisition and output. This is not necessary for the NI-DAQmx driver. Here you can add, 
delete, and configure DIAdem drivers, signal inputs, signal outputs, and processing functions 
that the driver executes on the measurement hardware. Double-click a registered device to open 
the list of supported driver functions and click Options to change the parameters of the driver 
function selected in the list. Make sure that the device parameters such as the base address or the 
input voltage range are the same as the settings on the measurement hardware.

You usually use Plug&Play to specify system resources such as base address, IRQs, or DMA 
channels. The operating system and the hardware that is already installed ensure that the new 
hardware is integrated correctly. If you specify the system resources the hardware requires 
manually, ensure that no other application uses this resource. 

Note Usually you can only access installed hardware with different applications 
such as two DIAdem versions or with DIAdem and LabVIEW alternately and not 
simultaneously. National Instruments hardware recognizes this type of conflict at the 
driver level and displays an error message.

In the function groups Driver inputs, Driver outputs, and Processing DIAdem displays the 
registered driver functions. DIAdem saves the registered driver functions in the desktop file.

If you change the predefined settings or the assignments in the driver function groups later, the 
driver block settings in the block diagram remain unchanged. DIAdem saves the settings of the 
driver blocks included in a block diagram, in the block diagram. If you use different hardware, 
you can replace the driver blocks in the block diagram with the driver inputs and driver outputs 
from the new hardware. To do this, drag and drop the driver blocks of the new hardware onto the 
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blocks you want to replace in the block diagram. If possible, the settings of the previous blocks 
are used in the new blocks.

Communicating via Interfaces
You communicate with external measurement devices, which are connected to the computer via 
an interface, either directly via the OPC driver or the CAN driver, or indirectly via a control file 
or a VBS script. 

Using OLE for Process Control
DIAdem can communicate via the OPC (OLE for Process Control) interface as the OPC 
client with each OPC server that is registered on the computer, and can access either local 
measurement hardware or, via an OPC server, hardware that is located on the network. This 
enables you to connect DIAdem to field bus systems and the associated hardware. DIAdem DAC 
can provide multiple access to one OPC server and can access several OPC servers 
simultaneously.

Open the dialog box of the OPC block to register OPC servers, which are either on the same 
computer or on another computer in the network. When the OPC servers are registered, you can 
select the signals to be measured in the OPC Browser. In OPC applications the signals are called 
items. Drag and drop the signals into the signal list. You configure the communication on the 
tabs Parameters and OLE.

Using NI-XNET
With the NI-XNET driver, DIAdem can acquire and output data with the NI-XNET hardware.  
The NI-XNET hardware supports CAN (Controller Area Network), LIN (Local Interconnect 
Network), and FlexRay. Although the individual network types have a number of differences, 
NI-XNET offers an API (Application Programming Interface) that allows all three network 
types to be accessed with similar functions.

A database file in Field Bus Exchange format (FIBEX) describes the network (Cluster) and the 
transferred data packages (Frames). Every frame contains several signals which contain the 
actual measurement data. The DIAdem driver accesses the signals defined in the FIBEX file 
directly through the NI-XNET-API. Frames and signals are referenced through their names. 
DIAdem does not support the direct access to the raw data of the frames.

The dialog boxes in the NI-XNET driver provide a signal selection with signals to be acquired 
or output. In the dialog boxes of the Bus configuration you specify the clusters and specify some 
of the network settings not defined in the FIBEX file. First, select a bus configuration or load a 
database file to create a bus configuration. One bus configuration can apply in several DIAdem 
blocks. Then select the signals available in the cluster for DIAdem to read or write. You can 
acquire and output up to 255 signals in a DIAdem DAC block. 
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Using CAN Drivers
The Controller Area Network driver from National Instruments (NI-CAN) transfers data to and 
from DIAdem via interface boards. To connect DIAdem to CAN, select Settings»Single Point 
Processing»Interfaces»CAN Bus and configure the CAN interface, and establish CAN 
channels, for example, in the Measurement & Automation Explorer. Branch to My System»
Data Neighborhood»CAN Channels in NI MAX, and click Create Message on the function 
bar. Select the created CAN message and click Create Channel on the function bar. Then you 
configure the CAN channels. 

The CAN block in DIAdem uses the channel names to access the CAN channels. Double-click 
the block to open the block dialog box and select the channels you want. 

Using ECU Measurement and Calibration Toolkit Driver
 The NI ECU Measurement and Calibration Toolkit is used for acquiring data from Engine 
Control Units (ECUs).

The CAN Calibration Protocol (CCP) or Universal Measurement and Calibration Protocol 
(XCP) is used for executing the measurement data acquisition and calibration of Electronic 
Control Units (ECU). CCP is a protocol for measuring and calibrating ECU data and is based on 
CAN. XCP is a generalized version of the CCP. You can use the definitions of an A2L file to 
access the controller data. The A2L files are based on the ASAM-MCD 2MC standard.

You must first install the NI ECU Measurement and Calibration Toolkit to use the ECU 
Measurement and Calibration Toolkit driver with DIAdem.

Using Control File Drivers
You can use the control file driver to access external measurement devices in DIAdem via the 
RS-232 interface or General Purpose interface Bus (GPIB). This communication is based on a 
simply-structured text file in which a communication protocol for linking devices is defined. Use 
the Example.atr control file as an example.

A control file consists of the measurement preparations, the actual measurement, and the 
post-measurement action, as shown in the following figure. The Init procedure starts the 
communication with the measurement device and the Start procedure starts a measurement. 
During the measurement, DIAdem calls the Input procedure for data input, and the Output 
procedure for data output, cyclically in the specified measurement clock. The Stop procedure 
stops the measurement and the DeInit procedure resets the measurement device.
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Figure 2-3.  Structure of a Control File

You can use several control file driver blocks in one block diagram, and you can address several 
external devices in one control file. 

The interface monitor on the toolbar guides you through an interactive dialog box with external 
devices via the serial interfaces COM1 to COM9 and via GPIB (DIN IEC 625 or IEEE 488). You 
can send character strings to a device and read the replies on the screen. The interface monitor 
is useful for testing and commissioning programmable measurement devices and for 
programming control files. In the hexadecimal display mode, you can see all the control 
characters the device sends.

Using Script Drivers
The Script driver uses Visual Basic Script (VBS) to acquire, process, and output data with 
external devices. You can use VBS for complex tasks such as test sum calculations, which you 
cannot execute with the control file driver. The GFSUDI communication layer communicates 
with the interfaces RS-232, GPIB, and TCP/IP, to exchange data with external devices, as the 
following figure shows. If you use VBS, you can access other program modules such as ActiveX 
components.
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Figure 2-4.  External Devices Can Communicate with DIAdem via VBScript

In the Script block you specify the inputs, outputs, and the script. To create a script, click Script 
Template. DIAdem opens a wizard where you select the interface and specify the script 
functions. DIAdem creates a template, which you can edit in DIAdem SCRIPT.
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3
The Block Diagram Describes the 
Measurement Task

In DIAdem DAC you create block diagrams in order to acquire, to process, to visualize, and to 
output measurement values. For each function you select a block from a function group, position 
the block in the workspace, and connect the block to other blocks. Double-click a block to 
configure the block in dialog boxes. 

Creating Block Diagrams 
You start a block diagram on the left with a data source, for example, a driver input from the 
installed hardware, use blocks for scaling and processing, and the data ends in the display 
instruments on the right. The data in the block diagram does not always flow from left to right, 
but it always flows from block outputs to block inputs. 

A simple block diagram consists of a data source and a display instrument. If you want to use an 
inbuilt National Instruments measurement board as the data source, click NI-DAQ Driver in the 
Driver Inputs function group. Then open the Display Instruments function group and click 
Curve. DIAdem inserts the blocks in the top left-hand corner of the workspace. Position the 
Curve display block to the right of the driver block. Click the data output on the right edge of the 
driver block and drag the crosshair to the data input on the left edge of the Curve display. Click 
the data input of the Curve display as soon as OK appears next to the crosshair. DIAdem connects 
the two blocks with a green data bus. Double-click the NI-DAQ driver block and select the 
signals to be displayed, from the channels defined in the Measurement & Automation Explorer.

To display the measurement values, click Start Display on the toolbar. DIAdem switches to the 
VISUAL panel and displays the selected signals as curves. To stop the display, click Stop 
Measurement on the toolbar. You also can press <Esc> to abort a measurement. 

If you use a block to save the measurement values in the block diagram, you must click Start 
Measurement so that DIAdem can visualize measurement values and can save the measurement 
values in the Data Portal or in a file. To save the measurement values without visualizing them, 
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select Measure»Measurement (Without Display). In the Save block you specify where to save 
the data and also the maximum number of measurement values to be saved. Select Measure»
Last Measurement Status to see how long the last measurement with data storage took and how 
many values DIAdem saved. Before starting a measurement, DIAdem checks the block diagram 
and displays corrupt connections and settings. Use the Check Block Diagram function to reveal 
errors when you create block diagrams.

To create and test a block diagram independently of the measurement hardware, open the 
function group Simulation Inputs first, and use the blocks Random, Noise, or Function 
Generator as data sources. You also can use input instruments, data files, data channels of the 
Data Portal and calculation results from processing blocks as hardware-independent data 
sources. In the second step you exchange the simulation blocks for driver blocks. To replace a 
block, drop the driver input onto the simulation input in the block diagram. DIAdem replaces the 
simulation block with the driver block and transfers the common settings, such as the block 
name and the number of signals.

Connecting Blocks with Buses to Create a Block 
Diagram
The task determines which block you select and how you connect the blocks in a block diagram. 
You can connect blocks to blocks, blocks to buses, and buses to buses. If you click an output or 
an input terminal on a block, the beginning of the new bus appears with a crosshair at the tip. 
Click a bus and press the left mouse button to create a new bus. Drag the crosshair over an input 
terminal or a bus that is the same color, until DIAdem displays OK at the crosshair. After a mouse 
click, DIAdem creates the connection. If DIAdem displays a crossed out crosshair, you cannot 
connect the blocks.

If you drag a bus away from another bus, DIAdem displays the branch as a circle. When you join 
two buses, DIAdem displays a small square at the input node. The black triangles in the square 
indicate which buses deliver signals. 

If the block diagram is very complex, DIAdem might continue the bus in the background. Then 
the bus ends with a black point which displays the name of the bus, for example, D11 for the 
eleventh data bus. At a different position in the block diagram, a second black point appears with 
the same name, D11, from which DIAdem continues the bus.

Buses Differ According to the Signals They Transport
DIAdem distinguishes the connections between data buses, control buses, system buses, packet 
buses, alarm buses, and text buses. Each bus type transports different signals. You only can 
connect buses and block terminals that are the same type, for example, you cannot connect data 
buses to control buses. To distinguish between the various buses, DIAdem displays each type of 
bus in a different color. Single point processing buses are monochrome and packet processing 
buses have two colors. Refer to Chapter 5, Working with Packet Processing, for more 
information on single point processing and packet processing.
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DIAdem organizes the different bus types in separate display layers. To keep a block diagram 
clear and easy to understand, and to make it easier to make connections, you can hide the layers 
using the symbols on the toolbar or in the View menu. A block diagram can contain up to 
six layers:

• The system layer contains the yellow system buses, which transport clock rate information 
between the blocks. 

• The control layer contains the red control buses, which transfer conditions, and activate, 
deactivate, or reset blocks.

• The data layer contains the green data buses, which transfer analog signals or digital 
signals, depending on the data source.

• The packet layer contains the green and black packet buses, which transport data packets.

• The alarm layer contains the blue and black alarm buses, which transport alarm 
information.

• The text layer contains the gray and black text buses, which transport text information.

The blocks have different input terminals and output terminals. Data leaves a block on the right 
side of the block and reaches a block on the left side of the block. This also applies for data 
packets, alarms, and texts. You connect the control buses and system buses on the horizontal 
edges of the block: the inputs at the top and the outputs at the bottom. Control blocks can have 
several control inputs and control outputs. Display instruments and manual input instruments 
have the control inputs Start, Stop, or Reset which enable, disable, or reset the visualization. 
Packet blocks can have several data input and data output terminals.

Buses Contain Multiple Signals
All the buses between the blocks transport multiple signals. For example, a green data bus 
between two blocks can transport the measured values from 20 sensors. If you connect the signal 
from another sensor to this data bus, the data bus contains 21 sensor signals after the input node. 
DIAdem displays the number of transported signals along the bus and at the input terminals and 
the output terminals. 

Double-click a bus to obtain a list of the signals transported in the bus. The bus dialog box lists 
the names of the block outputs and the names of the signals. If blocks enter more than one signal, 
double-click the block name to open the list. 

You specify in the block diagram dialog boxes how many signals the block creates or processes. 
For example, to increase the number of signals generated by a function generator, click the List 
Length button in the Signal list in the dialog box of the function generator. Increase the number 
of outgoing signals to five, for example. After you close the dialog box, the function generator 
displays the number five at the data output terminal. If you connect a Curve display, the display 
instrument shows five curves underneath each other. By default DIAdem enables the checkbox 
Automatically increasing in the list length of the display block, so that the display instruments 
automatically displays all connected signals.
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Note For the driver inputs, the list length must be the same as the number of 
terminals on the installed hardware.

You can disable signals in data sources, data outputs, and some process functions, without 
changing the signal list. To do so, open, for example, the signal list in the dialog box of the 
function generator. Click the checkbox in the fifth row of the Enabled column to disable the 
fifth channel. When you close the dialog box, the number five is still on the Curve display bus. 
However, if you start a display, the display instrument displays only four curves. If you change 
the list length, the sequence of the signals changes. If you disable signals, the sequence of the 
signals remains unchanged.  Therefore you do not need to adjust the rest of the block diagram 
when you separate and then reconnect it.

Select the data signals to be processed by the block in the block dialog box.  For example, to 
disconnect signals at the curve display, click Inputs»Data. DIAdem displays a list with the 
five connected signals. Select a signal and click Disconnect signal. You can select several 
non-consecutive signals to disconnect them all simultaneously. DIAdem deletes the signal 
names in the row of disconnected signals and displays in the neighboring column a disconnected 
plug. When you close the input dialog box, the number four appears at the data input terminal. 

To re-connect a data signal, you must click the empty field of the signal name. Open the selection 
list and select a data signal. If you want to connect several signals in one step, select all the data 
inputs you want to connect. Click Connect Signals to open a list with the names of the connected 
blocks. When you double-click a block name, DIAdem displays a list of signals you can choose 
from. 

Combining Subtasks into Subblock Diagrams
The more blocks you insert and connect in a block diagram, the more complex the block diagram 
becomes. To keep the block diagram easy to understand, you can group sections of the task into 
subblock diagrams. A subblock diagram looks like a block with signal inputs and signal outputs. 
You can include other subblock diagrams in a subblock diagram and in this way, establish a 
hierarchy with several levels. You can export subblock diagrams to reuse the task sections in 
other block diagrams. 

To create a subblock diagram, you select the blocks and the buses that you want to group 
together, and click Group Subblock Diagram on the toolbar. DIAdem packs the blocks and the 
buses into one subblock diagram block and creates inputs and outputs for the buses to the blocks 
outside the subblock diagram. Double-click to open a subblock diagram. In the following figure, 
you recognize the open subblock diagram by the surrounding terminal bars for importing and 
exporting the various types of signals. You can move and extend the terminal bars to enlarge the 
workspace of the subblock diagram.
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Subblock Diagram with the Terminal Bars of the Various Bus Types

You use the connection bars to connect blocks inside the subblock diagram to blocks outside the 
subblock diagram. Double-click the terminal fields at the edges of the subblock diagram to open 
the dialog boxes with lists of the imported or exported signals. You can add or delete connections 
in these dialog boxes. If you add a new import connection for data, the respective import field 
of the subblock diagram receives another connection. The subblock diagram contains another 
data input terminal where you can connect more signals. If you add export connections, DIAdem 
also generates the respective terminals in the subblock diagram and in the subblock diagram 
block. You only can delete terminals if no signal buses are connected to these terminals in the 
subblock diagram or in the subblock diagram block.

Click the Close Subblock Diagram button on the toolbar to display the subblock diagram again 
as a single block in the main block diagram. To integrate the blocks of a subblock diagram in a 
block diagram, select the subblock diagram block and click Ungroup Subblock Diagram on 
the toolbar. Before you ungroup a subblock diagram, you must connect each import and export 
terminal inside and outside the subblock diagram with buses that are the same length as the list 
length, otherwise DIAdem will not be able to completely unpack the subblock diagram. 

You can save a subblock diagram as a file in order to reuse partial solutions for other tasks. Open 
the subblock diagram and select File»Save Subblock Diagram. To save a brief description of a 
subblock diagram, click Block Diagram Parameters on the toolbar. DIAdem saves block 
diagrams with the filename extension .dac and subblock diagrams with the filename extension 
.sub in the same file format. You also can load a block diagram as a subblock diagram and use 
a subblock diagram as a template for a block diagram. Select File»Load Subblock Diagram to 
import subblock diagrams. After you have selected the file name, DIAdem imports the subblock 
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diagram without changing the global settings such as the default system clock, interfaces, data 
storage, and measurement parameters, of the main block diagram. 

Editing Block Diagrams
In the DIAdem DAC workspace you can select and position one or more blocks. Use the 
alignment functions and the grid, which you activate on the toolbar, to position the blocks in 
relation to each other. When you move the blocks, DIAdem reconnects the buses. To move buses 
separately from the blocks in the block diagram, move branches and input nodes. Press <Del> 
to delete selected objects. To delete a bus between two blocks, for example, select the bus and 
press <Del>. To deselect all objects, click anywhere in the worksheet, or press the <Esc> key.

If you move a block to the right or down over the edge of the workspace, you move the visible 
section of the block diagram. Use the scroll bars to move the visible section anywhere in the 
workspace. To view the entire workspace, click Zoom Out. To enlarge a section of the block 
diagram overview, click Zoom In. DIAdem displays a cursor with a rectangle, which you use to 
specify the section you want. You can use this function repeatedly until you have the view you 
want. You can now click Zoom Out to undo the zoom step by step and click Zoom Off to restore 
the normal view. 

In complex block diagrams, you can select Edit»Find to search for blocks and signals. When 
DIAdem finds a block, you can open the block properties and terminals from the search dialog 
box. At the same time, DIAdem selects the block in the block diagram. 

You can prevent changes being made in block diagrams in DIAdem DAC. To do so, click Lock 
Editing on the toolbar. DIAdem saves this setting with the block diagram. However, you can 
still change the parameters for the display and input instruments in DIAdem VISUAL.

In the DIAdem DAC settings you specify the maximum size of the block diagram and the display 
of the block diagram editor. Select Settings»Options»DAC»Measurement Kernel to specify 
the maximum number of blocks and signals for one block diagram. Select Settings»Options»
DAC»Block Diagram to change the background colors, the block display, the bus layers, and 
the labels for the blocks and buses. 

Select Settings»Single Point Processing»Default System Clock to specify the basic sampling 
rate for the block diagram. DIAdem sets the default system clock for all blocks for which you 
do not set a clock signal. Use system clock blocks in the block diagram to assign a clock rate that 
is different to the default system clock to individual blocks. The blocks that are not connected to 
the System Clock block continue to work with the default system clock. If you use several 
system clock blocks, you can create subsystems that have different sampling rates. The settings 
you set in the system clock block specifies whether only the DAC kernel controls the 
measurement, or whether the kernel and the measurement hardware control the measurement 
together.Refer to Different DIAdem Measurement Modes in Chapter 7, The Basics of Process 
Measuring and Control Technology with DIAdem, for more information about the measurement 
modes.
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If you also use packet blocks in a block diagram, select Settings»Packet Processing»Default 
System Clock to specify the sampling rate of the packet blocks. Refer to Chapter 5, Working 
with Packet Processing, for more information on single point processing and packet processing.

In a block diagram file with the filename extension .dac, you save the blocks, the buses, the 
hardware settings, the interfaces in DIAdem, the system settings, and the visualization settings. 
If you use a graphic for visualization, DIAdem saves the filename including the path, in the block 
diagram. Select Settings»Options»DAC to save a block diagram in ANSI format instead of in 
Unicode. With DIAdem 10.2 and earlier versions you only can load block diagrams that were 
saved in ANSI format. 

Enter a short description of the block diagram in the Block Diagram Parameters. In the block 
diagram parameters you can also include user commands so that you can use functions you 
defined in a script, before and after a block diagram check and before and after a measurement. 
Select Settings»Options»Extensions»User Commands and register script files that contain 
user commands, for DIAdem to add the user commands contained in the files to the collection 
of commands.Refer to Appendix A, Executing Measurements Automatically, for more 
information about scripts for DIAdem DAC. Refer to Chapter 6, Automating Work Sequences, 
in the DIAdem manual Data Mining, Analysis, and Report Generation, for general information 
about creating scripts.

DIAdem DAC Function Groups
DIAdem provides an extensive library of functions as blocks for signal acquisition, processing, 
and visualization. These blocks are arranged by category in the DIAdem DAC function groups: 

• System

• Driver inputs and outputs

• Simulation inputs and outputs

• Scaling

• Processing

• Control

• Display instruments

Refer to DIAdem VISUAL Function Groups in Chapter 4, Visualizing Data and Operating 
Facilities, for a description of the display instruments. 

• Alarm system

Refer to Alarm System Functions in Chapter 6, Monitoring Processes with the Alarm 
System, for a description of the alarm functions. 

• Packet processing

Refer to Packet Processing Functions in Chapter 5, Working with Packet Processing, for a 
description of the packet function. 
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Note The NI License Manager only enables DAC functions included in your 
DIAdem license. DAC functions that are not included in your DIAdem license are 
dimmed in the corresponding function groups. To use these DAC functions you must 
obtain a license for a different DIAdem edition.

System Function Group
The function group System includes the blocks Save Data, Save Data with Trigger, and Save 
in Variables, for saving measured values. The blocks Save Data and Save Data with Trigger 
save channel group properties and channel properties with the measured values, in the Data 
Portal or to a file.

To save measured values in relation to events, you can define a start trigger and a stop trigger in 
the system block Save Data with Trigger, and you can define consecutive triggers in the system 
block Trigger Sequence. For the start trigger and the stop trigger you can define a pre-range and 
a post-range, to save the measured values that come directly before or after a trigger. For each 
trigger sequence you can define a data reduction, to save only the first value, the minimum, the 
maximum, or the arithmetic mean, of the specified interval. Select Settings»Options»DAC»
Measurement Kernel»Triggers to change the maximum number of trigger sequences in a 
block.

Use the System Clock to create subsystems with different sampling rates. DIAdem sets the 
default system clock for all blocks for which you do not set a clock signal. The measurement 
mode you set in the system clock block specifies whether only the DAC kernel controls the 
measurement, or whether the kernel and the measurement hardware control the measurement 
together. To make settings for the default system clock select Settings»Single Point 
Processing»Default System Clock.Refer to Different DIAdem Measurement Modes in 
Chapter 7, The Basics of Process Measuring and Control Technology with DIAdem, for more 
information about the measurement modes.

Driver Inputs and Driver Outputs
The function groups Driver Inputs and Driver Outputs include functions for registered 
measurement hardware and interface functions. Use the function group Driver Inputs to insert 
signal acquisition blocks into a block diagram. Use the function group Driver Outputs to insert 
signal output blocks into a block diagram. 

Both function groups contain blocks for the interfaces XNET, CAN, OPC, DDE, and device 
drivers. With the NI-XNET driver, DIAdem can acquire and output data with the NI-XNET 
hardware.  NI-XNET supports CAN (Controller Area Network), LIN (Local Interconnect 
Network), and FlexRay. The driver inputs contain the ECU driver, which uses the NI ECU 
Measurement and Calibration Toolkit to acquire data from the Engine Control Units (ECU). The 
NI-CAN Driver (Controller Area Network) enables access to signals via the CAN bus and the 
NI-DAQmx-driver enables access to the National Instruments hardware that you define in the 
Measurement & Automation Explorer, which is the National Instruments device configurator. 
With the OPC Driver (OLE for Process Control), DIAdem can communicate as an OPC client 
with any OPC servers registered on your computer. With the DDE Driver (Dynamic Data 
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Exchange), you can establish a client/server link via DDE. DIAdem uses the Script Driver to 
communicate, VBS based, with external measurement devices via the interfaces RS-232, GPIB, 
and TCP/IP. DIAdem uses the Control File Driver to communicate with external measurement 
devices on the basis of ASCII control files, via the RS-232 interface or the GPIB bus.Refer to 
Chapter 2, Installing Measurement Hardware and Communicating via Interfaces, for more 
information on how to register measurement hardware in DIAdem or how to access external 
devices via interfaces.

Simulation Inputs and Simulation Outputs
The function groups Simulation Inputs and Simulation Outputs include functions for 
generating signals without measurement hardware. You can use simulation blocks to create and 
to test block diagrams without hardware, and you can later replace the data sources with 
hardware blocks. 

The function group Simulation Inputs includes the blocks Random, Noise, and Function 
Generator, for generating continuous signals. You operate the input instruments Switch, Push 
Button, Slider Control, Dial, Radio Button, and Numeric Input in DIAdem VISUAL using 
the mouse or the keyboard, to generate signals interactively. You can manually trigger control 
signals in relation to conditions. The blocks Read Channel from Data Portal, Read Channel 
from DAT File, and Read Channel from DAT Measurement File, read data from the Data 
Portal or from a data file that can originate from a measurement that has finished or is still 
running. 

To display the date and time during a measurement, use the Absolute Time with a digital 
display. Because DIAdem displays the time in seconds since the year zero, you must enter the 
digital date display in days, hours, seconds, and milliseconds, for example, in the format #dd 
hh:nn:ss.ffff. Use the Date block if you want to display only the day, the month, or the year 
of the current date, and use the Time block to display the current hour, minute, or second. In the 
connected digital display, you do not specify a time format to display the date or the hour, you 
specify the number of decimal places, for example, dddd for the date. You use the Stopwatch 
to measure the duration of events in seconds, by starting, stopping, and resetting the stopwatch 
with control signals.

You use the Counter to simulate a counter component that has a control input Clock 
Release, which starts counting synchronously with the system clock, and a control input 
Reversion, which changes the counting direction. The Buffer Monitor monitors the filling of 
the measurement value buffer to give you an idea of the load the measurement subjects the 
computer to. 

The function group Simulation Outputs includes the Loudspeaker, which outputs measured 
values as acoustic signals to the computer loudspeakers. Use the Execute Application block to 
start other applications in relation to events. Use the Open Application block to display and to 
hide executing programs on the screen. 
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Scaling Function Group
The Scaling function group includes blocks for converting the incoming signals from the 
measurement hardware into the measured physical quantities. Scaling blocks convert, for 
example, the voltage recorded on temperature sensors into the original measured temperature, 
with the unit degrees Celsius. 

Linear Scaling scales signals linear, using the linear equation ax+b, and Two-Point Scaling 
scales signals using two specified points. You can execute a calibration measurement to 
determine the two points. Use Free Linearization via Table to create a value table and use Free 
Linearization via Channels to specify channel pairs from the Data Portal which specify the 
interpolation points for any non-linear scalings. DIAdem uses an interpolation to calculate the 
scaled signal values between the between data points. Use the Offset Correction function to 
subtract a constant from the measurement values.

The PT100 Linearization calculates the temperature from the measured resistance. The 
Thermo Linearization block calculates the temperature from the voltage measured on a 
thermocouple. If you execute external pre-amplification, DIAdem can convert the incoming 
voltage values to the voltage range on the thermocouple used, so that the linearization function 
processes the measured values correctly.

Processing Function Group
The function group Processing includes blocks for calculating data signals and controlling 
processes.

In the processing block Formula you define formulas for connecting data signals to control 
signals, in the same way as in the DIAdem Calculator. You can execute comparison operations 
and Boolean operations in the formula, for example. However you cannot execute VBS 
commands. As the formula result, DIAdem outputs data signals such as the power, calculated 
from the current and the voltage. The Signal Copy creates as many copies of the input signal as 
the block has data outputs. However, the Signal Multiplexer, which is controlled by the 
selection input, groups measured values from several input signals, into one data signal. You use 
the block Control Signal–>Data Signal to convert control signals into data signals, for 
example, to visualize the status of control signals. The processing block supplies data signals 
with the values 0 and 1.

Use the PID Controller, the Two-Point Controller, or the Three-Point Controller to calculate 
actuating values from the difference between the reference values and the actual value. In the 
non-linear blocks Two-Point Controller and Three-Point Controller, you can specify a 
hysteresis by entering different values for the on and off levels. With the PID Controller you 
must ensure that the proportional part, the integral part, and the differential part correspond, to 
ensure good control behavior.

Use the Bit Bundling block to bundle up to 32 single-bit signals into one 32-bit signal, and the 
Bit Extraction block to divide a signal with up to 32 bits, into single-bit signals. The processing 
block Mean of N Signals calculates the arithmetic mean of all the input signals and the 
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processing block Floating Mean calculates the floating mean for each signal at an interval that 
you specify. The processing blocks Binary Code->Gray Code and Gray Code->Binary Code 
convert measured values from binary code to Gray code and vice versa.

Create your own processing functions in scripts, to use the functions in the processing block 
VBS Script in block diagrams. You also can create function libraries (DLLs) which you register 
via Settings»Options»Extensions»GPI Extensions in DIAdem and provide in this function 
group via Settings»Single Point Processing»Driver Function Groups.

Control Function Group
The function group Control includes blocks for monitoring data signals, system signals, and 
control signals. DIAdem generates control impulses when data signals exceed thresholds, for 
example, or when periods of time elapse, or when a key is pressed. Control signals have the value 
1 if a condition is true and the value 0 if a condition is not true. Use control signals to start or to 
stop the storage of measured values, to switch display instruments on and off, or to adjust the 
sampling rate during the measurement. 

To add an inverted block output to the control blocks, enable the setting Inverted outputs for 
the control outputs. 

Use the control block Window, Slope, and Signal Alteration to monitor data signals. The 
Window generates a control impulse when data signals enter or leave a specified value range. 
The Slope block checks whether data signals exceed a threshold in the ascending or the 
descending direction, and the Signal Alteration block monitors the difference between 
consecutive values.

In the control block Formula you define formulas for connecting data signals to control signals 
and for outputting control signals as the formula result, in the same way as in the DIAdem 
Calculator. You can execute comparison operations and Boolean operations in the formula, for 
example. However you cannot execute VBS commands. When you use formula blocks, 
remember that DIAdem processes predefined conditions, such as the Window block, faster than 
formulas.

The Push Button, the Radio Button, and the Checkbox create a control impulse if the user 
presses a specified function key or selects the respective button in DIAdem VISUAL. With the 
Start and Stop control inputs, you can block and release the operation of the three input 
instruments in relation to events. The Time block realizes an on/off delay or generates a periodic 
control impulse, and the Absolute Time generates a time condition with the date and time. 

Use the control blocks AND and OR to execute operations on control signals, and use the NOT 
block to invert a control signal. The Impulse Delay control block forwards a control signal, with 
a delay, as an impulse.

The Mono Flop and the Flip Flops work the same as the electrical engineering components. The 
Mono Flop is a single-shot circuit that outputs a control signal for a specific hold time, as soon 
as a control impulse arrives at the set input. The RS Flip Flop and the JK Flip Flop are bi-stable 
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circuits that, after a control impulse, continue to output a control signal at the set input until a 
new control impulse arrives at a reset input. The Switch is similar to the RS flip flop, but 
DIAdem monitors only one control input: only the reset condition for a set switch and only the 
set condition for a switch that is not set.

Use the control blocks System Clock Status, Trigger Sequence Status, and Number of Values 
to monitor system signals. The System Clock Status checks the status of a system clock and the 
Trigger Sequence Status checks the status of a trigger sequence of a system clock rate. You can 
use this control information to start other clock systems or trigger sequences consecutively. The 
control block Number of Values generates a control impulse after a specific number of clock 
cycles. 
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4
Visualizing Data and 
Operating Facilities

You use DIAdem VISUAL to design the visualization of block diagrams that you create with 
DIAdem DAC. When a measurement starts, DIAdem automatically switches to DIAdem 
VISUAL to display measurement data, open or closed loop control data, or monitoring data. The 
display and input instruments can be positioned freely and pictures and audio files used, 
allowing you to design all kinds of appropriate visualizations for your task.

Creating a Visualization
When you create the block diagram in DIAdem DAC, you select, configure, and connect the 
blocks and decide which display instruments show which signals. In DIAdem VISUAL you then 
design the visualization by arranging and configuring the display instruments and the input 
instruments. You save the definition of the visualization with the block diagram. You also can 
add display instruments and input instruments from the function groups in DIAdem VISUAL. 
With each instrument you add, you also add a block to the block diagram in DIAdem DAC, 
where you connect data buses, control buses, and system buses to the block. 

For example, to display the data of the NI-DAQ driver input as curves on a recorder, open the 
Recorder Display function group in DIAdem VISUAL and click the Horizontal Recorder 
Display button. DIAdem inserts the display instrument in the top left corner of the workspace. 
Move and resize the recorder display to position the display instrument. Double-click the 
instrument and select the y-scaling, specify the frame and background, and display the axis 
labeling and a legend in order to edit the instrument. To connect data to the display instrument, 
open DIAdem DAC and connect the data input of the Recorder block to the data output of the 
NIDAQ-In block.

To display the measurement values, click Start Display on the toolbar. DIAdem displays the 
connected and active signals as curves. To stop the display, click Stop Measurement on the 
toolbar. While a measurement is running, you cannot move or edit the instruments, you only can 
operate the input instruments in the workspace and click Stop on the toolbar. In DIAdem 
VISUAL you can not only start a block diagram, you also can load it and save it. 
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Use the full-screen mode to hide the DIAdem VISUAL user interface and display the workspace 
contents on the entire screen. Press <Ctrl-U> for the full-screen mode. Then press <Ctrl-F5> to 
start a measurement. Hit the <Esc> key to stop the measurement. Press <Ctrl-U> to disable the 
full-screen mode. You can neither enable nor disable the full screen mode while a measurement 
is running. 

Editing a Visualization
You can position display instruments, input instruments, and graphics anywhere in the visible 
workspace. However, you cannot move instruments over the edge of the screen as you can in 
DIAdem DAC, because the DIAdem VISUAL workspace is limited to the visible area. Enable 
the grid to position instruments exactly next to each other or above one another.

When you select an instrument, DIAdem marks the instrument with a dashed frame and small 
squares in the corners and at the sides. Move the squares at the sides to change the width and the 
height. Drag the squares at the corners to resize the instrument while maintaining the 
proportions. Press <Ctrl> at the same time, to change the size but keep the center. 

You can select several instruments and move and resize them together. You can use the 
alignment functions to align selected instruments to each other and to align the size of the 
objects. The dashed frame is the reference point for DIAdem. To align three instruments evenly 
spaced underneath each other, click the Align Vertical Intervals button on the toolbar. If the 
selection frame is smaller than the total height of all three instruments, DIAdem positions the 
instruments underneath each other with the edges touching, without changing the height of each 
instrument. If you position an instrument incorrectly, or if you use the wrong alignment function, 
press <Ctrl-Z> to undo steps.

If you cannot select an instrument with the mouse in the workspace, because the instrument is 
hidden by another instrument, click the instrument which is on top, and select Edit»Outline to 
make the hidden instrument visible. To edit hidden instruments, select one instrument after 
another with the <Tabulator>. DIAdem displays the selected instrument in the foreground. 

The display instruments and the input instruments have a predefined value range of ±10. You 
can change the value range separately for each signal in the block dialog box. In the dialog boxes 
for the display instruments Curve, Recorder, Wiper, and Spike you can select automatic 
y-scaling so that DIAdem sets the value range according to the incoming measurement values. 

You can prevent changes being made in visualizations in DIAdem VISUAL. To do so, click 
Lock Editing on the toolbar. DIAdem saves this setting with the block diagram. However, the 
visualization block parameters can still be changed in DIAdem DAC.

Working with VISUAL Pages 
Position instruments you want to view simultaneously when the display starts next to each other 
or one above the other without one instrument concealing the other. However, if you want to 
change the display in relation to an event, arrange the instruments so that they are stacked on top 
of each other and only reveal the instrument you need. The conditions which you define in the 
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control blocks determine when DIAdem displays which instrument. If you connect a control bus 
to the start input of the curve display, DIAdem does not show this display instrument until the 
condition at the start input is true.

To make it easier to select display instruments and input instruments in complex block diagrams, 
which makes it easier to edit the visualization, you can group instruments together into VISUAL 
pages. You can display, hide, and lock VISUAL pages for editing. To define VISUAL pages in 
DIAdem VISUAL, select View»Page Management. Then you must assign a VISUAL page to 
each instrument in the block dialog box under Frame. To hide a group while you edit the 
visualization screen, click View and disable the appropriate VISUAL page. 

By default, each subblock diagram uses its own VISUAL page, which has the same name as the 
subblock diagram. To assign another VISUAL page to a subblock diagram, open the subblock 
diagram in DIAdem DAC and select Block Diagram Parameters»VISUAL Page on the 
toolbar. To assign a different VISUAL page to an instrument of the subblock diagram select 
select the new VISUAL page in the block dialog box. 

Visualization Settings
To specify basic visualization properties, select Settings»Block Diagram Parameters»
Visualization. You specify whether DIAdem hides deactivated display instruments during the 
measurement, and select the VISUAL background color. DIAdem saves the sizes and positions 
of the instruments in relation to the workspace, to automatically adjust the visualization to 
different screen sizes or changed window sizes. For identical display of the sizes and positions 
of instruments on any screen, specify the display area for the visualization, for example, as 
800 × 600. DIAdem then shows the same visualization screen, regardless of the screen 
resolution. 

DIAdem VISUAL Function Groups
DIAdem provides various display and input instruments. These functions are arranged by 
category in the DIAdem VISUAL function groups: 

• Manual input

• Curve display

• Wiper and spike display

• Recorder display

• XY displays

• Gauge displays

• Bar displays

• Alphanumeric displays

• Binary and status displays

• Alarm system display
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Refer to Alarm System Functions in Chapter 6, Monitoring Processes with the Alarm 
System for a description of the display instruments of the alarm system.

• Graphics

DIAdem DAC includes blocks for displaying measurement values in the function group Display 
Instruments and  the blocks for the manual instruments in the function group Simulation 
Inputs. 

Manual Input Instruments
The function group Simulation Inputs includes the instruments Switch, Push Button, Radio 
Button, Slider Control, Dial, and Numeric Input, which you can use to create data signals 
manually. In DIAdem DAC use the Push Button, the Radio Button, or the Checkbox from the 
Control function group to create a control impulse manually. You can operate the manual input 
instruments with the mouse, the keyboard, or with a data signal. After you enable remote control 
in the dialog box, the block receives another control input and data input. The additional data 
signal does not control the manual input instrument unless there is an active control signal at the 
remote control input. You cannot control manual instruments manually and via a data input at 
the same time. 

You use the arrow keys on the keyboard to operate the Slider Control and the Dial, and you use 
an assigned function key to operate the Switch and the Push Button. Select the settings for a 
Radio Button and Checkbox either with the arrow keys and the enter key, or with the function 
keys. For Numeric Entry you enter numbers on the keyboard and press <Enter>. If you enter a 
value that is outside the set value range, DIAdem uses the corresponding limit value instead.

Curve Display, Recorder Display, Wiper Display, and 
Spike Display
The function groups Display Curves, Recorder Display, and Wiper and Spike Display 
include display instruments that display signals as time-related curves. 

Use the Display Curves function group to display signals as time-related curves, which 
DIAdem plots from left to right. The Curve display deletes when the curve reaches the end of 
the window, refreshes, and re-plots from the left. 

Use Recorder Display to display signals as a continuous horizontal curve from right to left, or 
as a vertical curve from the top to the bottom. The recorder displays the signals as curves as if 
they were recorded on paper by a needle on a roller. 

Use the Wiper to display signals as continuous time-related curves, and use the Spike display 
instrument to display signals as vertical lines over the time axis. In both of these display 
instruments, a vertical line moves across the instrument from left to right and deletes and re-plots 
the curve. Wiper and Spike display, for example, display the values measured in the last 
ten seconds. In this case the current values are to the left of the vertical line and the previous 
values are to the right of the line. This enables you to see signal changes as soon as they occur. 
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With these display instruments, you can display all the curves in one axis system or each curve 
in a separate axis system. Grid lines, legends, and warning and alarm ranges make it easier to 
monitor the signals. To scale the time axis you specify a time segment, which DIAdem labels 
with the measurement time, with the current time, or with a fixed scale. To scale the y-axis, you 
can choose between a scale with the percentages of the display area, and a scale with the physical 
values. Specify the value range in the signal list; otherwise DIAdem specifies the range 
automatically. If you select automatic scaling, you can specify a minimum range, a fixed range, 
or an automatic scaling with peak hold. 

If you enable the setting Allow manual changes to the value range, you can change the 
y-scaling interactively during a measurement. To do so, position the cursor over the y-axis scale 
and turn the mouse wheel when a double-arrow appears at the cursor. Rotate the mouse wheel 
to expand or to shrink the scale. If you position the cursor at the center of the axis, you modify 
the scale at both ends of the axis. If you position the cursor at the lower end or the upper end of 
the axis, you scale the axis at the selected end, while the opposite end remains fixed. Of course, 
you also can move the section. At the end of the measurement DIAdem restores the original 
value range. 

XY Display
Use XY Display to display the relation between two signals as an xy-curve. The display 
instrument plots a curve or moves a symbol, such as a circle or a triangle, across the display area.

To scale the x-axis and the y-axis, you can choose between a scale with the percentages of the 
display area, and a scale with the physical values. Grid lines, legends, and warning and alarm 
ranges facilitate signal monitoring. 

Gauge Display
The function group Gauge Display includes display instruments such as the Tachometer, 
Analog Instruments, and Cylinder Tachometers, to display the current signal values with 
pointers. The Analog Instrument uses a quadrant, the Gauge Display uses a semicircle, and the 
Tacho Display uses a three-quarter circle as the scale that the gauge moves in. You can modify 
the size and position of the scale for the gauge and for the tachometer.

In Cylinder Tachometer display, the scale moves, not the pointer. DIAdem can move the 
cylinder vertically or horizontally and display the pointer as a line or as a double arrow. You 
specify the scale on the cylinder as a percentage that is the size of the visible segment of the value 
range.

Use the Polar Display to display the x-values and the y-values of a signal in a polar axis system. 
The x-values contain the angles around which the pointer rotates and the y-values contain the 
amplitudes that specify the length of the pointer. 

The Cylinder tachometer displays a separate display instrument for each signal, whereas you can 
display all the signals in each of the other gauge displays. You can choose between a scale with 
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the percentages of the display area, and a scale with the physical values. Legends and warning 
and alarm ranges make it easier to monitor the signals. 

Bar Display
Use the Bar Displays to display the current signal values as horizontal or vertical bars. By 
default DIAdem plots bars from the bottom edge of the instrument to the current value. If the 
value range is ±10, DIAdem plots a bar from -10 to -3 for the value -3. The reference line 
specifies whether the bars display on one side or on both sides of the axis. To differentiate the 
positive and negative values set the reference point to 50% in the middle of the symmetrical 
value range. If the values are positive, DIAdem plots the vertical bar upwards. If the values are 
negative, DIAdem plots them downwards. 

The bar displays of the Container specify the filling level in different-shaped containers. The 
level corresponds to the current measured value. You can choose between three cylindrical forms 
and one round form or a graphic for the selected container. To do this, select a graphic file in the 
dialog box of the container, and specify the transparency color. The graphic area which displays 
the bar must have the transparency color.

You can choose between a scale with the percentages of the display area, and a scale with the 
physical values. A color change in the bars indicates that the limit values have been exceeded. 

Alphanumeric Display
The Alphanumeric Display function group includes the digital displays Digits and Table, for 
numeric display of the current signal values. You can manually enter the numeric format and the 
font, and you can use color changes to indicate when limits are exceeded.

Use Message Display to display events visually or acoustically. DIAdem reads the messages 
from a text file and displays each measured value in a separate line. Instead of text, DIAdem can 
also display graphics and play audio files. To display graphics, enter @graphic in the first line 
of the text file and enter the paths with the graphic files in the subsequent lines. To run audio 
files, you must enter @sound and the audio files instead. To combine graphics with audio files, 
use two Message blocks in the block diagram. 

Use Text to display a description or instructions in relation to an event. DIAdem has static text 
and dynamic text. Dynamic text contains formula expressions and variables that DIAdem 
periodically updates. You can double-click to open the text editor, for example, to enter 
@@CurrTime@@ for the current time display. 

Binary and Status Display
The instruments in the function group Binary and Status Display do not show measured values, 
they divide the measurement range into two or more states. 

Use the binary displays Valve and Switch to display an opening or closing valve or switch. If 
you select the Rectangle or the Light instead, a color change indicates whether the signal is 
inside or outside the display range.
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Use the Status display to differentiate between several states with colors, graphics, and audio 
files. The status display, for example, can display the various work steps of a press such as 
opening the car roof or the deformation of a component.

Use the Color Matrix, for example, to show the temperature distribution on a workpiece. The 
temperature sensors must be positioned in a regular grid on the workpiece. The color palette that 
you define as the value range determines the color shading for the signals in DIAdem.

Graphics
Use the function group Graphics to integrate a picture of the test rig, the company logo, or a 
video, in the visualization. To integrate graphics in the customary formats and videos in the AVI 
file format and the MPEG file format, select Load Graphics. If you load a graphic or a video, 
DIAdem creates a link to the file. DIAdem saves the link with the path definition in the block 
diagram. If you want to use the block diagram on another computer, you must also copy the 
graphic or the video to the computer.

The following figure shows how the icons on the buttons on the left edge make switching 
between components easy. The large graphic on the right of the visualization shows the part of 
the plant to which the measurement values are assigned.

Figure 4-1.  Monitoring a Facility at Four Critical Points
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Working with Packet Processing

DIAdem provides two different methods for measuring and visualizing data: single point 
processing and packet processing. In single point processing, the measurement kernel controls 
the timing for point-by-point data acquisition, processing, and output. In packet processing, 
DIAdem handles the data in packets. The data flow controls the processes, which means that 
a function block must process an entire data packet before the subsequent function blocks can 
start to process the packet. You can combine single point processing and packet processing in 
one block diagram, for example, to execute an online FFT in the packet section and to use the 
maximum values of the frequency analysis for control in the single point section.

Processing Single Values
In single point processing, the measurement kernel controls all functions. This centralized 
control decides when DIAdem executes which functions, and controls the sampling rates, 
triggers, and conditions. The measurement kernel requests values from the device drivers or 
forwards values to device drivers for output, and displays the values on the screen. At any point 
in time, the current acquired or calculated value is at each function block.

In single point processing, data acquisition is executed in hardware clock or software clock. This 
enables you to execute long-term measurements and fast measurements. You can use plug-in 
boards to execute open and closed loop control without a signal processor. 

Refer to Different DIAdem Measurement Modes in Chapter 7, The Basics of Process Measuring 
and Control Technology with DIAdem.

Single point processing is especially suitable for the following operations:

• Measurement data acquisition with individual moderate sampling rates

• Long term measurements

• Event-controlled data acquisition

• Open and closed control tasks with moderate real-time requirements

Processing Data Packets
In packet processing, DIAdem does not process single values separately: DIAdem groups the 
single values into packets that pass through each of the processing steps consecutively. As soon 
as a data packet arrives, DIAdem forwards the data packet to the first processing function. The 
function processes, visualizes, saves, duplicates, or rejects the values and transfers the resulting 
data packet to the next processing function. 
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The data packet flow works like a letter shoot. The data packets go physically from one function 
to the next. The reduced amount of administration effort increases the data throughput compared 
to single point processing. Each function works automatically as soon as a data packet arrives. 
This makes it possible to execute calculations such as Fourier analyses, which require a certain 
number of values simultaneously. 

The measured values are acquired in data packets with data flow control. The measurement 
hardware determines which additional functions you have, for example, processing 
mathematical functions or complex testing tasks with short response times to boards with signal 
processors, which reduces the computing load during processing. 

Packet processing is especially suitable for the following operations:

• Data acquisition with high data throughput

• Fast online visualization

• Complex online mathematical functions

• Using special hardware features

Using Packet Functions in the Block Diagram
Packet processing has its own functions for signal processing, signal analysis, visualization, 
signal acquisition, and signal output. To combine single values and data packets in one block 
diagram, use the Pack block, which groups single values into data packets, and the Unpack 
block, which divides the data packets into separate values. 

For example, to display a signal from the single point NI-DAQ driver input defined in the block 
diagram as a waterfall diagram, open the function group Signal Processing (Packet Processing) 
and click the Pack button. Position the packet block below the existing block diagram and 
connect the green data bus that is connected to the driver input, to the data input on the Pack 
block. Double-click this block to specify the number of values in one data packet in the block 
dialog box.

To display the data packets as a waterfall diagram, open the function group Display and I/O 
(Packet Processing) and click Oscilloscope (3D Display). Position the Oscilloscope block next 
to the Pack block and connect both packet blocks. DIAdem connects the two packet blocks with 
a green and black packet bus. Together with the Oscilloscope block, DIAdem displays a new 
window which you can position anywhere on the screen, not just in the DIAdem VISUAL 
workspace.

When you start a measurement, the window displays axes and measurement curves as soon as 
the oscilloscope block receives data. The Oscilloscope window displays the curve of the current 
data packet in the foreground and the curves of the old data packets in the background, which 
creates a three-dimensional waterfall display. While a measurement is running, you can move 
the window around on the screen and you can modify the display of the measured values using 
the menus or the toolbar in the window. Click Stop Measurement on the toolbar to stop the 
measurement.
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Unlike the display instruments in single point processing, the display of the windows is specified 
only in the menus or on the toolbar, and the functions of the input instruments are specified in 
the shortcut menus. In the dialog box of these packet blocks you only make settings concerning 
the data flow. In DIAdem VISUAL you have no access to the packet processing display windows 
and input instruments.

Unlike the single point processing function blocks, which distinguish between data buses and 
control buses, you connect packet buses to the control inputs, not control buses. DIAdem 
monitors the packet buses to check whether the condition is true.

Block Size and Sampling Rate Determine the Data 
Packet Flow
Packet processing transports data packets from one packet block to the next in the block 
diagram. Data packets are generated by hardware inputs, input instruments from packet 
processing, or the Pack block. DIAdem does not forward a data packet to the subsequent packet 
block until the data packet is completely filled with data. The subsequent packet block does not 
work until all the block inputs have data packets and the block outputs are vacant. 

How many values a data packet contains depends on the size of the block. The maximum block 
size depends on the measurement hardware you use. Most packet blocks leave the block size 
unchanged during processing. Several packet blocks output data packets with a smaller block 
size, for example, the FFT data packets are half the size of the incoming data packets.

The packet processing driver blocks deliver data packets whose data originates from several 
channels used on the hardware. Multi-channel data packets generate the statistics function and 
the Merge packet block which combines several data packets from several packet buses. The 
packet blocks Oscilloscope, File-I/O, Relay Switch, Arithmetic, Copy, Voltmeter, and 
Protocol list can process multi-channel data packets. DIAdem arranges the data of the 
individual channels in multi-channel data packets value-wise. DIAdem first enters all first 
values, then all second values, and so on, into one data packet. The number of channels a data 
packet contains is indicated at the beginning of the multi-channel data packet. 

The size of the data packets and the sampling rate determine the processing speed, which in turn 
determines the data flow in the block diagram. The sampling rate determines how fast DIAdem 
generates data or requests data from the data acquisition board. The response time in the block 
diagram depends on the ratio between the block size and the sampling rate. A data acquisition 
block that is to measure 100 values at a sampling rate of 100 Hertz, can return only one data 
packet per second. All packet blocks whose dialog boxes do not specify block size or sampling 
rate, use the default settings.

If you select Settings»Packet Processing»Default System Clock you can specify the packet 
call clock as well as the block size and the sampling rate. The packet call clock is the rate at 
which DIAdem calls the packet blocks. At every call, DIAdem checks whether a packet block 
is prepared for work. A packet block can work if all block inputs contain data packets and no 
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data packet is blocking the block outputs. As long as a packet block is working, the packet block 
ignores the packet call clock.

Packet Processing Functions
All the packet processing functions in DIAdem DAC are grouped by category into four function 
groups. 

• Signal processing (packet processing)

• Signal analysis (packet processing)

• Display and I/O (packet processing)

• Driver (packet processing)

The Complete Selection button in the function group Signal Processing (Packet Processing) 
contains other packet functions that you can use in your block diagram.

Note The NI License Manager only provides the packet functions if your license 
contains packet processing. If not, the buttons in the alarm function groups are 
dimmed. To use the packet functions you might have to obtain a license for a different 
DIAdem edition.

Packet Functions for Signal Processing
The function group Signal Processing (Packet Processing) includes the functions Unpack and 
Pack, for combining packet processing with single point processing. The Unpack packet block 
divides the data packets of a packet bus into single values and outputs the single values to a data 
bus in single point processing. The Pack packet block combines values from one data bus in 
single point processing and outputs the data packets to a packet bus. 

You use the Merge packet block to combine data packets from several packet buses to a new 
multi-channel data packet. The packet size and the sampling frequency of one-channel data 
packets must correspond. You use the Manager packet block to select channels from 
multi-channel data packets. To create single-channel data packets, enter only one channel in the 
channel list. This packet block forwards the unaltered input signal together with the selected 
channels. 

Use the Multiplexing packet block to output data packets from several data inputs in alternating 
order from a block output, and the Demultiplexing packet block to output data packets from 
one input signal to several block outputs in alternating order. The signal at the control input 
specifies which input DIAdem uses for the multiplexer or which output for the demultiplexer. 

The Relay Switch packet block works as an on/off switch or as a toggle switch, to interrupt data 
packet transport or to assign the transport to two block outputs. The signal at the control input 
controls the relay switch. The Trigger packet block outputs data packets in relation to events, 
and DIAdem monitors whether the data signal or a second signal overshoot thresholds. The 
Trigger block rejects all data packets before the event.



© National Instruments Ireland Resources Limited | 5-5

NI DIAdem: Data Acquisition and Visualization

You use the Ignore packet block to reduce the amount of incoming data. The Ignore block can 
reject values, change packet sizes, or output specified sections of data depending on a control 
signal. The Replicator packet block repeatedly outputs a data packet, for example, for recurring 
use of a data packet with set points or comparative data, or to synchronize data signals that have 
seldom and irregularly incoming data packets with fast data signals. You use the Offset Register 
packet block to reduce the block size by dividing large data packets into smaller subpackets. 

You use the scaling functions to convert values, for example, to display the values in a different 
unit. Linear Scaling uses a linear equation with a factor and an offset for calculations, whereas 
2-Point Scaling uses two points to determine the linear equation. Thermo Linearization 
converts the voltages measured with thermocouples and with PT100 resistance into 
temperatures. Multi-Point Scaling scales data with a non-linear calibration curve, which the 
packet block reads at a second data input. To change the calibration dynamically, you can 
exchange the calibration curve during the measurement. 

Use the Clock packet block with the single point block System Clock to change the packet call 
rate in the block diagram. Use the packet block Stop to stop the block diagram packet blocks or 
the complete measurement after a specified number of data packets.

Packet Functions for Signal Analysis
The function group Signal Analysis (Packet Processing) includes the packet block Formula 
Parser, which executes mathematical functions on data packets from several packet buses, with 
a specified formula. DIAdem calculates the data packets of each block input value-by-value and 
outputs the results in a data packet that is the same size as the first data input. 

You use the Averaging packet block to calculate the arithmetic mean or the floating mean for 
entire data packets or for sections of the data packets and you use the Counter packet block to 
count measured values, data packets, or time ranges. The Statistics packet block calculates 
characteristic statistical values for data packets and the Online Classification block specifies the 
frequency distributions for the measured values in the data packets. DIAdem divides the data 
packets into classes, and counts how many measured values each class contains. 

The function group Signal Analysis (Packet Processing) includes functions such as fast Fourier 
transform (FFT) and Third/Octave Analysis, which you use to monitor frequency sections of 
oscillations during measurements. The FFT block transfers signals from the time domain to the 
frequency domain, the Inverse FFT block reverts signals from the frequency domain to the time 
domain, and the FFT of Two Time Signals analyzes two signals with a common time channel, 
by calculating cross spectra and transfer functions. You use the Third/Octave Analysis to check 
the frequency distribution in the signal for frequency domains, not for individual frequencies. To 
do this, the third/octave analysis sums up the amplitude values of an FFT in standardized 
logarithmic frequency intervals.
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With the Digital Filters packet block, you can attenuate or amplify selected frequency ranges of 
a time-related signal. You can choose from a selection of filter types such as lowpass, bandpass, 
and bandstop filter, which you use as IIR filters and FIR filters. The following figure shows the 
results from the IIR filters Butterworth and Chebyshev.

Figure 5-1.  Signals Filtered with Different Digital Filters Displayed in the Oscilloscope

Packet Functions for Display and File Access
The Display and I/O (Packet Processing) function group includes the oscilloscope and the 
voltmeter for visualizing data packets, and packet blocks for manual input and output of data 
packets. These blocks have their own windows, which you can configure separately and position 
anywhere on the screen. 

The Oscilloscope displays data packets as curves, bars, or spikes. You can display the 
chronological profile of signals as a three-dimensional surface or in recorder display. You use 
the menus and the toolbar in the display window to specify the appearance of the display, which 
you also can change during measurements. 

Click Cursor on the toolbar to show two cursor lines for measuring curve profiles and the cursor 
window. You can move the cursor lines with the mouse during the measurement and enlarge the 
range between the two cursor lines. The cursor window shows, for example, the point numbers 
and the x-values and the y-values, of both cursors.

The Voltmeter block displays measured values with gauges, digital instruments, horizontal or 
vertical bars, and text. If the voltmeter contains multi-channel data packets, the window displays 
a separate instrument for each data channel. Use the shortcut menu of the display window to 
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specify the display mode for the incoming signals and to show the warning and alarm limits, the 
drag indicator, and the trend display.

The Generator packet block generates signals such as sine signals and noise signals. The 
Manual Input blocks generate data packets with a slider control, a dial, a switch, a push button, 
or a bit switch. You use the shortcut menu of the instrument to specify the instrument display. If 
you generate several signals with a manual input instrument, DIAdem displays an input 
instrument for each channel in the display window. Manual input generates data blocks that have 
a block size of 1. Use the bit switch to output integer data values and use the slider control and 
the dial to output any data values. Use the push button and the switch to output control signals. 
The Push Button and the Switch blocks return the value 0 when they are off and the value 5 when 
they are on, whereas the slider control, the dial, and the bit switch output the set value. 

The Data Write packet block saves measured data in the Data Portal and the Data Read packet 
block reads data from the Data Portal, for example, as the reference channel. The File I/O packet 
block writes data to files and reads data from files. In the window of the File Player you read 
consecutive data packets or overlapping data packets forwards and backwards in data files. You 
use the packet blocks Network Server and Network Client to exchange data packets between 
DIAdem installations on a network.

Packet Functions for Data Acquisition and Output
The function group Driver (Packet Processing) includes the functions of the packet sound 
driver Sound Input, which acquires signals with the sound board in the computer, and Sound 
Output, which emits signals on the computer loudspeakers. For more driver functions, register 
the packet driver of the measurement hardware after selecting Settings»Options»Extensions»
GPI Extensions. For the acquisition, output, and processing driver functions, select Settings»
Packet Processing»Driver Function Group.

Refer to Installing Measurement Hardware in Chapter 2, Installing Measurement Hardware 
and Communicating via Interfaces, for more information about registering DIAdem drivers.

Complete Selection of Packet Functions
If you open the Signal Processing (Packet Processing) function group and click Complete 
Selection, you get packet functions that are not contained in the function groups. Use the Scaling 
packet block to convert data packets into a different physical unit using a linear characteristic 
curve. Specify the characteristic curve with two points. 

Use the Level Calculation packet block to calculate characteristic values for describing 
surrounding noise, from a time-related acoustic signal. You use the Protocol List to create and 
to print a list of the first value of each data packet in the protocol window. The Copy block 
outputs the data packets of an input signal on several packet buses simultaneously. The Buffer 
block collects data to output large data packets. The Timer block outputs control signals 
time-related, and the Trigger Finder also monitors a data channel in multi-channel data packets, 
to output a control signal.
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6
Monitoring Processes with 
the Alarm System

You use the alarm system to monitor whether signals overshoot or undershoot limits. Define 
limits in two stages to trigger alarms with increasing priorities of importance. DIAdem displays 
the alarms continuously on the screen. You can record and comment on alarms online as they 
occur. The alarm log can function as an operation report that DIAdem sends straight to those in 
charge so they are informed about alarms that occur. 

Note The NI License Manager only provides the alarm functions if your license 
contains the alarm system. If not, the buttons in the alarm function groups are 
dimmed. To use the alarm system you might have to obtain a license for a different 
DIAdem edition.

The following figure shows how the alarm generator monitors measured values from connected 
packet buses. If limit values are exceeded, the alarm generator displays alarms in the alarm table 
on the screen. To record the alarms in a file or to send them in an e-mail, DIAdem converts the 
alarm information into text. With each alarm, the alarm generator also outputs numeric data 
packets with the status of the alarms.
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Figure 6-1.  Alarm System Structure

The alarm blocks are packet blocks and and control the incoming measurement values in the data 
packets with data. The alarm generator does not work until a data packet arrives at the input, and 
the subsequent alarm table does not work until an alarm packet arrives from the alarm generator. 
The alarm generator monitors the green and black packet buses and outputs alarms on the blue 
and black alarm buses. DIAdem transports text on the gray and black text buses.

Defining Alarms
The alarm generator is the central function block in the alarm system. The measurement values 
to be monitored arrive in a packet bus at the alarm block, where you specify the alarm conditions. 
You confirm alarms in the alarm table which displays the alarms of the alarm generator. 

For example, to use the alarm system to monitor signals from the NI-DAQ driver input, which 
is already defined in the block diagram, open the function group Alarm System and click the 
Alarm Generator button shown here. Position the alarm block below the packet block Pack and 
connect the green and black packet bus to the data input E on the alarm generator block. 
Double-click the alarm generator to open the dialog box where you define alarms and change 
the default settings.
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Then click the Alarm Table button in the same function group and position this alarm block to 
the right of the alarm generator. Connect output A on the alarm generator to input E in the alarm 
table. DIAdem connects the two alarm blocks with a blue and black alarm bus.

Select DIAdem VISUAL to position the display instrument for the alarm table in the DIAdem 
VISUAL workspace. Click Start Display on the toolbar to display the alarms. As soon as the 
measured values exceed the limit specified in the alarm generator, the alarm table shows an 
alarm with a time stamp and a description, in each row. As soon as the limit is no longer 
exceeded, DIAdem deletes the alarm from the alarm table. 

Note You should match the block size of the data packets you want to monitor, with 
the acquisition rate. If the block is substantially larger than the acquisition rate in 
Hertz, the alarm generator waits a long time for the data packet that is to be 
monitored. If, on the other hand, the block size is much smaller than the acquisition 
rate, the alarm generator has to monitor many small data packets. 

Specifying Alarm Attributes
In the alarm generator you specify the alarm attributes to define alarms. DIAdem differentiates 
between static and dynamic attributes as shown in the figure. You specify static attributes when 
you configure the alarm system. DIAdem determines the dynamic attributes during runtime. 
Static attributes are, for example, the name and number of the channel that is to be monitored, 
or the limit, the delay, or the comment. Dynamic attributes are the time stamp, the current 
measured value, or the alarm status. DIAdem manages the five attributes alarm group, alarm 
type, priority, quit level, and alarm status for all blocks, so that alarms can be filtered with these 
global parameters, and colors and graphics can be assigned to the alarms for visualization.
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Figure 6-2.  Static and Dynamic Attributes Describe Alarms

If a limit value is exceeded, DIAdem combines the attributes to a formatted data packet, the 
alarm, and transports this data packet in alarm buses to the alarm table and to the alarm/text 
convertor.

During a measurement, you can confirm alarms that occur in the alarm table, for example, if it 
was a false alarm or if the cause of the alarm was rectified during the measurement. DIAdem 
then changes the alarm status. For this purpose, you connect output A on the alarm table in the 
block diagram to input T on the alarm generator. You must also click the Display button in the 
alarm table dialog box and enable the Display button for alarm confirmation checkbox.

Creating Protocols
To record the alarms in a file or to send them in an e-mail, DIAdem must convert the alarms into 
text. To do this, use the alarm block Alarm–>Text and connect this block to the alarm bus. In 
the dialog box of the alarm/text convertor, you select the alarm attributes that you want DIAdem 
to forward to the subsequent protocol blocks on the text bus. DIAdem creates a format string that 
consists of the appropriate variables, which are indicated by the @ characters, and text.
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The following format string records for each alarm the time stamp, the alarm counter, the name, 
the measured value that caused the alarm, the alarm type, the limit, and the current alarm status:

@PKALTIMESTAMP@ @PKALCOUNTER@ @PKALNAME@ 

(@PKALVALUE@ @PKALTYPE@: @PKALREFVALUE@)—@PKALSTATE@ 

You can record alarms in three ways. To display the text for each alarm immediately on the 
screen, use the Dynamic Text Display shown in the following figure. To save the text for later 
inspection, use the Logfile. To send an e-mail with the alarm details, use the Text Output 
Outlook.

Figure 6-3.  Visualization with Alarm Table, Text Display, and Buttons for Confirming Alarms

Setting Up User Management
With the alarms system you can confirm limit overshoots in the alarm table. The system 
administrator provides the necessary rights in user accounts in the user management system, so 
that only authorized users can confirm alarms. DIAdem saves the user accounts in an encrypted 
file with the filename extension .adm and saves the access rights with the block diagram. Each 
time a measurement starts, DIAdem checks whether the user that is logged on has the rights 
required to confirm the alarms.

To set up or modify user accounts or user rights, select Settings»Alarm System»User 
Management. To log on as the administrator, you must first enter the user name 
administrator and the password diadem. You can enter the text in uppercase or lowercase 
because DIAdem is not case-sensitive here.

To change the standard password, click Password. To open the user management, click 
Register. In the user management you create new user accounts, change access data of user 
accounts, and grant or revoke rights. Click Save to create a new ADM file. Click OK to save the 
settings in the current ADM file and to close the user management. Select Settings»Alarm 
System»User Log On/Log Off to log off.
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Alarm System Functions
The function group Alarm System includes all the functions you need to define, generate, 
display, and record alarms and to send alarms as e-mails.

Use the Alarm Generator to define alarms and to monitor data packets for limit overshoots. Use 
the Alarm Table to display or to confirm alarms output by the alarm generator. Use the alarm 
block Log User On/Off to allow the users registered in the user management to log on and off 
during measurements. 

The alarm block Alarm–>Text outputs selected alarm attributes via text buses, which the alarm 
block Dynamic Text Display displays on the screen and which the alarm block Logfile saves 
in a text file. Use the alarm block Text Input to enter comments from the keyboard during 
measurements, and to display the comments in a separate window in DIAdem VISUAL. If you 
display the button for confirming the text input, this alarm block displays the comment on the 
text bus.

Use the Text Multiplexer to combine the alarm texts from the converter with the comments, and 
to forward them in alternating order to the subsequent alarm blocks, on a text bus. Use the Alarm 
Multiplexer to combine alarms from various alarm buses. Alarm blocks can process only data 
packets from an alarm bus or a text bus.

Use the block Text Output Outlook to send alarm text as e-mails with Microsoft Outlook. For 
DIAdem to establish an OLE connection to MS Outlook, you must install MS Outlook and set 
it up as an active e-mail program. Use the block Text Output DDE to transfer alarm texts via 
the DDE (Dynamic Data Exchange) interface with fax software, e-mail software, or paging 
software, or to archive the packets in a database. You enter the DDE server as the recipient of 
the alarm texts.

Use the alarm blocks Alarm Server and Alarm Client to exchange alarms, and the alarm blocks 
Text Server and Text Client to exchange alarm texts between DIAdem installations on one 
network. 
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7
The Basics of Process Measuring 
and Control Technology with 
DIAdem

For computer-based data acquisition of measured signals you need to be aware of the 
phenomena involved in a measurement chain, so that you can choose and set the individual 
components correctly in order to minimize or avoid errors. This chapter gives you a brief outline 
of the basics of process measuring and control technology, and describes the measurement 
modes and sampling rates that are available in DIAdem.

Computer-Based Signal Acquisition
The following figure shows the basic processes involved in the acquisition of temperature 
measurement values with DIAdem DAC. The top display solves the task with a data acquisition 
measurement plugin and the bottom display solves the task with an external measurement device 
connected to the computer via a digital interface such as GPIB or USB. 

Figure 7-1.  Temperature Measurement Using a Plug-In Board or an Interface

For measured value acquisition, sensors first convert the physical quantities, which are to be 
measured, into voltage or current. This creates, for example, a temperature-related voltage at a 
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thermocouple. The sensor signals are then transferred to a measurement amplifier and converted 
into numeric values for the computer, using an A/D convertor. The A/D convertor converts the 
continuous, analog signal into measured values that are time-discrete and amplitude-discrete. 
DIAdem can reconvert the measured values into the original physical quantities or save the 
values for later offline analyses.

Communication with Measurement Hardware
DIAdem DAC communicates with the measurement hardware via the DIAdem drivers, which 
are available for many different kinds of measurement hardware. If no driver is available for a 
specific measurement hardware, you can use a DLL-based driver interface to create and 
implement the driver for DIAdem yourself.

In most cases, DIAdem automatically provides the capabilities of the supported hardware when 
you load the device driver. You only need to specify the settings in the configuration dialog box 
to specify the base settings for the measurement hardware. 

Refer to Chapter 2, Installing Measurement Hardware and Communicating via Interfaces for 
more information on how to register measurement hardware in DIAdem or how to access 
external devices via interfaces.

Parameters for A/D Conversion
The following sections provide a rough overview of the most important factors which impact the 
digitalized signals.

Measurement mode
If a measurement system is unilaterally grounded, all inputs are connected to one grounding 
point, which means single ended. Use this system for voltages <1 Volt, for short signal cables 
(<4 m), and if all the input channels are grounded, at the same point. 

In all other cases, use a differential measurement system, where each input has its own reference 
potential. A differential system basically has two important advantages compared to a 
single-ended system: ground circuits cannot cause measurement errors, and most disturbances 
that affect both measurement cables of a signal are suppressed. On the other hand, unilaterally 
grounded systems have twice as many measurement channels.

Resolution
An analog signal is digitized into a discrete signal. The amplitude of the signal is represented in 
discrete steps, which results in a digitization error called the quantization error.

The number of bits the A/D convertor uses determines the number of steps the analog signal is 
digitized with. The resolution is better, the quantization errors decline, and the smallest 
measurable change decreases in relation to the increase in numbers of steps. A 3-bit A/D 
convertor, for example, divides its input voltage range into 23 = 8 stages. A binary or digital code 
between 000 and 111 represents the eight subsections.
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The following figure shows a 5 kHz sine oscillation digitized by a 3-bit A/D convertor. The 
digital signal does not adequately represent the original signal, because the convertor does not 
have enough digital subsections. If you increase the resolution to 16 bits, to increase the number 
of subsections in the A/D convertor from 8 (23) to 65536 (216), you achieve a precise 
representation of the analog signal.

Figure 7-2.  Resolution of a 3-Bit and a 16-Bit A/D Convertor

Measurement Range and Gain
The measurement range refers to the minimum and the maximum analog signal levels that the 
A/D converter can digitize. Many devices have selectable measurement ranges (usually from 
0 to 10 Volt or from –10 to 10 Volt), so you can adjust the range of the A/D convertor to the 
signal range. This makes optimal use of the available resolution for an exact signal 
measurement.

In the following figure, the 3-bit A/D convertor in the left diagram (1) has 8 digital subsections 
in the measurement range from 0 to 10 Volt. However, if you select the measurement range 
–10 to 10 Volt, as shown in diagram (2), the same A/D convertor divides the 20 V measurement 
range into eight subsections. The lowest measurable voltage change increases from 1.25 to 
2.5 Volts, which means the right diagram displays the signal considerably less precisely. 

Figure 7-3.  How the Measurement Range Affects Precision: 
(1) 0 to 10 Volt, (2) –10 to 10 Volt
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The amplification factor includes all amplifications and attenuation that affect a signal before the 
signal is digitized. If you adjust the amplification factor to the signal level, you make the best 
use of the resolution of an A/D convertor. Therefore, it is just as important to set the correct 
amplification as it is to set the right measurement range.

Sampling Rate
We have shown that digital signals have discrete steps to display the amplitudes, and we have 
described how to minimize the resulting quantization errors. However, we have not taken into 
account the fact that after A/D conversion, the signal is no longer continuous along the time axis. 
This is due to the fact that the signal is sampled only at specific times, and the samples are stored 
as numbers. Random sampling never gives an exact representation of the data.

The more frequent the samples, the more precisely you can reconstruct the original analog signal 
as a series of digital numeric values. However, this greatly increases the required sampling rate, 
especially for high-frequency signals, which in turn results in increasingly large amounts of data 
per unit of time.

This correlation results in the following requirement: you need a sampling rate that meets the 
requirements with as few samples as possible.

According to the Nyquist theory, the sampling rate should be at least twice as high as the highest 
frequency in the signal. The digitized signal then contains enough information to resolve, for 
example, the frequencies of the acquired signal after a transformation to the frequency domain 
(FFT). However, as shown in the following figure, this does not in any way provide an exact 
reconstruction of the signal profile. Neither the exact signal form nor the amplitude heights can 
be reconstructed for all points in time.

Figure 7-4.  How a Low Sampling Rate Affects Data Acquisition
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As this figure shows, a multiple of the Nyquist frequency is necessary if you want to display the 
correct shape of the signal as well as the frequency.

Anti-Aliasing Filter
If the sampling rate is lower than the sampling rate determined according to the Nyquist theory, 
an effect called Aliasing occurs. This effect causes digitized signal forms or signal frequency 
parts that are essentially different from the actual analog signal (alias frequencies). The data 
generated by undersampling display frequency contents that are substantially lower than the 
original signal, as shown in two examples in the following figure.

Figure 7-5.  Aliasing Effects Caused by Undersampling a Signal

You cannot distinguish between these apparent signal sections of the digitized signal and the real 
signal frequencies. Therefore, you cannot correct errors caused by aliasing.

If you cannot attain the sampling frequency that is required to measure a signal, or if the highest 
frequency in the signal is unknown, you must filter the analog signal with lowpass filters 
(anti-aliasing filters) before the A/D conversion. Alternatively, you can increase the sampling 
frequency by using other measurement hardware or a different type of measurement.

According to the Nyquist criterion, an appropriate lowpass filter must only let through signals 
that have frequencies lower than half the sampling rate used for the A/D conversion. In this case, 
filters that have very steep slopes are most suitable. 

Note Do not confuse anti-aliasing filters with digital filters on the digital side after 
the A/D convertor.
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Unwanted noise distorts the analog signal before the signal is converted into a digital signal. 
You can limit external influences by using suitable signal conditioning such as filtering and 
amplification before digitization. Another way to reduce noise distortion is to oversample the 
signal, which means using a higher sampling rate for the data acquisition and then averaging the 
digitized values.

Computer-Based Signal Output
With the right hardware, DIAdem can output acquired data, generated data, and calculated data, 
as voltage or current. You can use analog or digital outputs to control processes with DIAdem, 
or to create closed loops with control blocks.

The following figure shows the signal output for temperature control. DIAdem converts the 
actuating variable, which is determined by comparing the room temperature and the set point, 
into the manipulated variable for the heating valve. DIAdem transfers a numeric value to the 
D/A convertor, on a plug-in board for example, which outputs the proportional voltage. A power 
stage transfers the voltage to the heating valve. Assuming the set temperature is 20 °C, the 
heating valve opens wider and releases more hot water into the heating system. 

Figure 7-6.  Temperature Control with a Plug-In Board

Measurement Acquisition with Interrupts
The computer has interrupt mechanisms for reacting to events such as keyboard entries. These 
mechanisms prevent constant keyboard entry requests. If a relevant event occurs, the computer 
processor receives an interrupt request. The processor then interrupts its current program and 
processes the function associated with the event. DIAdem uses this mechanism to acquire data, 
to execute calculations, and to output set values at the clock times set by the user, and 
undisturbed by other programs.

Because the processor first has to save the status of the current program when an interrupt 
request arrives, there is a delay between the arrival of an interrupt and the interrupt actually being 
processed. This delay is called latency time. For periodic processes, such as data acquisition and 
open and closed loop control, each sampling step has a different latency time, because the 
latency time depends on the current status of the processor when the interrupt occurs: A 
measurement that is executed with 100 Hertz over a period of 1 second, results in 100 different 
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values for the latency time. The difference between the minimum latency time and the maximum 
latency time is called the jitter. The jitter thus indicates the degree of the periodicity of the clock 
times.

What jitter level is acceptable depends on the particular task at hand. In visualization tasks, 
tests have shown that delays of up to 100 Milliseconds are not actually perceived as delays. 
Therefore, it is acceptable for an alarm light to respond with a delay of up to 100 Milliseconds 
after the time the alarm occurs. On the other hand, the periods between the output times have to 
be precise in digital closed loop control. The output time is the time when the D/A convertor is 
accessed to output the manipulated variable. If the controller output is to be made with 
1 Kilohertz and the periodicity error of the output time is less than 5%, the maximum valid jitter 
is 100 Microseconds. 

Different DIAdem Measurement Modes
DIAdem differentiates between the measurement types software clock and hardware clock 
which you select in the system clock block. DIAdem and Windows generate the rate for the 
software clock and the measurement hardware generates the rate for the hardware clock. 
DIAdem supports the measurement modes HighSpeed measurement, DMA measurement, and 
Disk measurement, for earlier measurement hardware. DIAdem offers the hardware clock to 
execute these tasks on modern measurement hardware.

The standard DIAdem clock is the software clock, which fully supports the entire range of 
DIAdem functions. In the Software Clock measurement mode, the DAC kernel controls the 
complete measurement procedure. You can use the software clock in Windows timing, Multicore 
timing, or soft timing. Specifies that DIAdem automatically sets the best possible timing for the 
computer hardware and the measurement hardware. To specify the timing in DIAdem DAC, 
select Settings»Single Point Processing»Measurement Parameters»Timer. If you select soft 
timing or multicore timing, you can execute only one measurement. If you select Windows 
timing, you can execute several measurements. 

When DIAdem measures with several system clocks, DIAdem uses in the software clock the 
lowest common multiple of the single sampling rates as the total sampling rate. If the total 
sampling rate is too high, DIAdem tries to adjust the single sampling rates. If the DAC kernel 
cannot find a solution for the computer and the measurement hardware used, DIAdem aborts the 
measurement preparations.

In the Hardware clock mode, the measurement hardware generates the clock and the DAC 
kernel controls the measurement. This measurement mode supports the entire range of DIAdem 
functions with a few limitations, which include not being able to output signals in the hardware 
clock.
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Chapter 7 The Basics of Process Measuring and Control Technology with DIAdem

Software Clock with Windows Timing
If you set software clock with Windows timing, DIAdem uses the computer multimedia timer 
for the clock rate. In this measurement mode you can process analog and digital signals and 
execute measurements with nearly every hardware and a number of different devices. The 
Windows timing allows channel sampling rates of up to 1 kilohertz and latency times of a few 
milliseconds. 

You can use Windows timing to execute measurements with different sampling rates 
simultaneously on one measurement hardware. DIAdem requests the measurement values from 
the hardware at a clock rate that Windows generates. DIAdem processes the measured values, 
displays the results, and outputs signals. Other programs might require the operating system and 
prevent an accurate clock rate. The deviations can be in the millisecond range. You can reduce 
these deviations if you do not execute other processes on the computer at the same time.

For most process measurement and control tasks, Windows timing is completely adequate for 
clock rate generation, which is why most hardware drivers support only this type of timing. For 
time-critical processes that require more precise reaction times, you must use Software clock 
with Multicore timing or soft timing.

Software Clock with Windows Timing
If DIAdem runs in the software clock mode together with Multicore timing, DIAdem uses a 
processor exclusively and with top priority to generate the base clock. DIAdem uses this base 
clock to process the measurements defined in the block diagram, on other processors. Multicore 
timing achieves sampling rates above 1 kilohertz and better latency times than Windows timing. 
If the computer is suitable, Windows timing drivers support also Multicore timing. Multicore 
timing under Windows 7 and Windows Vista provides the best timing in the software clock.

Multicore timing is neither available on computers with only one processor nor on computers 
with a logical duplication, for example, with the Hyper-Threading technology from Intel.

Software Clock with Soft Timing
In Software clock with Soft timing, the DAC kernel uses real hardware interrupts to control the 
clock rate. Measurements in Soft timing maintain the clock rate much more accurately than 
measurements in Windows timing. A measurement with soft timing supports all the DIAdem 
functions that are also available in Windows timing. Ask your hardware manufacturer whether 
your measurement hardware driver supports this type of timing.

Soft timing is not available under Windows 7 and Windows Vista. If you use Windows 7 and 
Windows Vista and the performance in Windows timing is not sufficient, you can use a computer 
which supports multicore timing. 

With Soft timing an extremely accurate internal PC timer generates signals, which immediately 
interrupt all Windows functions to run DIAdem measurements and to maintain the clock rate as 
accurately as possible. During this interruption, DIAdem runs only operations that are 
time-critical, to avoid delaying Windows functions for too long. That is why drivers do not use 
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soft timing for hardware access via interfaces that have long reaction times, for example, via the 
serial interface. Screen display or measured data storage are not time-critical processes and are 
executed outside an interruption.

Hardware Clock
In the Hardware clock measurement mode, timers on the measurement hardware generate the 
clock rate. Use the Hardware clock to acquire data at high sampling rates. The maximum clock 
rate nearly always reaches the specified maximum sampling rate of the measurement hardware. 
You can generally only use the Hardware clock with analog inputs, because digital inputs 
usually work with no clock rate on the hardware and thereby do not support the hardware clock.

The Hardware clock achieves very high sampling rates. During the measurement preparations, 
DIAdem transfers the specified sampling rate and the channel list to the measurement hardware 
and then starts the measurement. The measured data first goes into the measurement hardware 
buffer. The data is read from this buffer at regular intervals and forwarded to DIAdem. Data 
output has first priority, because the device buffer is limited. DIAdem buffers the data again if 
the data is not processed immediately. This computer buffer can expand to several Megabytes 
for very fast measurements. 

The Hardware clock delivers data that is acquired at a guaranteed high-speed sampling rate. 
However, processing is always slightly delayed, because the data can never be read from the 
buffer in real time. In many applications, it is irrelevant whether data is displayed or saved a few 
milliseconds slower, as long as the end-result and the time reference are correct. However, if 
immediate reactions are required during the measurement, the delay can lead to unacceptable 
results. 

Because digital signals cannot be recorded in the Hardware clock, the signals must be measured 
parallel in the Software clock. This can lead to delays, because the timers on the computer and 
the measurement hardware cannot be synchronized at the start of or during the measurement. 
Because two timers never start at exactly the same time and never run at exactly the same speed, 
the times in the time channels are not exactly the same after a measurement. The deviation 
usually amounts to a few milliseconds. 



© National Instruments Ireland Resources Limited | A-1

A
Executing Measurements 
Automatically

You use scripts to automate recurring work sequences such as starting a measurement and then 
evaluating the saved measurement values. You create scripts in the script editor in DIAdem 
SCRIPT. 

Use the panel-specific object commands and variables to access the blocks of a block diagram 
in a script. DAC blocks are the central DAC objects; subobjects are signal connections at DAC 
blocks and subblock diagrams and labelling of display and manual input instruments. How you 
access objects in DIAdem DAC is not typical for VBS. You must first open the main object and 
then the subobject, make your changes, and then close the objects in the reverse order. 

Use the SchemeLoad command to load a block diagram. Use the commands DACObjOpen and 
DACObjClose to configure a DAC block. In the DACObjOpen command you enter the object 
name to open this object and to then change the object properties. The following script loads the 
Example.dac block diagram and the BlPinSigCountSet command sets the number of 
terminals at the signal input of the Bars DAC block to 21.

Call SchemeDel()

Call SchemeLoad("Example")

Call DACObjOpen("Bars")

Call DACObjOpen("Display data")

Call BlPinSigCountSet(21)

Call DACObjClose("Display data")

Call DACObjClose("Bars")

To add the object access to the script double-click the block to open the dialog box and press 
<Ctrl-Shift-A>. Switch to DIAdem SCRIPT and press <Ctrl-V> to paste the contents of the 
clipboard into the script. The script editor displays the commands with the object names and the 
variable assignments from the dialog box that was open.

To open a DAC object, you need the name of the object. If you select a block of the block 
diagram on the screen, DIAdem displays the name of the DAC block in the status bar. When you 
click a block terminal, DIAdem displays the name of the main DAC object and the name of the 
DAC subobject, separated by a point, in the status bar.
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B
Technical Support and 
Professional Services

Log in to your National Instruments ni.com User Profile to get personalized access to your 
services. Visit the following sections of ni.com for technical support and professional services:

• Support—Technical support at ni.com/support includes the following resources:

– Self-Help Technical Resources—For answers and solutions, visit ni.com/
support for software drivers and updates, a searchable KnowledgeBase, product 
manuals, step-by-step troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. Registered users also 
receive access to the NI Discussion Forums at ni.com/forums. NI Applications 
Engineers make sure every question submitted online receives an answer.

– Standard Service Program Membership—This program entitles members to direct 
access to NI Applications Engineers via phone and email for one-to-one technical 
support, as well as exclusive access to eLearning training modules at ni.com/
elearning. All customers automatically receive a one-year membership in the 
Standard Service Program (SSP) with the purchase of most software products and 
bundles including NI Developer Suite. NI also offers flexible extended contract 
options that guarantee your SSP benefits are available without interruption for as long 
as you need them. Visit ni.com/ssp for more information.

For information about other technical support options in your area, visit ni.com/
services, or contact your local office at ni.com/contact. 

• Training and Certification—Visit ni.com/training for training and certification 
program information. You can also register for instructor-led, hands-on courses at locations 
around the world.

• System Integration—If you have time constraints, limited in-house technical resources, or 
other project challenges, National Instruments Alliance Partner members can help. To learn 
more, call your local NI office or visit ni.com/alliance.

You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support phone numbers, email 
addresses, and current events.
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